function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Matthew Holliday 4Matthew Holliday 4 

Unable to save apex classes

I receive the following error when trying to save any of the classes in my developer console: "DEPLOYMENT ERROR: An unexpected error has occurred. 891009581-41899 (749494588) for deploymentId=1drK0000000qbfFIAQ If this persists, please contact customer support."

I've tried closing the developer console and re-opening it. As of writing, I've tried saving for roughly an hour with no luck. 
Matthew Holliday 4Matthew Holliday 4
Additional information: It appears that the same error occurs when trying to deploy out of any of our sandbox accounts. 
Muthuraj TMuthuraj T
Can you post your code. It helps to debug. 
Chandra Sekhar CH N VChandra Sekhar CH N V
have you tried re-creating the? delet and create the clas again?
Muthuraj TMuthuraj T

Copy the Deployment ID in your clipboard, and head to:


Click on the Delete button to delete the deployment record, and everything should be back to normal.
Rufus RodenRufus Roden
The error report is called by Salesforce a Gack (  It's basically Salesforce saying 'something went wrong'.  You should log a support case quoting the gack number and let them give you more information.  That said ... I'd suggest going to the Apex Classes page (YOURNAME / Setup / App Setup / Develope / Apex Classes) and click on the "Compile all classes".  Any errors produced may send your towards a particular classes that is messed up (because of refactoring or such) and that need to be fixed first before any other classes are saved.
Can you try to re-create the same class in Apex Classes online editor instead of Developer Console. If that also bring no luck then raise a case with salesforce.