function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Jeanne BuschJeanne Busch 

MIME type of the selected file is not allowed

I'm trying to do the data import wizard exercise ( and I'm getting the above error when I choose the file Trailhead tells me to download.  I went searching in the forums for an answer to this and tried the one suggestion -- copying to a notepad app and re-importing into excel.  It didn't work.  The other "suggestion" is to change browsers.  I don't find this an acceptable alternative.  In addition to the time and hassle it will take to shut everything down and fire it all back up in another browser, I don't have appropriate security set up on IE and I don't trust Chrome at all.  I also can't ask my users to do that every time they want to import. 

I've already been using the DataLoader and, where possible, DemandTools to import data.  I thought this would be a chance to learn how the Import Wizard works.  But all this exercise tells me is what other folks have told me before -- the Import Wizard is a pain and they don't use it. 

I don't expect the Trailhead forum to fix this, but I am about to load the required data using DataLoader.  I hope the Challenge doesn't care how I loaded it.  I will report back.  But in the meantime if anyone has any useful suggestions, please chime in.  Thanks.
Jeanne BuschJeanne Busch
So FYI, you can complete the challenge using the Data Loader.  Apparently Trailhead doesn't care.  Yay!
I'm having the same problem, and I tried using Data Loader but it keeps telling me that I've entered a wrong password for Salesforce.
You'll need to get a security token to log in using Data Loader.  Click on your name, choose My Settings, expand the Personal menu, then click on "Reset My Security Token".  It will email you the token for your developer edition account, and once you append that to your password, you'll be able to complete it.
Vasant HorapetiVasant Horapeti
I am not sure why the CSV file has to be MIME type. It looks like there no other way to complete that challenge as even switching to Chrome didn't work for me. I used Data Loader to complete the challenge.
Gotthard SzaboGotthard Szabo
I just renamed the file to c, and it worked.
Kimberly LeeKimberly Lee
I used Save As to convert the Excel data document into a CSV and then it worked