function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Admin User 3137Admin User 3137 

Error during Trailhead tutorial: Build a Lightning component with Design System

I am using a Mydomain enabled dev org on gs0 (Winter 16) and going throught the exercise in Trailhead. 

Follwed every step and when i click on Preview it takes me to my app (looks right) -

But it errors out with -

Lightning components require My Domain. Please contact your system administrator for more information.

Any idea what I might be missing? My org is defenitely provisioned with MyDomin.
debasis jena 35debasis jena 35
HI Admin User,

I think you didnt Deploy domain to the user. please go to the setup-->Domain management -->my domain, check your domain is not deployed to tehiser. you will find one button called as "Deploy to users". please clcik that button and then your lightning app will run.

Please mark as answer if it helps you,

Maryna KozakMaryna Kozak
Hi there,
I have created a domain (setup-->Domain management -->my domain) but before clicling "Deploy to users" I have to login. There is a line Your domain name is available for testing and Login button. When I click Login, the error page appears. 
Can anybody tell me why is that?
Ashish DeoAshish Deo
Thanks Jena. It works for me.. Superb:)
James LoghryJames Loghry
Just wanted to pipe in and say thanks Jena, this solved my lightning component / my domain issue too.  Kudos!
debasis jena 35debasis jena 35
If my answer solves your problem please mark it as best that anyone can refer to that easily.
Ruwantha  LankathilakaRuwantha Lankathilaka

debasis jena 35 answer works for me
mani rethinammani rethinam
thank u very much u
Lightning components started working after enabled My Domain, activate Domain and Deployed to users.
Swaraj Behera 7Swaraj Behera 7
Go to  setup-->Domain management -->my domain .Then register there.It will take some 5 min to register and domain ready for testing will take another 5 mins to complete.Then you can able to Preview your application.

Activate Domain and Deployed to users

Chitranjan ChetkarChitranjan Chetkar
Dear friend,
 I have received the same error. This can be solved by below action:
 please go to the setup-->Domain management -->my domain, check your domain is not deployed to the user. you will find one button called as "Deploy to users". please clcik that button and then, got to the developer console and click preview. Boom! your lightning app will run.

Gary SabinGary Sabin
Much obliged...
Sangeetha TSangeetha T

Whenever I click preview on the lightning app it takes me to the login page and  after typing the username and pwd again it redirects to the same page. However im not able to vie wmy application 

Please help me out 

Sangeetha T 
Thanks Jena..
Krish Sana11Krish Sana11
Thanks Jena, i couldn't find domain management in set up, but doing a global search for "My domain" lead me to the page referred above, where i was able to choose a domain and get that registered. My app works fine now. 

Thank you!!
Vinod Gaikwad 27Vinod Gaikwad 27
Thanks Jena
Andrew SchellAndrew Schell
This is what I love about salesforce, a huge community who all work together to find a solution. This seems to have solved my issue, found this via google error search.
Mosh HamedaniMosh Hamedani
Our web scraping Service provides high-quality structured data to improve business outcomes and enable intelligent decision making,Our Web scraping service allows you to scrape data from any websites and transfer web pages into an easy-to-use format such as Excel, CSV, JSON and many others.