+ Start a Discussion
Sean MacLeanSean MacLean 

Dataloader is not working for Sandbox

I have followed all the directions, like this:  

https://help.salesforce.com/apex/HTViewSolution?id=000004931&language=en_US
https://developer.salesforce.com/forums/?id=906F00000008kFmIAI

... you get my point.  

When I change the Server Host to https://test.salesforce.com then go to the OAuth sign in and click sandbox I get the following error message:  error=redirect_uri_mismatch&error_description=redirect_uri%20must%20match%20configuration

Therefore I tried the "Password Authentication" and put in my username/password (it still says https://test.salesforce.com in the Salesforce Login URL:)  

Thoughts? I've tried googling this issue and haven't seen anyone else encounter it.  If it means anything when I go back into settings, it will say "https://login.salesforce.com" if I do the exact process I outlined before.

Thanks - Sean
 
Best Answer chosen by Sean MacLean
3 Creeks3 Creeks
I have never used the OAuth method to use dataloader, but for the password authentication, did you use your sandbox user name and append your sandbox user's security token to the end of the password?

All Answers

3 Creeks3 Creeks
I have never used the OAuth method to use dataloader, but for the password authentication, did you use your sandbox user name and append your sandbox user's security token to the end of the password?
This was selected as the best answer
Sean MacLeanSean MacLean
3 Creeks - I want to give you a high-5.  I totally didn't know we neded the security token!

Thank you!