function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Users can't see report

Hey Guys,

Please helpe me. I am stuck, non of the users can see report. They can see the report folder but when they try to access report they get insufficient privilage error. Infact they can't even access unifed folder reports. Which is visible to all users. I am not sure why this is happening. I gave all these permissions but still they cant see: 

1) Manage Reports in Public Folders
2) Manage Dashboards in Public Folders
3) View Reports in Public Folders
4) View Dashboards in Public Folders
5)Create Report Folders
6) Create Dashboard Folders
7) Edit My Reports
8) Edit My Dashboards

Please let me know if I am missing something. Thanks.
Rupali PophaliyaRupali Pophaliya
Hi Rajiv,

The reason behind this error could be due to a number of circumstances (Organization-Wide Defaults, Field-Level Security, Profile, and User permissions), all outlined below. 
  • Check that your Report Type is in "deployed" status. 
  • ​Even though you think you have access to the Report Folder, it's a good practice to double check that the access has not changed for some reason.
  • You don't have 'read' access to one of the objects that the report references.​​
  • ​If the report is an Administrative report (reports on Users, Reports or Documents) you require the "View Setup and Configuration" permission on your profile.
  • Check the Field Level Security of the Lookup or Master-Detail Relationship field to ensure that your Profile has visibility to that field.  Without visibility into that specific field, you will not have the ability to view the relationship that it contains and thus not able to run the report.
    • Note: You'll need to check the Field Level Security for every field that is on your report and in the object you are referring to.​
  • ​Profile permission "Report Builder" is not available on the affected User's Profile.
  • If the report is built on multiple objects, this error can occur if the Lookup Field between two of the Objects is hidden from you by Field Level Security.
  • If the Report Type used to create the report is 'Opportunities with Products,' and the affected user does not have at least 'Read' access to the Price Book object.
  • This same error may be encountered by users within Customer Portals/Communities and Partner Portals/Communities. This will occur if the Organization Wide Default sharing for the Object(s) being reported upon is not set as Private. If further access should be granted to the remainder of your Organization, Sharing Rules can be defined. ​
    • Note: This error may also occur if the object used in a report type is part of a managed package that contains a visualforce page. 
Hope this helps.
Dushyant SonwarDushyant Sonwar
Hi Rajiv,

Did you check with the object "Enable Reports" permission?
Enable Reports on Object
May be that could be the issue.
I just ran into this issue and went through thie entire list and fields in all of the objects and none of that made a difference. and then i noticed the hierarchy of the report was set to a low level employee rather than a few levels higher. changed that and suddenly results. I wasted like 3 hours on this
krishna chaitanya 35krishna chaitanya 35
Hi Rupali Pophaliya,
The suggestion provided by you is helpful for me.Beacuse i have faced the same issue and assigned the permissions and it got solved.
Laura Panait 4Laura Panait 4
Came across this issue, where an user would not see a report, nothing below the filters on top, just a blue blank screen.
All the users in her team would see it, they all had same settins, no difference, she could see all other reports just not this.
In the end I have cloned that report and saved it under the same folder and it worked.
Weird one but at least this solution did the trick.
Tausif Shaikh 19Tausif Shaikh 19
Thanks Rupali Pophaliya. The answer is really helpful
sundar s 24sundar s 24
in my case the object dont have viewall permission and it fixed my issue
Sven BordihnSven Bordihn
I had a similar issue like Laura Panait 4 but the difference was, that the user was able to open the report and see data when he opens it from the folder but got only a blue screen when he tried to open it from the dashboard. So I cloned the dashboard, saved it in the same folder an voilà - it worked. Thanks Laura! 
Sara Rivka PincusSara Rivka Pincus
I had a similar issue that was caused by the user's profile not having access to the Lead object (although the report was Contacts and Accounts.)
Priscilla PestoffPriscilla Pestoff
Compare the report Ids in the URLs: report clicked from the report folder vs the report clicked from the dashboard. When the dashboard is created while the report is in a private folder, then the report gets moved to a different folder, the dashboard report may not be pointing to the one you think it is.