+ Start a Discussion
Soumya BeheraSoumya Behera 

Not able to see Choose Files Connect: Google Drive

Hi All,
Greets for the day.
Need your help for the below .
I am trying to create an external data source to connect with the Google Drive. However i am not able to get the Type as : Files Connect: Google Drive  .  Although i have already enable the file connecton setting.
Please do let me know how this option will be available in the dropdown list.

NOTE :- I am following the below salesforce provided link ( http://help.salesforce.com/HTViewHelpDoc?id=admin_files_connect_google_xds.htm ).

Please do let me know if  you guys have any suggestion.

Soumya Behera

Soumya BeheraSoumya Behera
The other way of question is Files Connect: Google Drive option is not coming when we are creating an external data source . Please do let me know the reason ? Do i need to enable anyting in the org ?
Soumya BeheraSoumya Behera
The on-premises permission is available with a paid permission set license, “Files Connect for on-premises external data sources.” To enable the license for your organization, see these brief instructions in Salesforce Help.
Is it needed , than only we will be able to see the option . Only whose are having liences ?

Shashank Singh 20Shashank Singh 20
Just in case, someone else faces this issue: If you do not see an option that should have been there, while setting up an external data source - rest assured that you have not setup the permission set correctly.

In case of on-premise files connect, one would need to:

1. Purchase the relevant license and have the license assigned to one's user.
2. Assign the Files connect on-premise permission to the permission set that one is using (also, make sure that one's user is assigned to the permission set).
3. Specifically for on-premise files connect also have the API Enabled permission in the permission set.

Once you have the settings mentioned above, you should be able to see the different option in the drop-down while setting up an external data source for on-premise files connect.

For any online files connect setup, you would need to assign the files connect cloud permission and add the user to that particular permission set and you would be good to go!

Hope that helps!
Piyush Sinha 43Piyush Sinha 43
Make sure you have permission "Files connect cloud" on your user record via permission sets or on your profile.

Juan LizarraldeJuan Lizarralde
We followed the instructions and got the Permission set in place with the Files Connect checked and assigned to the only user. We got Files Connect: Quip showing up but not the other types. Files Connect is in fact showing up which means it's enabled and the permission set is correct, still only 1 type , Quip, is coming up. How can we get the other Types to come up? Google Drive, Sharepoint, One Drive and Box? Are this types not supported any more?
Juan LizarraldeJuan Lizarralde
Salesforce is now hiding them for some customers in Professional Edition is what they said. Hopefully they get the documentation updated explaining that users who miss the options other than Quip, after enabling the 'Files Connect' permission, need to open a Case with Salesforce support to get them enabled, it means Box, Google Drive, Sharepoint and One Drive documentation must be updated.