+ Start a Discussion
Ben MyhreBen Myhre 

How to make Global Action appear in SF1 Developer Intermediate > Visualforce Mobile >Implementing Global Actions with Visualforce Pages

  1. I created a visual force page and then enabled it for mobile apps. I verified that this exists and is enabled.
  2. Build> Create> Global Action I added a new Global Action, action type "Custom Visualforce" and label "Quick Account" This is saved
  3. Create > Global Action > Publisher Layout. There is only one. I override the default for SF one and added "Quick Account" for sf1 experience and saved
  4. The action does not show up at all on sf 1. I logged out and back in several times. Am I missing a step?
pconpcon
Have you tried editing the default Global Layout (instead of creating a new one) and place the action in the "Salesforce1 and Lightning Experience Actions" section, save and then reload SF1?  If you have, can you please take a screenshot of the visualforce page's option (showing the "available for mobile apps" setting), the new global action and the edit screen of the global publisher layout with the action added.
Rafael Ortiz 15Rafael Ortiz 15
Hi, I have the same problem, here the screenshots:

User-added imageUser-added image
Suzi Simmons 30Suzi Simmons 30
I have the same issue, can't get past it.  My code and screenshots are identical.
Suzi Simmons 30Suzi Simmons 30
And here is the screenshot of the global editor
User-added image
pconpcon
This works as expected for me under the simulator following the same steps you have. How are you view this in SF1?

User-added image
Suzi Simmons 30Suzi Simmons 30
It doesn't show up in SF1 at all.  I have verified that I am the same user, and the domain is the same on my desktop and SF1.  I have logged out and back in multiple times.
Can you see it on your actual mobile device, or only the simulator.  (Grasping at straws, here)
Suzi Simmons 30Suzi Simmons 30
(Thanks for responding, by the way!!)