+ Start a Discussion
John StaalJohn Staal 

proces builder

TrailHead - Automating Processes with the Lightning Process Builder - error

Hope that someone can help me here. I wanted to finish my challenge of this traihead.

Created the proces with the following conditions:
User-added image

With the following actions:
User-added image
And got the following eror when I checked the challenge:
User-added image
 What did I do wrong?
Jayson Faderanga 14Jayson Faderanga 14
Hello John,
Your Process Builder is firing on Contacts and your criteria is field from Accounts. You're referencing a null object on a foreign entity.
To fix it, create a new version of your process builder and add this to your criteria(diamond block), Account not equal global constant null, please add that on the beginning of your criteria. That should fix it.
John StaalJohn Staal
Hello Jayson,

Thanks for the very quick reply but here is what I have done:
User-added image

And the result is the same ... 

I do follow your logic, but this proces is activated when the account shipping address is changed, so the pointer to account can not be NULL, I would think. Where did I take a wrong turn?

Best regards, John

Jayson Faderanga 14Jayson Faderanga 14
Hi John,

I see, I'm sorry for my previous post, I definitely didn't get it right. (sorry for my suggestion).

do you have any active validation rule? or any flow that isn't active that is firing when you edit the account? (even if the flow is not active, when the user who does the DML is a system admin, the flow will still run)

We can start a gotomeeting session so I can help you troubleshoot.,..just let me know..send me an email jayson.faderanga@gmail.com

Amit Chaudhary 8Amit Chaudhary 8
Please check below post with screen shot. and compare your process builder

Please let us know if this will help you
John StaalJohn Staal
Jayson, Amit,

Thanks for your support, I have finally solved it.

Did the condition and action parts in the same order. That was not enough initially. I basically biuild the proces from scratch up, starting with one field, save and test. Then adding the second etc. That worked.

Thanks guys!