function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Ian Carswell 13Ian Carswell 13 

Error logging into Salesforce org with custom URL from IDE

I am getting the following error from Eclipse (Kepler) when trying to login to our Production org which uses a custom url:
Unable to fetch organization details for  [myusername]

Element {}returnFieldDataTypes invalid at this location

I have no problems accessing the Org via the dataloader using the same credentials.
Daniel BallingerDaniel Ballinger
According to Eclipse IDE - Why is the possibility to specify a hostname provided? ( you can use the "Other(Specify)" option to specify a Hostname that matches your custom url. E.g.

Ian Carswell 13Ian Carswell 13
Dan -  I am already using the "Other(Specify)" to specify the hostname "" (our custom domain). :-(
Daniel BallingerDaniel Ballinger

Do you get any messages in the Salesforce Login History? If something shows up it would atleast indicate that the API request is reaching Salesforce. It would probably also indicate problems with missing security tokens or untrusted IP addresses.

Can you access any other orgs with Eclipse? Maybe a free dev org? That would help isolate the issue to either the Eclipse setup or the org in question.

Ian Carswell 13Ian Carswell 13
I am getting the same error for any org (Production/Sandbox/Developer) that I try to access. So it might be something to do with the Eclipse configuration?
Skippy MillerSkippy Miller
I am having the exact same problem.  It is only in a Production/Developer edition.  I have tried Kepler, Luna and Mars versions of Eclipse. I have no problem with the data loader nor is there a problem with Mavensmate.  I would like to solve this as well.
Daniel BallingerDaniel Ballinger
I see they just put out a new release of the IDE for Spring '16. Maybe that includes some bug fixes that would help out? Other than that, may try raising an issue in Github?
Nick ChenNick Chen
The IDE has been updated to use the latest version of the API, i.e., v36 (Spring '16). The issue stems from the fact that the version X of the IDE is always forwards compatible (you can use it on version X+1 of the instance) but not backwards compatible when connecting.

As of today, Jan 14,, most (but, not all) of the sandbox instances have been updated to v36. *None* of the production instances have been updated yet.

If you are trying to connect to an organization that is still on the old version of the API, you will see that error.

I've tried connecting to my cs23 instance (v36) and I am able to connect fine.

I tried connecting to my na15 instance (v35) and I see the error above.
Nick ChenNick Chen
User-added image

If you are still trying to use it on an older, v35 instance, then you can select to install v35 (as shown in the screenshot above).
If you have already installed v36, you need to uninstall it first.
Peter HitchmoughPeter Hitchmough
I had the same problem using a new Developer Edition account today (Jan 31, 2016) but using v35 of the IDE resolved it. Thanks, Nick Chen.
I updated my question to point to this post.