+ Start a Discussion
Jason StengrenJason Stengren 

Trailhead: Developer Beginner > Define Sharing Rules issue

Hi all,

I'm trying to complete the challenge for this module but the new "priority" field isn't appearing as an option in the drop-down criteria options... I'm only seeing the stock fields. I've looked at field-level security and even enabled "edit" for everything that was disabled, no dice.
Isidore Jose 5Isidore Jose 5
Please follow the steps again. It's working. I just validated

The custom object must be named 'Project' with a resulting API name of 'Project__c'.
The Name field for 'Project' must be of type Text (not Auto-Number).
The custom object 'Project' must have a custom field of type picklist named 'Priority' with a resulting API name of 'Priority__c'.
The role label should be 'Training Coordinator' with the resulting 'Role Name' of 'Training_Coordinator'. Note that you may already have this role in your role hierarchy from a previously attempted challenge.
The sharing rule can be named anything.
The organization-wide defaults for Project cannot be set to 'Public Read/Write'.
Jason StengrenJason Stengren
Those are the exact steps listed in the challenge. Nothing new here. I followed all of those, then went into sharing rules for the Project object and tried to set up a Project sharing rule based on custom criteria. Then, in the "select which records to be shared" section (3) I'm supposed to pick Priority from the field drop-down (I assume)... but it's not there.
Jason StengrenJason Stengren
"Create a custom picklist field on the Project object called “Priority” with the following values: High, Medium, and Low. Then create a criteria-based Sharing Rule for Project records where the Priority = High to share those records with the Training Coordinator role."
Jason StengrenJason Stengren
User-added image
Isidore Jose 5Isidore Jose 5
Hi Jason,

I'm not sure what other configuration you have in your Org. I can confirm that the steps provided in Trailshead works and I can see the Priority in the pick list.User-added image
Isidore Jose 5Isidore Jose 5
Please create another filed with a differnt name and try
Jason StengrenJason Stengren
Got it! I created a Test field (text), set all options to Visible (select all) and it appeared in Sharing criteria. Went back and deleted both the Test and old Priority fields, then created a new Priority field again setting all to Visible and it showed up. Thanks for your help.
Isidore Jose 5Isidore Jose 5
Great !!
Brian ChristiansenBrian Christiansen
Mine wasnt working until I changed the Priority=High Sharing rule to Read OnlyImage of read only flag
Shivam Mishra 4Shivam Mishra 4
I cannot complete the challenge.
Can you guys tell me what is wrong??

User-added image

User-added image