function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Romi MadiaRomi Madia 

Salesforce for Outlook .net frameworks error

I have seen a few people post issues with Salesforce for Outlook and when instaling getting the >net frameworks error.  Mine says I have the .net 4.5.2, but when I try to uncheck it, it won't let me.

I also tried looking for an install and uninstall option and that didn't work either. 

Help, I am a director and since I purchased a new PC (my last PC did have windows 10 on it, but it was upgraded from XP), my new one came with Win 10, I can not get it to install

Daniel BallingerDaniel Ballinger
Windows 10 should already have the .NET Framework 4.6 installed. This provides the functionalty that .NET 4.5.2 did. [Source (]

Do you have the latest version of Salesforce for Outlook? The Winter '16 release notes say it is compatible with Windows 10 (
German Ayala 8German Ayala 8
The exe file installs the 4.5.2 version of .NET. I had to uninstall 4.6.2 and install this older version. Not sure if this is possible on Windows 10, I have 7.

I believe this was caused by them trying to fix the installation. Before you needed to have .NET 4.6 and up and you couldn't install the plugin if you had an older version. I believe when they tried to fix this they forgot to include newer versions of .NET as acceptable.

Can this be fixed Salesforce? Thanks 
lalit kumar 11lalit kumar 11
Same issue. Constantly getting this error. "NET Framework 4.5.2 or a later update is already installed on this computer."  Please resolve.
Jonathan CulleyJonathan Culley
Mathieu MaesMathieu Maes
Had the same issue. Mine is a Windows 10 64-bit installation, so I added that info to my search and came up with this page:

Just download the 32-bit or 64-bit version depending on your Outlook version (like before with the standard MSI) install and you should be up and running again.
Jared GreenJared Green
I have a problem with Salesforce and Outlook Sync: When I click on the account button to save an email this little window comes up:

This page has an error. You might just need to refresh it. Action failed: clients:msMailContainerFlex$controller$navigateToSObject [Unspecified error.] Failing descriptor: {clients:msMailContainerFlex$controller$navigateToSObject