+ Start a Discussion
Namina P VNamina P V 

eclipse does not allow creating apex class

Hi All,

I am using eclipse for force.com project.

Also I am a beginner. I have created one project with my developer edition details. But when I tried to create new class (right click--> new->force.com->apex class), it shows an error that 'Unable to check Apex class Permisions-- invaild username, password, security token,, or user locked out'. Why its showing like this. 

Please help me out.
Thanks in advance.

SandhyaSandhya (Salesforce Developers) 
Hi Namina,
I suggest you consider below points.

If you don't see "Force.com Project" under "New" menu, then your Eclipse might be missing Force.com add-on. I guess that this is what your issue is.


Please follow the instruction below to install IDE with Force.com add-on





You could also get this error message if the password or token used by your project is no longer valid


To update your project connection, please goto

Right mouse click project folder => Force.com => Project properties => Force.com


Invalid username, password, security token; or user locked out - 
This error indicates a problem with the credentials inbuild.properties:
Username — Verify that your username is correct on this account. When connecting to a sandbox instance, your sandbox name is appended to your username. For example, if your production username is foo@salesforce.com, and one of your sandboxes is called bar, then your sandbox username is foo@salesforce.com.bar.

Password — Verify that your password is correct for this account. Note that you security token is appended to the end of your password.
Security token — The security token is a 25-digit string appended to your password. To reset your security token, go to the Reset My Security Token page in your personal settings.

Locked out — If you unsuccessfully attempt to log into an organization too many times, you may be temporarily locked out. The number of times you may fail to connect, and the lockout duration depends on your organization settings. Either contact your administrator to have the lock removed, or wait until the lockout period expires.

Connection mismatch between sandbox and production — If all of your connection credentials inbuild.properties are correct, you may have a URL mismatch. The server URL is different for sandbox and production environments. In build.Properties, the sf.serverurl value for production ishttps://login.salesforce.com. For sandbox environments, the value is https://test.salesforce.com.

Hope this helps you!

Thanks and Regards
Namina P VNamina P V

Hi Sandhya,
Thanks for your support.
Actually,, I have another problem with my newly installed Eclipse.

It is showing 'Setup check error'. Do you have any Idea about that??

Namina P VNamina P V

I have gone through the solution you have given. But Here, I dont use a sandbox, I am using my developer edition. My username and passwords and security token all I have give,. Also as you said I tried to append security token at the end of password, but it shows a wrong password. And also my force.com property box does not remember my password and security token.

What do you think about it?

SandhyaSandhya (Salesforce Developers) 
Hi Namina,

Try generating new security token from your personal setting and also please refer below the video.

Thanks and Regards

Namina P VNamina P V
Hi Sandhya,,

I have tried generating security token.. The thing is that, my account is having no issue with login. Because it is working in other PCs. 

I think problem is with my eclipse. Or can that be the problem with JDK?? I am not getting. 3 versions of eclipse I have tried. But that showing the same problem, with setup check error also.. Can you tell me, what wil be the issue regarding?