function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Shield Custom Field encryption


According to below link, I can (select) encrypt custom field if it falls in to any mentioned category below.
  • Email
  • Phone
  • Text
  • Text Area
  • Text Area (Long)
  • URL
  • Date
  • Date/Time

Here what I cannot understand is, I have created a text custom field in the Account standard object, but it does not showing in the Field List of the "Platform Encryption" page. What I'm doing wrong here?
Trail Head 33Trail Head 33
Hi ,

have you enabled this option below ;
Mark as best Answer if your problem solves.

Thanks ,
yeah it is already enabled. Also I'm logged in as System Administrator. But no luck yet.
You've probably already figured it out by now, but I thought I would leave this here because this question is still unanswered.  The field list on the "Platform Encryption" page is only for Standard fields on Standard objects.  To encrypt custom fields, you need to go through the normal object configuration screens and edit the field.  Once platform encryption is enabled, you'll see a new checkbox for platform encryption on each field that can be encrypted.
Antara Saha 11Antara Saha 11
After selecting the checkbox, the data in the custom field is not being shown as masked...what should I do to show it as masked.The view encrypted data permission is disabled already.
Since the Spring '17 release data is no longer shown as masked.  If you have the permission to see the data, you'll see it unmasked.  If you don't have the permission to see the data, you won't see it at all (even masked).  The data at rest is encrypted, though.
Miguel PuigGarciaMiguel PuigGarcia
The only way to see If the fields are encrypted (From Spring 17 release). Is to Encrypt the field, and remove the tenant key