+ Start a Discussion
Ben DannattBen Dannatt 

Process Automation: Automate sets of Delayed Actions With Workflow

Having a nightmare with the above section in the Process Automation module - Confident I've completed things correctly but I keep getting the same message when checking the challenge "The 'Case Escalate on High Priority' Workflow rule was not found. Either it was not created, not associated with Case, or not activated" 

Any help here? I've activated the rule and it all looks good from my side *scratching head* 
Best Answer chosen by Ben Dannatt
Adam OlshanskyAdam Olshansky
Hmm could be some other weirdness going on (domain enabled, namespaced org, another process interfering, etc). Would you be able to recreate it in a new dev org? A little inconvenient but should solve the problem.

All Answers

Hi Dannatt,
one of the requirements in the challenge is...
"The workflow rule must evaluate on create and when it doesn't meet the criteria but is edited to meet the criteria."

The current rule will be evaluated when the record is "created and every time it's edited".
Please change it to the "created, and any time it's edited to subsequently meet criteria" and try to check the challenge.

NOTE in the challenge as that "in real-time projects a time-trigger action need to be created for this scenario but for trailhead, immediate actions is to be created". I successfully completed the challenge with immediate actions.
Verify if immediate actions works...!!!

Ben DannattBen Dannatt
Thanks for the advice Nirdesh, I'll give it a go and lt you know!

Thanks again
Ben DannattBen Dannatt
Hi Nirdesh, just carried out the steps you advised and still no luck!? really unsure why it wont work here, I've even checked against online resources and filled everything as per step by step, I'll keep trying different things until something finally works!
Adam OlshanskyAdam Olshansky
Hey Ben, can you post a screenshot of the Workflow Rule detail page and confirm these parts are all true?

Rule Name: Case Escalate on High Priority
Object: Case
Evaluation Criteria: Evaluate the rule when a record is created, and any time it's edited to subsequently meet criteria
Rule Criteria: (Case: Status NOT EQUAL TO Closed) AND (Case: Priority EQUALS High)
Ben DannattBen Dannatt
Hey Adam, 

Thanks for reaching out - screenshot added below - any help is greatly appreciated!! 
 User-added image

Adam OlshanskyAdam Olshansky
Can you confirm that the workflow rule is active and works when you manually test it?
Ben DannattBen Dannatt
Hi Adam, Yes the workflow is active and does work when testing, completely confused on this one Sent from myMail for iOS
Adam OlshanskyAdam Olshansky
Hmm could be some other weirdness going on (domain enabled, namespaced org, another process interfering, etc). Would you be able to recreate it in a new dev org? A little inconvenient but should solve the problem.
This was selected as the best answer
Ben DannattBen Dannatt
I'll give that a go and let you know how I get on, thanks for taking out so much time to help, really appreciate it!
Karen Churchill 12Karen Churchill 12
I know this is quite a bit after you requested help. I was having the same error message. I activated the workflow rule (it made me choose a default workflow user) and then the challenge was accepted. 
James McCrearyJames McCreary

I needed to activate the workflow as well. Additionally, my criteria were different than some:

Case: Closed Equals False
Case: Priority Equals High

Let me know if those two fields let you pass the challenge, otherwise I can troubleshoot with you further.



Preeti Shukla 13Preeti Shukla 13
I am also stuck on this trailhead :
Super badge : Lightning experience specialist.
Process Automation : Create a workflow rule that will update a field.
 Create a workflow rule that will set the escalated flag and send a task to the case owner if a case is not closed and its priority is set to High.

Its working fine when i am actually testing the same but when trying to check the challenge.  It is giving following issue :
Challenge Not yet complete... here's what's wrong: 
Case escalation failed to execute correctly.

Could you please help? Is anyone got the answer
Adam OlshanskyAdam Olshansky
Hi Preeti, when checking the challenge, leave the Dev Console open and check the logs to see if you get a more detailed error message that may direct you to the answer
Jess BurghJess Burgh
Hey all. I went through all the steps and finally came to this screen. User-added image
After activating the rule I went to check the challenge and got this message.
User-added image

What am I doing wrong? Feedback would be appreciated! Thanks!!
Adam OlshanskyAdam Olshansky
Looks like there's a typo in your rule name. "Esculate" instead of "Escalate". Try changing it and see if that helps
Lisa SouletLisa Soulet
I am having similar problems.  I have been working on this for hours now and keep getting this message:

User-added imageI have double checked all syntax and the workflow rule actually works in my org, SF just doesn't recognize.  Any suggestions?
Preeti Shukla 13Preeti Shukla 13
Hi Everyone,

I am able to solve the same.  I am using "My Trailhead Playground" default one now.  Try in some other org.  Attaching screenshot for your reference.  If it will solve your problem.
Workflow rule detail
Task detail :
User-added image
Field update detail :
User-added image
Let me know if you need any thing else.  Previously when i was checking the same rule in another org in developer console it is giving me error that the rule is not getting called as required.

Thanks & Regards,
Nick BroekemaNick Broekema

Had the same problem and tried on and on on all all my different already used dev.org's and trailhead playgrounds, that was exactly the problem.

Opened a new trailhead playground and it worked straight away! Really annoying and lost at least an hour figuring out what I did wrong in the process, please save yourself some time and open a new and fresg trailhead playground! 

Lisa SouletLisa Soulet
I had a lot of the exact same problems and errors that are listed above.  I followed the advice of starting over in a new dev org.  I was still getting the error message:  "The Case Escalate on High Priority workflow rule was not found.  I just happened to be looking at my workflow rule page and notice that I had spelled "High" incorrectly.  Instead of "High" mine read "HIgh".  Small mistake, but once I fixed the spelling the challenge was accepted.  My two cents would be to make sure your spelling matches exactly the spelling asked for in the challenge.  Starting over in a fresh org was helpful advice too.