function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Maggie LongshoreMaggie Longshore 

Unable to run newly written (Summer 16) test in developer console

I wrote a simple test class today in a sandbox.
When I attempt to run it from the developer console by itself using
Test->New Run
it fails and the results look like 
image of test failure from developer console

If I run the same test in a new run with pre-existing tests it runs fine.
The test also runs correctly from the Apex Test Execution Window.  I tried this on 2 sandboxes with same result.

The test only calls a method in 1 class that I wrote today.

is this related to the new release? Could be related to the known issue with opening classes in the dev console I am unable to open a class from the console - although I do not get the same error as reported in the known issue.

It is running fine at my sandbox with latest release. Please try again. 

Sandeep Singhal
Maggie LongshoreMaggie Longshore
I tried it again and it still fails

To reproduce

1 Go to setup->develop->apex classes
2. Hit 'New' button
3. paste in :
private class Hello
    static void logHello()
        system.Debug('hello, World');

4. hit 'Save'
5. open developer console
6. Test->New run, select 'Hello' and add the test
7. hit 'Run'

expected result is test should run and test tab should have a green checkmark and there would be a log file on log tab

what I see is
red x like I state above and no log file

If I add any existing test to the test run it succeeds.
Works fine for me too.
I would suggest resetting all of your test results and trying again.