function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Carlos HernandoCarlos Hernando 

Receiving thousands of user_info logs


For a couple of days I've been receiving this kind of line in my debug logs. I guess this is realated to the new API version (v37.0). 
I would n't care about this if didn't receive thousands of lines like this one in all my traces. 

17:02:42.238 (238882742)|USER_INFO|[EXTERNAL]Salesforce user id| username| GMT time

My debugs levels are: 

Database               INFO
Workflow                INFO
Validation               INFO
Callouts                 INFO
Apex Code            INFO
Apex Profiling        DEBUG
Visualforce            NONE
System                 NONE

I'm having the same problem.  Debug logs in our sandbox are near useless now.  It's so difficult to find which lines have actually been hit.  Often the logs only show what's happened in the constructor followed by thousands of lines of USER_INFO garbage and nothing else.  Don't know what they've done but debug logging has got worse with each of the last two or three updates
Similar issue here.  Have seen huge file size on load files.  Seem to work fine on VF pages and Controllers but when I an debugging a controller on a VF component we get this large logs filled with USER_INFO.
Avinash NelluriAvinash Nelluri
Facing this issue since many weeks. I tried to log a case with Salesforce but as it is a Development related question, I'm being redirected tothis discussion forum :(
Same issue here... This is very inconvenient. Has anyone discovered workaround?
Carlos HernandoCarlos Hernando
Hola everyone,

I've been told this issue will we solved en the 204 release

We will have to life with this for a while 

Avinash NelluriAvinash Nelluri
Found the soultion. Follow the steps listed in the below link to get rid of this nonsense.
Avinash, thanks! This is a good info. I followed the instruction but I still get those lines... :( I really hope those lines will go away soon.
Avinash NelluriAvinash Nelluri
naocaom, can you repeat those steps a couple of times? Make sure you check the tooling api. It is working for everyone else :)
Did that 5 times, still not working. After going through those steps, the record in "User Trace Flags" table in "Debug Logs" under Setup are cleared up though....
Doesn't work for me either.  The USER_INFO lines come back straight away