function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Kalashree Borgaonkar 5Kalashree Borgaonkar 5 

Problem posting snapshot of dashboard on chatter feed.

This is the trailhead challenge I'm working on.
Create a report of Opportunities grouped by Type. Then follow the dashboard and share a snapshot on Chatter.
Name the report 'Opportunities by Type' and save it to the 'Unfiled Public Reports' folder.
The report must be of type Opportunities.
The report format must be a Summary report.
The report must be grouped by 'Type'.
The date range should be for All Time.
You can include any columns you like, but must include 'Amount' as one of the columns.
Create a dashboard named 'Opportunities Dashboard' and save it to the 'My Personal Dashboards' folder.
Create a dashboard component on the dashboard using the report you just created.
Set the header to 'Opptys by Type' and the title to 'For all time' for the dashboard component.
Use the horizontal bar chart dashboard component, and ensure the record count is displayed on the x-axis.
Follow the 'Opportunities Dashboard' dashboard in Chatter. Make sure that Feed Tracking is enabled for Dashboards first.
Post a snapshot of the 'Opptys by Type' dashboard component to Dashboard Chatter feed.

But I'm getting the following error when I check if the challenge has been completed
Challenge Not yet complete... here's what's wrong: 
The dashboard snapshot post to Chatter was not found.
Can someone hepl me?
If possible post the snapshots?
Daniel GoldblattDaniel Goldblatt
Did you ever figure this out? I am getting same error. My problem is when i hover over a dashboard I'm not getting the "Post snapshot to chatter feed" like it says I should be getting. I went in and enabled the Dashboard Component Snapshots checkbox as well. 
George VazquezGeorge Vazquez

Hey guys, you need to go into Setup -> Chatter -> Feed tracking.


Click on Dashboard and enable feed tracking for all 5 check boxes. Then, go back to your Dashboard and hover over it, there should be a drop down where you can not snapshot to Chatter Feed.

Jennifer JordonJennifer Jordon
Uhggg why is that working for everybody else but me ? When I hover it just says, "click to go to full report" ??? HELP!
Jennifer JordonJennifer Jordon
Nevermind George Vazquez was right, but it should be specified that you have to click eack individual section and then turn on feed tracking for each section not just on the main page. Thanks George!
Samuel StevensSamuel Stevens
I'm having the same problem with just getting "click to go to full report". 
Jennifer or George - can you explain further what you mean "it should be specified that you have to click eack individual section and then turn on feed tracking for each section not just on the main page." 
Samuel StevensSamuel Stevens
I figured it out now - I didn't have feed tracking turned on for dashboards. Pretty confusing though!
mahesh p 20mahesh p 20
Please follow the path 

Setup -> Customize -> Feed tracking -> select Dashboard in the list 

then Click each individual check box and turn on the feed tracking option by clicking the check box .
User-added image
Sekhar Oleti 6Sekhar Oleti 6
Tank you @George Vazquez 
It worked for me after enabling all in settings
"Click on Dashboard and enable feed tracking for all 5 check boxes."
Chloe NigroChloe Nigro
I am now having the same problem, but have enable feed tracking. 
Can anyone share insight on this?
Evan SpringerEvan Springer
I enabled feed tracking on the Dashboard and Reports but you do then have to be in Classic mode in order for the hover button to show up. It wasn't working in Lightning.
Clayton BurkleClayton Burkle
This is not working for me either despite having all tracking fields enabled.
Justin Ruiz 1Justin Ruiz 1
@Clayton Burkle I'm Having the same issue. Seems a lot of trailheads are having issues since their last release. 
Steve Rubin, Certified Sr. ProjectSteve Rubin, Certified Sr. Project
Thanks all. The screen shots helped me. It's too bad that the instructions on the Trailhead weren't as precise. Very frustrating. 
Andrew MontemayorAndrew Montemayor
Evan Springer had the answer for me. Once I switched to Classic, I was able to see the hover button and complete the challenge. Thanks Evan!
Josh StigallJosh Stigall
This is, at least, the second challenge in this Trailhead that requires classic to be validated. Would be helpful to add that in the description.
Therese DodgeTherese Dodge
My problem is the same as everyone else but when i try to go to classic i get an error message. Bah!
1. First Enable feed tracking for 5 fields for Dashboard
2. Switch to salesforce classic
3. Click on down arrow on report
4.User-added image
5. Click on Post Snapshot to Dashboard Feed
6. User-added image
7. Click on Check Challange
Abhilash DaslalAbhilash Daslal
George Vazquez thank you so much.I was racking my brain over it
Amber EvansAmber Evans
Tapeshwar, you saved my sanity with your very first step. 
Fraser RackhamFraser Rackham
In case anyone else is also still having issues with this, the screenshots above plus:
- make sure that posting snapshot from the dashboard (at the bottom) and not reposting your failed previous shares.
Tom Curran (901)Tom Curran (901)
I have got virtually everything here working in Lightning with one important exception - when I click on the Share Component button from within a Report within a Dashboard, or when I click the same button from the Dashboard itself, I can see a Chatter feed, yet have no ability to actually Post to Chatter there.  This, even though I can post to Chatter elsewhere in my org.  Any suggestions?
Bhuvanesh MohankumarBhuvanesh Mohankumar
This Challenge works only with Salesforce Classic version
User-added image
Post using the First option in the drop down,

User-added image
Andrew Bishop 6Andrew Bishop 6
If anyone is still having an issue with this, and you started the process in Lightning... what you need to do is delete the old report/dashboard and follow ALL of the steps in Salesforce Classic.
Krishna Prasad 56Krishna Prasad 56
Thank you @Mahesh P 20 and all
Matt FaranoMatt Farano
Finally got this to work when I switched to Classic and followed the steps. Phew! 
Jeevanprakash C MJeevanprakash C M
It worked only if I switched to Classic In Lightning it didnt work
Fahri KivancFahri Kivanc
Unfortunately, this snapshot action does not work in Lightning. So, if you want to pass that unit in Trailhead, you have to switch to Classic version. You should also enable feed tracking options for dashboard in the setup.
Roc TorioRoc Torio
It didn't specify on the steps to enable feeds on the 'Dashboard'. Do that and your off!
Sue Go 9Sue Go 9
I followed all suggestions posted here:
1. I enable the Feed Tracking
2. I check on all 5 fields in Dashboard
3. I am in classic view
4. I posted snapshot to Dashboard Feed
5. I can see the feed in Chatter
I still get the error message. What am I missing here?
Eric TechoEric Techo
I'm with Sue Go 9.  What can we try next?
Eric TechoEric Techo
Your instructions worked.  Thx.
Nitika Semwal 11Nitika Semwal 11
I am also facing similar issue, the dashboard is posted on chatter but Trailhead challenge says "The dashboard snapshot post to chatter was not found". What I am missing?  #Trailhead Issue.

User-added imageUser-added image
Tom FloydTom Floyd
@Nitika, you have to change Salesforce back to Salesforce Classic, and then go to the Dashboard and use the drop down shown on the trailhead module to post it to Chatter. This doesn't work in Salesforce Lightning.
Nitika Semwal 11Nitika Semwal 11
@Tom Floyd, I did in Classic too but same issue. The Chatter is showing the post but the trailhead says

Challenge Not yet complete... here's what's wrong: 
The dashboard snapshot post to Chatter was not found.
Harika AchantaHarika Achanta
I am also facing the same issue like @nitika
Harika AchantaHarika Achanta
I followed instructions of Sue and it worked for me 
Bhuvanesh MohankumarBhuvanesh Mohankumar
This Challenge works only with Salesforce Classic version
See my comments & screenshot posted earlier, it worked for me.
Drew Peterson 11Drew Peterson 11
For anyone still experiencing this issue, you have to build the dashboard and add (and name) the component in classic [in addition to all the other feed tracking, etc.]. Lightning doesn't allow you to name the component, it just grabs the report name. I went around and around on this until I noticed my snapshot said untitled component. Trailhead apparently looks for the component name. Good luck
Tim McManamonTim McManamon
After reading all of this, I thought I would try starting over to make sure I build the report and dashboard in Classic.  But when I try to create new reports, I'm unable to save the reports because the names are still in the cache.  Rats.
Wow! After breaking my head re-doing every step, finally Evan Springer's solution worked!
Change over to Classic and the hover-mode shows up magically
Josh KlabundeJosh Klabunde
For anyone who has switched to classic in order to post the snapshot heed this advice: Using a report or dashboard made in lightning will fail this trailhead. You must start in Classic, and then create the report, dashboard, and component (with title) in classic before you post the snapshot in order to pass this trailhead.
Salomé PouwSalomé Pouw
I worked on this assignment in Classic from the beginning but I still get the error message... Anyone any idea what I can do? Followed all the steps that were mentioned earlier
makarand gajaremakarand gajare
type ' feed tracking' in search box and enble all the three boxes for dashboard.
Howard LubingerHoward Lubinger
Anyone figure this out?
1) Enabled Field Tracking for both Dashboards and Reports and selected all the fields
2) Followed the dashboard
3) Enabled Dashboard Component Snapshots in Reports and Dashboards

What am I missing??
Pavel Basu ChoudhuryPavel Basu Choudhury
User-added image

1) Enable Field Tracking for Reports and Dashboards.
2) You need to follow the dashboard from the dashboard list.
3) You will get the hover button to Post Snapshot to Dashboard Feed.
Howard LubingerHoward Lubinger
Ah.  It has to be done in Classic.  Thank you!
Ionut GavazIonut Gavaz
You need to do 2 things in order to complete this challenge:
1. Go to Setup->Chatter->Feed Tracking and check Enable Feed Tracking
2. Post the snapshot using the Classic interface, not the Lightning version. 

Hope it helps.


follow the 2 steps to To view Post Snapshot to Dashboard Feed/Post Snapshot to User or Group Feed option under the Dashboard.

1) Enable Dashboard Component Snapshots checkbox under Setup -> Reports & Dashboards -> Report and Dashboard User Interface Settings
2) Enable the Feed Tracking for the Dashboard
Refer -

Thanks & Regards,
Sakthivel Madesh

Jessica ManvellJessica Manvell
This took way too long to troubleshoot. Followed the suggestions here but still wasn't passing. Finally I switched to Lightning to view the chatter feed and checked the challenge again, and this time it worked. Not sure why you'd have to do that when the challenge itself needs to be done in Classic...
Doug MobleyDoug Mobley
I also struggled with this. But I had to switch to classic in order to see the drop down arrow along the perimeter of the component allowing you to post. I could not do it in Lighting. 
Jason AdkinsJason Adkins
Even in Classic I still seem unable to find the pop up that allow you to post snapshot to dashboard or group feed.  Feel like I am searching for some hidden item with my cursor, driving me crazy.  Any other thoughts?  All I can see is "click to view full report"....
Madhu NuthulaMadhu Nuthula
Worked in SF Classic, as "George Vazquez" mentioned above.
Shashank S 4Shashank S 4
Hi Users,
Kindly, follow the steps as show below: 
1) Setup -> Customize -> Feed tracking -> select Dashboard in the list and
2) Click each individual check box and turn on the feed tracking option by clicking the check box .User-added image
Vishal (ISE) KhokhaVishal (ISE) Khokha
This module works Only in Salesforce 'Classic' view Not in Salesforce 'Lightning' (View profile -> Switch to Salesforce Classic). Also follow the items below.
1. First Enable feed tracking for 5 fields for Dashboard
2. Switch to salesforce classic
3. Click on down arrow on report
Mayur MehtaMayur Mehta
After enabling feed tracking for Dashboard it is working for me.
Pratiksha Jadhav 24Pratiksha Jadhav 24
Please refer to this video, it is really helpful.
yashaswini sathishyashaswini sathish
If anybody doing this in salesforce lightning 
1. create a report in lightning  as mention in the challenge
2. create a dashboard in lightning  as mention in the challenge
3.  setup - > reports and dashboards setting - > Enable Dashboard Component Snapshots -> save
4.setup - > Chatter - > feed tracking -> select dashboard in object -> enable 6 checkbox
User-added image
(do this 1 to 4 steps in lightning)
5. switch to salesforce classic
6. select opportunities dashboard
7. select post snapshot to dashboard feed
User-added image
8. write comment opportunities Dashboard then click ok
User-added image
9.check challenge 

This will definitely work
Priyanka JobyPriyanka Joby
I can see Post Snapshot to Dashboard Feed option and after providing commment clicked OK. But I am getting an error as in the below given screenshot (3rd screenshot). So I couldnot complete the challenge. Can anyone help me?
User-added image
User-added image
User-added image
Thanks & Regards,
Priyanka Joby
Shweta JagtapShweta Jagtap
I am getting the same error if someone has any solution plz help.
Haripada Dey 5Haripada Dey 5
Hi Sweta/Priyanka - I had exactly the same issue as you have mentioned above even afte following all the steps mentioned above. I realized that my playground was copprupted, so I created a new play ground and followed the steps again and it worked for me. I hipe this will also work for you.
Nayana Sebastian 5Nayana Sebastian 5
Switch to classic and try again. That worked for me.
@Priyanka Joby I am getting the same error
Yasser ElmahfoudiYasser Elmahfoudi
For all of those who still having the same problem, I was facing the same issue. All you need to do is to create a new org and do every thing with salesforce classic, BUT you need to switch to lightning in order to add TYPE to the GROUP ROWS and then go back to salesforce classic and complete the task normally.
Don't forget to
1.setup - > reports and dashboards setting - > Enable Dashboard Component Snapshots -> save
2.setup - > Chatter - > feed tracking -> select dashboard in object -> enable 7 checkbox) -> save