function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Petr Částek 3Petr Částek 3 

Debug logs are not being created

when I develop my managed package in dev org I see the logs normally. But my customer installed my package (release) in his org and has some error during running my package. He gave me admin right to his org. I tried to debug my package in his org. The package contains a batchable job that writes leads to db. When I run the package in his org, new batch job appears successfully in apex jobs table in status "processing". After a while status detail contains a brief message with error and number of failures raises. But there are no logs in debug logs page. I setup new User trace flags of type DEVELOPER_LOG as well as USER_DEBUG. But after running the batch again there are still no logs. I also modified the debug level filters but without success. Why there are no logs? Many thanks