+ Start a Discussion
hari azmeera 8hari azmeera 8 

An account owner must be associated with a role to enable portal users or transfer portal users to his or her account. ?

NagendraNagendra (Salesforce Developers) 
Hi Hari,

First and foremost sincerely regret delayed reply.

Customer Portal roles are automatically generated when you enable an account for the CP.  What it's trying to tell you is that the user who is the owner of the account (i.e. the guy who's in the Account Owner field) has no role.  Go to his user record and edit it and give him a role, and your problem will be solved.

First, ensure that the user who is the Account Owner has a role.  Once you've done that, go back to the Account and click Work with Portal -> Enable for Customer Portal.

For additional information check here; Kindly mark this post as solved if the information help's so that it gets removed from the unanswered queue and becomes a proper solution which results in helping others who are really in need of it.

Best Regards,
Padmanabhan KamuniPadmanabhan Kamuni
Hi Nagendra,

I'm facing the same issue. And  your solution is not working. Can you please update the answer. 
Thank you!!