+ Start a Discussion
Dan HewDan Hew 

Shield Platform Encryption trailhead error: The Contact Mobile Phone field does not appear to be encrypted.

I have this field encrypted and there is data in there.

Please advise.
Ajay Anikar H RAjay Anikar H R
Hi Dan,

I had the same error first time, after a retry contact error went off and now Account phone error is coming...The Account Phone field does not appear to be encrypted.

but i have got email with all the required fields as encrypted:
Encryption has been enabled for the following fields:

Account: Phone
Contact: Mobile
Case: Description

Not sure if there is anything wrong with the validation. 
Anil Shivaraj1Anil Shivaraj1
Yes i am facing the issue as well,The Contact Mobile Phone field does not appear to be encrypted. Make sure you have records with data in this field even after encrypting this field and ensuring data
Ajay Anikar H RAjay Anikar H R

As per suggestion over the community - i created a new developer org and tried the same steps which worked fine.


Create a new DE org...
Henry Hai_Henry Hai_
Ensure that the user does NOT have view encrypted data permission.  Also I had to add new data to each of the encrypted fields in order to pass the test.
Prakash  RaiPrakash Rai
Make sure you login to the new DE org before you check the challenge. You might want to logout and log back in to make sure you have right DE org to check the result.
Oscar Alejandro Garcia BenitezOscar Alejandro Garcia Benitez
This problem occurs because you have enabled the portal partner or customer portal so you have to turn them off. creating a new one works because these features are disabled.

Good luck
shyamesh k rshyamesh k r
Hi All,
I have passed this challange. Make sure that you have assigned that permission set to a user and System administrator. Now Go to 
Setup-->User-->click on the user who is a System Aministrator--> under Permission Set Assignments-->click permission set that ypu have assigned recently to the user for this challenge  and uncheck the view Encrypted data for this profile
Hi All,

I have tried in several new DEs as well as Trailhead playgrounds, but still got the same error. 

I think there is a problem in the Development Org. Because I have assigned all different profiles (i.e. Standard User, custom profile) to my user with no permission to see Encrypted Data. But still user can view encrypted field.
If any of you has any update, please let me know.

Many thanks in advance.
Gustavo TandeciarzGustavo Tandeciarz
There's something amiss here.  If I create a new custom encrypted field using classing encryption, that field appears encrypted in the details view, but the mobile phone field is still visible in plain text.

User-added image

And Settings:

User-added image
Jaume JuanosJaume Juanos
I'm facing the same issue too, I've set up a new DE org as suggested and I've enabled the fields stated in the module and the validation fails too...

Challenge Not yet complete... here's what's wrong: 
The Contact Mobile Phone field does not appear to be encrypted. Make sure you have records with data in this field.

I've received the email confirming the encryption activation... Seems a problem on the validation tool

Encryption has been enabled for the following fields:
Account: Phone
Contact: Mobile
Case: Description

Thank You,
Salesforce Developers
Veronica SchmiedeskampVeronica Schmiedeskamp
Hi Faruk, Gustavo, and Jaume. The issue you're having with the Shield Platform Encryption module challenge is a known issue. We've found a solution and are working on the patch. Thanks for your patience!
Dan McGaughey 8Dan McGaughey 8
Thanks Veronica. Will you post back here when the patch is complete?
Veronica SchmiedeskampVeronica Schmiedeskamp
You bet, Dan. I'll post an update once we validate that the patch has gone through.
Thanks Veronica!  I was working on the trail & had the same issue and am relieved to see the update.
Fabrizio ParrellaFabrizio Parrella
Thank you Veronica.  Will wait before completing this challenge.
Hi Vironica,

I have encountered another issue with this trailhead: https://trailhead.salesforce.com/projects/lemonade-stand-workshop/steps/create-reports-and-dashboards. No matter what I do, I am getting this error "Challenge Not yet complete... here's what's wrong: 
The 'Pending Orders by Queue' report does not appear to be grouped by Fulfillment Queue Name and Flavor Name.". 

Could you please help to resolve this trailhead? Many thanks in advance.

P.S. I have checked in the developer forums "https://developer.salesforce.com/forums/ForumsMain?id=9060G000000XdPVQA0". There is a issue has been logged before, which is now marked as resolved. However, I have tried all the options/suggestions that have been suggested, but still getting the same error.  
Veronica SchmiedeskampVeronica Schmiedeskamp
Hi everyone,

We've patched the Shield Platform Encryption Unit 2 hands-on challenge. You should be able to complete the challenge at this point.

Again, thanks for reporting this and for your patience. Happy Trailblazing!
Veronica SchmiedeskampVeronica Schmiedeskamp

Thanks for reporting your issue with the Create Reports and Dashboards unit challenge. I'm not familiar with that unit, but will let someone on our team know about your issue.

Please continue to monitor the Create Reports and Dashboards Challenge - Lemonade Stand Project (https://developer.salesforce.com/forums/ForumsMain?id=9060G000000XdPVQA0) thread for updates.
Still struggling with the same issue.It doesn't seem to be resolved.
Also, @Gustavo were you able to get the encryption at the UI? I am struggling with the exact same issue you listed.
Ang Maria RufinaAng Maria Rufina
@Veronica Schmiedeskamp
Issue persists inspite of the said patch.  Please help.
"The Contact Mobile Phone field does not appear to be encrypted. Make sure you have records with data in this field."
Action taken:
1) New Org
2) Added new Contact with Mobile field populated
Ali Noorani 17Ali Noorani 17
@Veronica Schmiedeskamp (https://dfc-org-production.force.com/forums/ForumsProfile?communityId=09aF00000004HMG&userId=005F0000006gYGH&showHeader=false)
It's been over 3 years and this still looks unresolved. I completed the Unit 2 module successfully, but achieving completion on this unit is misleading b/c the fields don't actually appear encrypted in the UI (and yes, I have the "View Encrypted Data" system permission disabled).​​​​​​

Additionally, I navigated to Encryption Statistics in Setup, gathered statistics for each object, synced each object, updated values in the encrypted fields to test the result. I got the same result, which was that the data I saved on the records were still visible in the UI and nothing appeared to be encrypted.

Please follow up on this as we are trying to test Shield in our sandbox environment (to eventually implement in production) and running into the same issue which is preventing deployment.
Gustavo TandeciarzGustavo Tandeciarz
Shield platform encryption does not mask the data in the UI. PE encrypts the data at rest. Gustavo Tandeciarz
Ali Noorani 17Ali Noorani 17
@Gustavo Tandeciarz, thanks - as soon as I posted that I found this article which states that data masking was decoupled in Spring '17.
Ali Noorani 17Ali Noorani 17
Does anyone know if there's a native feature in Salesforce (excluding Classic Encryption or custom Apex code) that allows masking of data?
Vinay Naidu 4Vinay Naidu 4
This happened with me as well but salesforce sends email with detailed description about the issue, you can view the details and act accordingly. For me i had to enable Chat & Field service lightning in my Dev org and remove the references of phone field in other fields.
Albino Noynay JrAlbino Noynay Jr
The instruction is quite misleading as it states "Admin does NOT have access to encrypted field" which most of us think that we need to set it under field level accessibility. You do NOT need to do that, leave it as is and just make sure that the View Encrypted Field permission under Admin profile is unchecked. That's it and you should pass this challenge!