function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Koushik Saha 10Koushik Saha 10 

Set Up and Manage Shield Platform Encryption

I am not able to complete the che challenge "Set Up and Manage Shield Platform Encryption". Everytime it shows "The Case Description field does not appear to be encrypted. Make sure you have records with data in this field." Although I encrypted the Case description filed. Anyone have any idea how to get rid of it. Please help me. I am stucked in this step for two days.
You need to make sure you have the following
  • Description field set under platform encryption
  • Data in at least a single case's description field
  • Your user does not have the view encrypted data permission
When you goto the case with the description data, you should only see **** in the field.  If you can see data then the check will fail.
Koushik Saha 10Koushik Saha 10
Can you please tell me how to add data in single case's description field and how to disable the view encrpted data permission? Thanks in advance.
To add data to a case, pick one from your Case tab and edit it.  Add anything you want to the field.

Once you've added the data you should see *** in place of your data.  If you see real data then you need to check the following places to make sure they are all unchecked
  • System Administrator Profile and ensure that View Encrypted Data is unchecked
  • Look at all permission sets assigned to your user and make sure all of them have View Encrypted Data unchecked.
Koushik Saha 10Koushik Saha 10
Thank you bos.but still this message is coming "The Case Description field does not appear to be encrypted. Make sure you have records with data in this field.". How to get rid of it. I'm fed up with this. Sorry for the trouble.
Please provide a screenshot of the following:
  1. "View Encrypted Data" checkbox for System Administrator Profile
  2. List of permission sets associated with your user
  3. "View Encrypted Data" checkbox for each of those permission sets
  4. Platform Encryption page.  Setup -> Security Controls -> Platform Encryption
  5. List of Encrypted Fields
John Medeiros 15John Medeiros 15
I am having the same issue: 
It appears that Platform Encryption is not setup correctly in your org.

I have checked the PE fields that are encrypted - done
I have removed all permission sets from my Admin User - done
I have checked the Admin Profile and it does not have View Encrypted Data - Done
Added Accounts, contacts, cases and files / attachments - populated each of the encrypted fields and only see "**********" so it is working.
But I am not able to get past the Error Message.  
I cleared my cache and relogged into Dev Org with PE setup.  

Any steps I am missing?  
  1. Are you doing this in a brand new org?
  2. You may want to leave the key master permission set on your admin user and just ensure that they do not have view encrypted data
Chirag GulatiChirag Gulati
Were you able to get the issue resolved? May be it's a glitch.

I had everything in place but I was facing the same issue. Creating a new case record or editing an existing one worked for me. Give this a try.
Dr. Thomas MillerDr. Thomas Miller
I have the same problem: "It appears that Platform Encryption is not setup correctly in your org."
PE is configured, permissions given to a second user who generated a tenant secret.
Fields are marked as encrypted, as are files and attachments. Visible as **** for the admin.
I had the same error on my Trailhead playground (Org generated from Trailhead) but I was able to fix and complete this trail. The only change I did is to create a permission set named 'Key Manager' with the 'Manage Encrypted Keys' permission and assigned it to my user while removing the same permission on profiles (from the cloned sys admin profile I assigned to another user). Trailhead is probably checking for the permission set.
LeighAnn GrahamLeighAnn Graham
I had the same error message, "The Case Description field does not appear to be encrypted. Make sure you have records with data in this field.", even though I had encrypted the case description. I was able to solve this error by creating a new case and entering anything in the description section. When you save the case, the description will appear as the asteriks. Then check the challenge and it should go through.
Matt NelsonMatt Nelson
I'm also having an issue with this challenge, but for me the trouble is that I don't have 'Manage Encrypted Keys' as an available permission. I set up my dev org after the summer of '15 so Shield Platform Security should be automatically enabled. Am I missing something?
K Ramesh 12K Ramesh 12
Hi ,

Can you check once again that Case Description Field is Encrypted or not Under Platform Encryption.
Security Control --> Platform Encryption --> Edit Field Encryption --> Case Description

After enabling go to  Case object and fill all the case records Description Field.

i hope this will help you to complete your trail head Test.


Before taking challenge need to check setup once again.

Create Permission set Ex:Admin Permission --> go to System Permission --> Check the Manage Encrypted Keys --> Save

Then After Assign this permission set to Users.
Pavlo ShchurPavlo Shchur
Hi Matt, please go through the unit and read carefully. If it didn't help watch this video.
Roland Fuchsberger_Roland Fuchsberger_
I've followed your video, but could get it working. I am always receiving the error

Challenge not yet complete... here's what's wrong:
It appears that Platform Encryption is not setup correctly in your org.

Any ideas? Could it be that this challenge is broken since a recent release?
Steve Martyn 3Steve Martyn 3
Two things, it seems to take a while for encryption to enable, and you will get an email.  Second, make sure to edit records after you enable it, since they will not encrypt the data until the next insert / edit.  It finally validated for me after doing this.
Lauren Rockford 9Lauren Rockford 9
For anyone else facing the "It appears that Platform Encryption is not setup correctly in your org." - i had to redo everything in another org and it passed on the first try.

I had to use one of my existing trailhead playgrounds. For some reason, the new one I created for this challenge would not complete this no matter what actions I took, and since I was having issues creating new trailhead playgrounds, I tried in an older org. Didn't even have to mess with the data, it worked by just setting up the encrypted fields/files.