• Pooja Gupta 54
  • 10 Points
  • Member since 2016

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 3
  • 7
I am trying to import the data according to steps mentioned as-
1. From Setup, enter Import Custom Objects in the Quick Find box, then select Import Custom Objects. 2. Click Start the Import Wizard! The Import Wizard appears. 3. Select Position for the type of record you're importing, and click Next. 4. Choose Yes to prevent duplicate position records from being created as a result of this import. Leave the other options as their defaults. 5. Select None for the record owner field. We didn't include a User field in the CSV file to designate record owners. The Import Wizard assigns you as the owner of all new records. 6. Choose the Hiring Manager lookup relationship field so you can link position records with existing User records in the Recruiting app, and click Next. 7. Click Browse and find C:\recruiting\Positions.csv. Click Next. 8. Use the drop-down lists to specify the Salesforce fields that correspond to the columns in your import file. For your convenience, identically matching labels are automatically selected. Click Next. 9. Click Import Now! 10. Click Finish.

I am doing this in my developer org. 1,2,3 steps are ambiguous but I can atleast get to import wiazrd window but I am unable to follow up with step no.4 as there is no YES option available. Also, there is no click next for point 3 and 6. I am getting really confused. Can anybody tell me whether these options are available in Developer org or not.

Thanks in advance.
after completing the challenge when checking the results the system indicates error. But the value is correct.

The formula evaluates "0" , I tested it twice. With a prior result of -3 (last activity) was 5/1 , today was 5/3 the formula evaluated -3.
Today I retested again. Updated the Activity today , the formula evaluated = 0. The error on screen shows 

Challenge Not yet complete... here's what's wrong: 
The 'Days_Since_Last_Update__c' formula field did not return the correct number of days between an Account’s Last Activity Date and today.

I look forward to your update.

I have an email template (templateId = 'xxxxx') that has custom fields which are part of the email tempalte. 

I have a trigger when when criteria A,b, and c are met, then an email is supposed to be sent. i am trying to use an email template while sending the email, but I am getting the follow error message below. Any thoughts as to what is causing the issue?

First exception on row 0; first error: INVALID_ID_FIELD, WhatId is not available for sending emails to UserIds.:

My email code logic is:
sendTemplatedEmail(Id whatId, Id targetObj, List<String> toAddr, Id templateId) {
        //create new SingleEmailMessage (i.e. eml)
        //setToAddress to toAddr
        //setTemplateId to templateId 
       //setTargetObjectId to targetObject
       //setWhatId to whatId
       //setSaveAsACtivity to false

  • November 03, 2015
  • Like
  • 0

Hello All, I'm having an issue with the Using Formula Field Challenge . I'm using the formula that Vivek provided to a solved question yesterday " TODAY()  -    DATEVALUE(LastModifiedDate) " but its been met with this error below when its been checked by the challenge " 

Challenge not yet complete... here's what's wrong: 
The 'Days_Since_Last_Update__c' formula field did not return the correct number of days between an Account’s Last Activity Date and today

Can anyone assist???
Working on TrailHead Challenge... (https://developer.salesforce.com/trailhead/force_com_introduction/data_security/data_security_sharing_rules)

Tasks completed:
The custom object must be named 'Project' with a resulting API name of 'Project__c'.   Done
The Name field for 'Project' must be of type Text (not Auto-Number).  Done
The custom object 'Project' must have a custom field of type picklist named 'Priority' with a resulting API name of 'Priority__c'. Done
The role label should be 'Training Coordinator' with the resulting 'Role Name' of 'Training_Coordinator'. Note that you may already have this role in your role hierarchy from a previously attempted challenge.   Done
Set the organization wide settings to public read only.    Done

Here is where I think is the problem:
The sharing rule can be named anything.  
Create sharing rule under "Sharing Settings" under Project Sharing Rules..  Create a criteria based project sharing rule with Priority custom field equal to High.  Shared with role "Training Coordinator" as read-only access.

What am I missing?
Hi all, 
I'm a newby in Salesforce so I decided to start learning with the Trailhead. 
I have completed all the challanghes related to the "Getting Started with the Force.com Platform". 
This morning I started with the part 2: "Intro to Visual App Development". 

The fist challenge for Workflow Atuomation is about "Automated Process with Workflow". 
I did the challenge but I receive a failure even if It should seems to run correctly in my Develper Edition Platform. 
Tha error massage received by the check challange button is "Challenge not yet complete... here's what's wrong: Case escalation failed to assign a task to the owner."

I say that all seems to work fine because I edited e case, set up the Priority to High and: 
1) The Escaleted flag was set automatically to true as per the rule action defined
2) I receive a notification about escalation on that case (because I'm the owner of the case as per the task definition field)
3) An activity under the case was automatically created and assigne to me. 

As anyone tha same problem?
Any help would be much appreciated. 
Thank's in advance,

I want to count the number of digits in a phone number to restrict the number to 10 digits or some customized number only. I tried this with Len(text), but could not get it. Do we have any other validation already available for this? please let me know if there is any possibility to use count function for this.

Thsnks in advance.

  • May 25, 2012
  • Like
  • 0