• Praveen Krishna 1
  • 0 Points
  • Member since 2017

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 4
i am using dataloder batch mode.
i have extracted contact adresses and passed them through another proces to clean the addresses. now i want to pass them back to salesforce.

i have my csv
i have a mapping file that works when i run it interactively
i have done my best to create the update bean in the process-conf.xml as ther eis no update exapmle.

when i run the batch update I get the error below for every record in my csv.
Error message:Id not specified in an update call
the csv and the mapping file work when i run it interactively, which tells me my issue must be my pross-conf bean?

here is that:
   <bean id="homeAddressUpdateProcess"
      <description>Home Address Update job gets the Address record updates from a CSV file and uploads them to salesforce using 'update'.</description>
        <property name="name" value="homeAddressUpdate"/>
        <property name="configOverrideMap">
                <entry key="sfdc.endpoint" value="..."/>
                <entry key="sfdc.username" value="..."/>
                <entry key="sfdc.password" value="..."/>
                <entry key="process.encryptionKeyFile" value="D:\MONITORING\DataLoader\CONF\key.txt"/>
                <entry key="sfdc.timeoutSecs" value="600"/>
                <entry key="sfdc.loadBatchSize" value="200"/>
                <entry key="process.operation" value="update"/>
                <entry key="process.mappingFile" value="D:\MONITORING\DataLoader\MAPPING\homeAddressUpdateMap.sdl"/>
                <entry key="dataAccess.name" value="D:\MONITORING\DataLoader\INBOUND\homeAddressExtract.out.csv"/>
                <entry key="dataAccess.type" value="csvRead"/>
                <entry key="sfdc.entity" value="Contact"/>
                <entry key="process.initialLastRunDate" value="2006-12-01T00:00:00.000-0800"/>
        <entry key="process.statusOutputDirectory" value="D:\MONITORING\DataLoader\LOGS\" />
        <entry key="process.outputSuccess" value="D:\MONITORING\DataLoader\LOGS\homeAddressUpdate_success.csv"/>
        <entry key="process.outputError" value="D:\MONITORING\DataLoader\LOGS\homeAddressUpdate_error.csv"/>
any thoughts on this would be most helpful.
Does anyone know if there's a way to get the parent fields for the Account parent object via the ObjectId relationship in ObjectTerritory2Association?

The query below works to get the Name.  But I don't know of a way to get the other fields.  It's actually one custom field that I'm hoping to get in my query.

select ObjectId , Object.Name,  Territory2.MarketUser_Last_Modified_Date__c ,LastModifiedDate
from ObjectTerritory2Association
where   Object.Type = 'Account' limit 10

Tried the following in "Execute anonymous":


Messaging.SingleEmailMessage	mail = new Messaging.SingleEmailMessage();
mail.setSenderDisplayName('Sender Name');
mail.setToaddresses(new List<String>{'recipient@gmail.com'});
Messaging.sendEmail(new List<Messaging.Email>{mail});


The email is received successfuly by when I "hit" reply it show s the email address of the "Admin" user that I executed the above code with. Should it not be "someemail@gmail.com"?


   I created a new object type(such as objectA)  that had one field(such as account__c) to refer to some account.When I called API to change one objectA to refer to another account,there was a error:"Cannot specify both an external ID reference Account__r and a salesforce id, Account__c".
   code like that(C#):
         //the old value of objectA.Account__C is accountA,now set it accountB
         objectA.Account__c = accountB.Id;
   What is my problem?How to solve it?