• Efraim Taranto 1
  • 29 Points
  • Member since 2017

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 5
I am trying to deploy the xml package for Customer_Interaction__b.object using the workbench for this unit. However I deploy and get success message in workbench but cannot see any big object.
  • I did see on the unit page it says that the examples are written for api unit 41.0 but my workbench doesnt allow me to go beyond 40. Does this matter?
  • My trailhead playground is on winter 18.
  • Does it matter what the file name for the object and permission set? (I do have the package.xml)
  • I have tried with and without having 'Single package' selected in workbench deploy
  • I have double checked the workbench is logged into the correct org
User-added image
User-added image

I installed Developer Hub Trial Org 64-bit Windows option.
I created a trial project with: 
     sfdx force:project:create -n geolocation

But, when I try to create the scratch org with:
      sfdx force:org:create -s -f config/project-scratch-def.json -a GeoAppScratch
I get this:
     ERROR running force:org:create: You do  not have access to the [scratchorgiinfo] object

I've tried several suggested fixes that I found when I searched for the above error. None has resolved the issue for me.
I am on the last module of the Build a Discount Calculator trail. I have verified the first 4 steps and received the 50 points (everything was configured correctly). Now, when I try to verify my last step I am getting the following error:

Challenge Not yet complete... here's what's wrong: 
The 'Calculate Discount' custom button doesn't exist or isn't properly configured. Check the instructions.

I've verfied the creation of the button, it's on the correct page layout and I've tested the button- it gives me the correct discount percentage and discounted amount.

Any other ideas on what I should check? I'm at a loss.
I'm getting an error when checking the Using Visualforce Pages in Page Layouts and Mobile Cards challenge. The error says that the page isn't evaluating the 'Prospecting' stage, yet the code works when I insert an Opportunity Id where the Stage = Prospecting.

The code:
<apex:page docType="html-5.0" standardController="Opportunity">
    <apex:remoteObjects >
        <apex:remoteObjectModel name="Opportunity" fields="Id,StageName" />
    <div class="myPage">
        <h2>Tip for when you're in the {!Opportunity.StageName} Stage:</h2>
        <p id="stageTip" />
        var opportunityStage = "{!Opportunity.StageName}";
        document.getElementById("stageTip").innerHTML = createStageTip();
        function createStageTip() {
                    case "Prospecting":
                        return "You need to ask really good questions"
                    case "Needs Analysis":
                        return "Determine the needs by asking really good questions"
                    case "Proposal/Price Quote":
                        return "Make sure the price doesn't exceed the budget"
                    case "Negotiation/Review":
                        return "Maybe go down, but don't go down too much"
                        return "Use your best judgement";
If you have any ideas as to why this isn't working, I'd love to hear them.

  • December 07, 2015
  • Like
  • 1
I am doing the "Add a Mobile Card that Displays Content Based on Opportunity Stage" challenge. It asks for a Visualforce page which displays content depending on opportunity stage.
I used the following code
       <apex:outputText rendered="{!CONTAINS(opportunity.stagename,'Prospecting')}" value="this is a good idea" />
       <apex:outputText rendered="{!CONTAINS(opportunity.stagename,'Analysis')}" value="do this" />
       <apex:outputText rendered="{!CONTAINS(opportunity.stagename,'Proposal')}" value="do that" />
       <apex:outputText rendered="{!CONTAINS(opportunity.stagename,'Negotiation')}" value="go away" />
and it works in the browser, but the challenge checks complains:
"The page isn't evaluating the 'Prospecting' stage. "
Any idea why?