• Prasad N R
  • 33 Points
  • Member since 2017

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 3
    Likes Given
  • 0
  • 10
Hello all,

I followed the directions in the Trailhead module and clicked https://localhost:8443. I received the below error.

This site can’t be reached
localhost refused to connect.
Checking the connection
Checking the proxy and the firewall

I have internet connection, there is no proxy, and I turned off the firewall. I saw documentation that suggested checking for missing "listen:443". I found it in the nginx.conf file. Any help would be appreciated. Thank you.

I know there are so many question which answers this type of questions but my problem is little different. 
I have one object called CRMData__c in that I have Name, CRMDefinition__c(master-detail), Number__c, Date__c fields. 
So CRMData__c will have many records with Date, Number__C some number, and CRMDefinition id. 

I am showing some data example below for better understanding. 
User-added image

I got the record list in one variable List<sObject> result = "My result";
based on this result I want a JSON like below.


    "Test1": 12,
    "Test2": 11,
    "date": "2018-01-01"
    "Test1": 15,
    "Test2": 23,
    "date": "2018-01-02"
   "Test1": 20,
    "date": "2018-01-03"

Means based on the date it should take the values of Test1 data and Test2 data.. 
I tried so many methods but it gives me the "APEX CPU Time Limit" error.
Because first I have to loop through the dates.
I am trying to deploy the xml package for Customer_Interaction__b.object using the workbench for this unit. However I deploy and get success message in workbench but cannot see any big object.
  • I did see on the unit page it says that the examples are written for api unit 41.0 but my workbench doesnt allow me to go beyond 40. Does this matter?
  • My trailhead playground is on winter 18.
  • Does it matter what the file name for the object and permission set? (I do have the package.xml)
  • I have tried with and without having 'Single package' selected in workbench deploy
  • I have double checked the workbench is logged into the correct org
User-added image
User-added image


I was doing the "Work with Custom Lightning Components" trail that requires enabling Mydomain, but after doing so I am unable to login to my org. 

I've tried the 'forgot my password' option 2 times already to no avail. (it works saving the new password, and I can also login here in the forum with it, but still can't acces my org.

this is very frustrating as I have the certificate-exam coming up, so I hope somebody can help me out with this asap.


I have a salesforce account - daniel.wymer@teradata.com - and get into endless loop and cannot reach Trailhead.  It seems like I have a Salesforce account, have established a password, but cannot login to Trailhead.

I have passed a single value to my server side apex controller using the following code

action.setParams({ "searchKey" : elemVal });

Now i want to pass one more argument along with elemVal. I tried the following code but i am getting null.

action.setParams({ "searchKey" : elemVal },{"temp" : t}):

Please help
  • June 24, 2016
  • Like
  • 0
Hi all,
I am trying to build lightning components and I want to access the properties of an Apex controller in the components to display certain data. When try to display the values like in Visualforce (with added @AuraEnabled), it does not work. When I place the properties inside an inner class and create a method that has a return type as that inner class, then when I return a list of that class I can see the data. Bellow is the code which displays data, but I want to use it without an inner class and extra method to get that data. If anybody can help please let me know.


public with sharing class EmployeeAvailability {
public static empAvailableInnerclass innerCList;
public class empAvailableInnerClass {
        public Decimal aetPerc {get;set;}
        public Integer totalEmployeesToday {get;set;}
        public Decimal budgetThisMonth {get;set;}
        public Decimal averageMargin {get;set;}
        public Object averageRate {get;set;}
        public Integer illnessToday {get;set;}
        public List<availableNextSixty> AvailableSixty{get;set;}
        public Date DateAfterTwoMonths {get;set;}

        public empAvailableInnerclass() {

    public static empAvailableInnerclass getEmployeesDailyStatus(){
        return innerCList;

JavaScript controller:
getFixedTable : function(cmp, event, helper) {
        var table = cmp.get("c.getEmployeesDailyStatus");
            var state = response.getState();
            if (state === "SUCCESS") {
            } else if (state === "ERROR") {
                alert('Error : ' + JSON.stringify(errors));

Lightning Component:
<aura:handler name="init" value="{!this}" action="{!c.getFixedTable}"/>
<aura:attribute name="tabTable" type="EmployeeAvailabilityLightning"/>

<table id="fixedTab">
                    <th>Total employees today : {!v.tabTable.totalEmployeesToday}</th>
                    <th>Budget this month : {!v.tabTable.budgetThisMonth}</th>
                    <th>Average Margin : {!v.tabTable.averageMargin} %</th>
                    <th>Available next 60 days : {!v.tabTable.AvailableSixty.size}</th>
                    <th>Employee hours available today : {!v.tabTable.aetPerc} %</th>
                    <th>Illness Today: {!v.tabTable.illnessToday}</th>



I need to add a field to the lead detail page which calculates the number of days since the last activity for a lead. This formula would return a number which represents the number of days since the last task has been created, updated or completed. Does anyone know what this formula is?





  • January 25, 2011
  • Like
  • 0

I know there is are issues surrounding the use of Eclipse and the Force.com IDE on Windows 7 64-bit.  Here's what I've done and what I'm experiencing.


1. Uuninstalled the 64-bit JRE and installed the 32-bit version from the Sun website.

2. Installed Ganymede version of Eclipse from the Eclipse.org website

3. Followed the wiki instructions for installing the force.com IDE through the Eclipse software updates path.


Everything seems to install just fine.  I am able to create a Force.com project and download Apex components from my org and edit some of my triggers.


Then the trouble begins.  I close Eclipse and restart.  It is as if I never installed the Force.com IDE.  It does not show up in Perspectives or in New Project -> Other.  When I go to Help->Software Updates, Force.com IDE does show up as installed software.


Anyone have any suggestions to make this work on the 64-bit Windows 7 environment? 


I am considering "buying" a new laptop to complete my project.  Fortunately I have a Windows 7 upgrade license available.  I'm hoping to reinstall Windows 7 32-bit on this new machine over the 64-bit version (which is all that seems to come preloaded on anything anymore).  Does anyone have any experience with this configuration?





I have university as parent object & college as child object.
There is a master-detail relationship defined on child object i.e college

I have a parent-child soql as follows
List<University__c> univList=[select Name,(select Name from colleges__r) from university__c];

Also I have a child-parent soql as follows
List<college__c> univList=[select Name,university__r.Name from college__c

when I execute the parent-child query I do not get any child related records .
Also when I execute child-parent query I do get the name of the college but the university ID I get but I want the university name also not the ID

please let me know.

Challenge Description:
  • Upload a specified zip file as a static resource. The zip will have directories with images and you have to display a specific image on a Visualforce page.The page must be named 'ShowImage'.
  • This file must be uploaded as a Static Resource named 'vfimagetest'.
  • The page must have a Visualforce apex:image tag that displays the 'kitten1.jpg' image from the 'cats' directory of the static resource.

Screenshot of Visualforce Page:
User-added image
Screenshot of Resource Page:
User-added image

Screenshot of page preview:
User-added image

Exact text of error:
Challenge not yet complete... here's what's wrong: 
The page does not include a reference to the specified image

Can't figure out whats wrong, everything looks like its working perfectly and I used the examples in the module as a base for the code.



I want to access controller getter-setter variable inside javascript. How could I do this.


Thanks in advance.







  • April 24, 2012
  • Like
  • 1