• RyanCox
  • 10 Points
  • Member since 2017
  • Technical Architect
  • Salesforce.com

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 4
Is there a way to stop the drop down that give and option to wrap or clip text in a lightning data table?

User-added image
Hello salesforce developpers!

I have an understanding issue with events/activities in Salesforce: I must insert event data in salesforce from an ERP using Talend.

During Talend insertion, I see the processed IDs in the logs. When searching for this ID by typing "https://eu5.salesforce.com/<ID>", I see the corresponding event and all its details. Seems fine.

However, when searching in developper console (SOQL) like this:
Select Id, Subject from event where Id = '<ID>'

... No event found.

Could someone explain to me why I do not see the event in console? is it stored in another table? (i've also searched in Activity table without much success).

Best regards, and thanks in advance!

I have some code that sends out an email. If I run that code from inside salesforce it works fine. However, if I run that code as the public sites user I get the following SendEmailResult error.


SendEmail failed. First exception on row 0; first error: INVALID_CROSS_REFERENCE_KEY, invalid cross reference id: []


However, all the mailing objects ID's (who, what, template and orgwide) are exactly the same when I send it from inside salesforce and from the website so I don't understand how it could be giving an error in one case but not the other.


 Here's the code that sends the email:


Messaging.SingleEmailMessage mail = new Messaging.SingleEmailMessage(); 






Messaging.sendEmail(new Messaging.SingleEmailMessage[] { mail});


for(Messaging.SendEmailResult res : r){

if(res.isSuccess() == false)




 Am I misunderstanding the error or is there some other ID field that could be screwing up the email?



Message Edited by grigri9 on 11-17-2009 09:08 PM