• Hun Low
  • 30 Points
  • Member since 2019

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 5
Hi All,

I am tring to authorize an org on visual studio code but when I am trying authorize it, I am getting the below error.

SFDX: Authorize an Org failed to run
Try this:
Kill the process running on port 1717 or use a custom connected app and update OauthLocalPort in the sfdx-project.json file.
19:31:13.241 sfdx force:auth:web:login --setalias VSCodePlayground --instanceurl https://login.salesforce.com --setdefaultusername ended with exit code 1

I have Killed the Process on port 1717 and tried it again then I am not getting any error but it is running for infinite time. 

Please help.

I tried integrating Salesforce with VS code.. I installed Salesforce CLI and when I tried creating a project in VS code but it says that Salesforce CLI is not installed.
 The exact error is

"14:48:25.402 sfdx force:project:create --projectname TestProject --outputdir d:\ --manifest
'sfdx' is not recognized as an internal or external command,
operable program or batch file.
14:48:25.492 sfdx force:project:create --projectname TestProject --outputdir d:\ --manifest ended with error spawn sfdx ENOENT
Salesforce CLI is not installed. Install it from https://developer.salesforce.com/tools/sfdxcli"