• johnson eater
  • 0 Points
  • Member since 2019

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 6
Hi All,
I have created one custom picklist on SBQQ Quote object.
I want to auotpopulate this field by referencing on custom checkbox from account object.
suppose checkbox on account is checked then set value X on quote picklist.

I am creating new record using <lightning:recordEditForm>  and i am not able to populate lookup field onload finction. 
I tried below things but both are not working: 
<lightning:inputField aura:id="caseLookup" type='String' fieldName ="Case__c" value="00842156"/>
<lightning:inputField aura:id="caseLookup" fieldName ="Case__c"/>
onload : function(component, event, helper) { var parentId = component.get("v.parentId"); // requires inputFields to have aura:id component.find("caseLookup").set("v.value", "00842156"); },
Please help me here, I can do it using custom component but i want to use this. Or let me know if i can use something else to create new record of any object. 

For several months I've been using the instructions in this blog post to use Workbench to backup the metadata in my org. Last month, the process stopped working. I assumed it was a one-off oddity and didn't think much of it, but I'm seeing the same errors again this month. Generating the XML "package" containing the metadata I want to export works fine and the process appears to succeed. However when I go to click the download link in Workbench I am told the .zip archive no longer exists. I've uploaded screenshots to show that the ZIP file is generated and the error message displayed when I click the download button. 

I have no idea what I'm doing wrong, and don't believe I've changed anything compared to what I was doing previously, when the backup worked. 

What I see before I click "download"

Error Message

I know there are alternative methods for doing this, such as those discussed here https://developer.salesforce.com/forums/?id=906F0000000BIYzIAO but I am interested in understanding why the method I've been using ceased to work. 

I am not an expert in lightning components, so I had to post this question.

In lightning, I have an app page. There a is a primarycomponent kept on the lightning page.

<aura:component implements="flexipage:availableForAllPageTypes,force:appHostable"
                access="global" >
 <lightning:button label="Neutral" 
                             title="Neutral action" 

Now I have another component say F1Comp.cmp

<aura:component implements="flexipage:availableForAllPageTypes"
                access="global" >
 <h1> I am F1 Comp </h1>

My requirement is when I click the button In primarycomponentit should call the f1Comp.

How to achieve this?

Please eloborate and suggest approaches.