• Taylor Young
  • 20 Points
  • Member since 2019

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 1
    Likes Given
  • 6
  • 1
I have a class that creates Tasks. When I go to the list view or the object page for those Tasks, if I click on Task Name field it links to Production (where the record doesn't exist) and asks me to login. 

I've never seen anything like this. Any ideas what is going on?

If you were wondering, no, I am not setting the Task Name field manually. It is automatically generated when the Task is created. 

Thank you!
I have an upload handling class that parses the information, finds the relevant objects, and updates them. After that occurs I pass the records to a class that creates Tasks depending on the values of certain fields. 

As is, the Task creating class is Queueable Apex. But I can’t add the object id to the WhatId field of the Task because of record locking. Do you know any way to work around this? I have tried adding 'FOR UPDATE' to the initial query as suggested here: https://developer.salesforce.com/forums/?id=9060G000000I2r1QAC

Thank you!
I am writing a batch that updates a custom object. There are millions of records though, and the query can't even be run without using a limit. Using the Query Plan tool I see that the Cost of querying this object is almost 6.  So instead I rewrote the batch to query the parent. The cost of the parent is about 4 (still very high, but at least the query works). 

In order to run the batch this way I have to query the parent object, create a list of their ids, and pass that list of ids to the new batch query. 

I am accomplishing that by doing the following: 
String schedQuery = 'select id FROM schedules__c '+ 
'WHERE DealProgram__c LIKE '%Gray%' AND Week__c >= :queryStart AND Week__c <= :queryEnd';

List<Schedules__C> schedules = Database.Query(schedQuery);

List<Id> schedIds = new List<Id>();
For(Schedules__c s : schedules){

And I can see in the logs that this is in fact a List of Ids and it is not empty. 

The following is the query that I pass to my batch: 
String query = 'select id, Air_Date__c, Order_Number__c, Invoice_Number__c  FROM spot_data__c ' + 
'WHERE schedule__c IN(:schedIds) AND ' + 
'Order_Number__c IN :orderNums ORDER BY Air_Date__c ASC ';
Even though the query works completely find in the Query Editor, I am getting the error message in the title which makes no sense to me: "Invalid bind expression type of List<Id> for column of type Id ". Most of the errors I saw like this are when 1.the type in the list is a mismatch (Case vs. Id) or 2. What is being passed in is a List<List<id>> instead of List<Id>. Neither of those are a problem here.

Below I will share the code in the batch. Thank you in advance for your generosity and time.

This is excluding the execute and finish methods because they are not reached before the error occurs:
global class InvoiceNumberSpotDataBatch implements Database.Batchable<sObject>{
    global final String query;
    global final Map<String, List<Map<String, String>>> orderMap;
    global final List<String> orderNums;
    global final List<Id> schedIds;
    global final Date queryStart;
    global final Date queryEnd;
   global InvoiceNumberSpotDataBatch(String query, Map<String, List<Map<String, String>>> orderMap, List<String> orderNums, Date queryStart, Date queryEnd, List<Id> schedIds ){

   global Database.QueryLocator start(Database.BatchableContext BC){
      return Database.getQueryLocator(query);

I worked on an SFDX project a while ago and deployed it to Salesforce. It is up and running in our org's Sandbox. I can't find the source code locally or on GitHub. Is it possible to export the source code from Salesforce?

Thank you,
I am building a Lightning app for my companies org. Most of the app is custom components that exchange data through events. I'd like to integrate a component from a seperate project which already exists on the Salesforce org. Is it possible to import this component for use in my other project? 
Hello. I'm starting to experiment with Lightning web components. I created a simple component name 'grid' which is rendered by 'app'. In 'grid.html' I am trying to use the 'lightning-input' markup tag to display an input field for date selection. I copied the input markup directly from the docs. I am receiving an error which leads my to believe the markup tag is being interpreted as another component. I am clearly misunderstanding some context. What is the difference in syntax between lwc html markup and component markup. And why is this markup tag being interpreted this way? Please advice.

<h1>I wear sandals on {date}!</h1>
<lightning-input type="checkbox"
<lightning-input type="checkbox">

import { LightningElement, track } from 'lwc';

export default class Grid extends LightningElement {
  @track date = Date().toString().slice(0,15);

app.html (if needed)
<div class="center grid">

How do you set up default app in salesforce lightning?  I would really appreciate if someone helps me.




How can I manage /Access /Update 100 millions of records in Apex .


Is it Possible using Batch Apex?


I think batch apex can Process 50 millions of records.


how can I do this?


any help?





  • May 04, 2011
  • Like
  • 1