• Yasantha Paranamanna
  • 0 Points
  • Member since 2020
  • Mr
  • Virtusa (pvt) Ltd.

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 1
    Likes Given
  • 0
  • 3

I'm doing a 'Visualforce Basics' module and I'm stuck at 'Use Standard Controllers' Unit (link here).
I created a page with the following code:
    <apex:pageBlock title="Account Summary">


Then I opened a page via the "Preview" button in a Developer Console and opened a JavaScript console in Chrome where I typed:

$A.get("e.force:navigateToURL").setParams({"url": "/apex/AccSum"}).fire();
And I got the following error:
Uncaught ReferenceError: $A is not defined at <anonymous>:1:1

Both the snippets are copied from the Unit's sections, I didn't change anything except the page's name - 'AccSum'. I tried all of the above in a Firefox which also did not work.

Does anyone know what's going on?

I am new to Visualforce and I am doing the Trailhead: Visualforce Basics Module - Use Standard Controllers.  The instructions state:
To preview your page in the context of Lightning Experience, open your browser’s developer console and enter:
    {"url": "/apex/pageName"}).fire();
I am not sure where to enter this.  When I enter it in the Visualforce page the text just show up on the Visualforce page preview.  I must be missing something.  Any help will be greatly appreciated.

while working with the developer console today it suddenly would stop saving any files.
In most cases it just states "Saving" forever.

After googeling the error i have tried to create a new workspace and delete the old one with no effect.
I can create and edit Visualforce Pages using setup. But when i'm trying to save a class it says "Organization Administration Locked
The changes you requested require salesforce.com to temporarily lock your organization's administration setup. However, the administration setup has already been locked by another change. Please wait for the previous action to finish, then try again later."

I get a similiar mesage when trying to work with Eclipse.

I have also used the function "Cancel all Deployments" from within the Progress Tab in the Developer Console.

Any Ideas how i could fix this?




When I press enter to select the suggested auto populated tags, it prints as - =""
Again I need to type and select it slow. Doesn't work blinking faster.
What's wrong?