• amelia pearl
  • -4 Points
  • Member since 2020

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 11

I have a requirement to sync CPQ quote line item values with an external system. I have used triggers to check if any insertion or updation happened and have called the external system in trigger. CPQ have its own triggers. So my custom trigger is calling more than one time. I have used the technique to stop recursion. But it is not working. If anynone have solutions, Kindly help on this.Thanks
Hi all - we don't use accounts in my installation, yet the reports all need an Account or the Contacts don't show up.

It is easy enough to update all existing contacts with AcctID=Individual, but how can I set it up so any new Contact has default of Individual account?

Please don't say "make Account required field and make them pick Individual".. I want it to default.

Thank you!

My requirement is to gather contact information with files upload on public site (using guest user).

1. My question is can we pre fill the form for guest users if data already exists in salesforce for example if user's first name, last name and email matches with existing data form pre fill rest of the foelds in form (lightning component)
2. File upload -- Lightning:Fileupload doesnot work if we don't have parent id (contact id). any insight on this? or i am thinking of using two pages on first create record and then get the contact id of just created record and pass it as a parent it to files on next page.

Hope i am able to explain.
I added a lwc in a package. How to remove it now? I want to delete it.

I'm struggle to access a custom field throught the PHP SDK.
The field exist:
User-added image
I can access the basic fields, but when i try to add the custom field to the query, always return the same error.

$query = "SELECT Id, FirstName, LastName, Phone, NumOrdem__c FROM Contact";
Error: "No such column 'NumOrdem__c' on entity 'Contact'. "

I've generate already the WSDL several times, but without success.

Can someone help and point me to the right direction?
I really appreciate.


Hi All,

When I have tried to execute the query as 
        "Select Id, Subject from ActivityHistory"

in 'Query Editor' from the developer console in the context of 'System Administrator'.

After executing the query, I got the error as  "entity type ActivityHistory does not support query"

Can anybody will help me how to solve this error?


For several months I've been using the instructions in this blog post to use Workbench to backup the metadata in my org. Last month, the process stopped working. I assumed it was a one-off oddity and didn't think much of it, but I'm seeing the same errors again this month. Generating the XML "package" containing the metadata I want to export works fine and the process appears to succeed. However when I go to click the download link in Workbench I am told the .zip archive no longer exists. I've uploaded screenshots to show that the ZIP file is generated and the error message displayed when I click the download button. 

I have no idea what I'm doing wrong, and don't believe I've changed anything compared to what I was doing previously, when the backup worked. 

What I see before I click "download"

Error Message

I know there are alternative methods for doing this, such as those discussed here https://developer.salesforce.com/forums/?id=906F0000000BIYzIAO but I am interested in understanding why the method I've been using ceased to work. 

I have a lightning app which has the remote site settings dynamic.
So, is it a good practice to use metadataService.class (http://technome2.blogspot.com/2017/05/creating-remote-site-settings.html) in post-installation script to add remote site settings for the org?
I want to relate an outbound email message to a different Opportunity. EmailMessage.RelatedToId holds the Id of the Opportunity for which it's related to. I attempted to simply change the RelatedToId on the EmailMessage using Execute Anonymous but it doesn't work. Getting error "System.SObjectException: Field is not writeable: EmailMessage.RelatedToId".
EmailMessage msg=[SELECT Id, RelatedToId FROM EmailMessage WHERE Id = '02so000000I7rXuAAJ'];
Update msg;

Is there another method of updating this field?
We would like to avoid to hardcode value in an apex class and use "environment variable". Is the use of custom settings the right way to do that ? 

Today I created a custom settings containing 2 fields, an url and a authorization token. The values are differents from one sandbox to another, so I create one data set for each of my sandbox (dev-int-uat-prod). Now my problem is to know in wich sandbox am I ? To retrieve the right values from my custom setting and of course I don't want to hardcode it. I used UserInfo.getUserName().substringAfterLast('@').substringAfterLast('.') to retrieve the sandbox name but for production this code doesn't work, so can anyone help me on the best way to do that ?

Thanks in advance for your answers and your help.
Hi Developers any basic code to hide the rows in a table based on the user action, I am aware of the controller, I am fnding it diffcult to achieve in the JS, I have been searching the forum all day long!