• madhav sharma 1
  • -9 Points
  • Member since 2020

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 41
I am not a VF expert....

I have created a VF page and I have a few page blocks and sections that I have titled and have applied no special style or formatting (See "A" in my image).  Code: 
<apex:pageBlock title="Standard Title Example">

I also have a couple sections that display related lists (See "B" in my image), and in an effort to remove the standard "New" button that appears when including those related lists, I am using facet.  Code:
<apex:facet name="header">
<font size="2.9"> //This is the closest I can get the font size to match
<b> &nbsp;&nbsp;&nbsp;&nbsp;Facet Header Example</b> // I included the '&nbsp;' to simulate an indent

I am struggling to make the font size and style of the Facet header (B) match up with the titles of the pageBlock sections (A) on the same page.  I mostly want to have the padding(?) around the facet header title increase, so that that title section is not so tight.

User-added image
I am creating  New Action Under 
Buttons, Links, and Actions 
for Lighting Component.

can some one help how to create below URL as Lighting Custom Component :


Can anyone help on this.

  • February 18, 2021
  • Like
  • 0
I want to add a button or link to multiple object detail pages.
This button must be shown automatically, based on some configuration stored in a table (the table would contain the names of the objects that will show the button and other info), it is not fixed and must be displayed conditionally.
I have seen the possibility of using custom button/links and the utility bar.
What is the best approach and what other options are available to achieve this in Salesforce (classic and lightning)?
  • February 15, 2021
  • Like
  • 0

I have used a custom cache mechanism.
I also want to use @AuraEnabled(cacheable=true)
Is it possible know the impact of them please ? or how wil they both cohibit
thank you for advise
  • February 08, 2021
  • Like
  • 0
how to write the trigger 

for last updated checkbox is checked Whenever customer___c related Invoices__c any record is inserted or updated at that time must have LastUpdatedInvoice__c checkbox is checked. and remaining all related child records must have un
Dear PG administrators

I am going to conduct some trailhead activities.
Recentrly, I had MFA activities on my PG, then logout.
However, I cannot connect/run on my PG based due to forgot my login id/passwd combination for my PG.
I also try to reset passwd, but I forgot QA's combination.

Could someone help/reset my passwd to enter into my PG.

PG URL:https://empathetic-fox-qhrzqt-dev-ed.my.salesforce.com/

If needs, I also provide more information.

With best regards,

// Jun
I use describeValueType() to get all fields of Profile successfully. But the same call with PermissionSet doesn't give me all fields, all permissions are missing. How can I get all PermissionSet fields?
public class testclassex {
@isTest static void Tempwarm()
    Decimal cel=TemperatureConvertor.FahrenheitToCelsius(70);
cant save the product2 view page in advanced apex trigger challenge 3
it shows DML requires SObject or SObject list type: List<Product2>
Hi,I have created a cutsom aura component for case submit form in customer community with case deflection functionality calling out on the standard fields with the help of event selfService:caseCreateFieldChange .But when I am adding lets say 'ip address' to the Subject field ,its showing article related to ip address and also one article named as email-to-case (which does not have any relation to ip address keyword.) Can anyone help me out in telling me why this is happening?
Hi. I am trying to get an access token for working with API

I always get the message 

{"error":"invalid_grant","error_description":"authentication failure"}*

I tried postman and curl 
curl -v https://login.salesforce.com/services/oauth2/token 
      -d "grant_type=password" -d "client_id=consumer_key" 
      -d "client_secret=consumer_secret" 
      -d "username=username" -d "password=password"

curl I repeat instruction from https://developer.salesforce.com/docs/atlas.en-us.api_iot.meta/api_iot/qs_auth_access_token.htm, but it still doesn't work 

what is wrong here? 

I am looking at the first challenge of the Trailhead's Apex Specialist Superbadge and I am facing some annoying error at the challenge 1.

When I submit my code, they ask me to populate the 'Equipment__c' field on the new Maintenance Request that has to be created from the Trigger. However, their is no 'Equipment__c' on the Maitnenance Request object.

Have you faced also this problem? How did you guys manage to solve it?

Thanks a lot!!
hi guys, i have one  government  tax editable/fillable  pdf form, uploaded into the static resource and from controller need to bind the values to that particular pdf and download the file ..

Do any one worked in such a way , Need your valuable suggestions to work on ..

Thanks and Regards,
Sfdc Franklin

I need to create a formula field(Forecast Amount) and display total amount based on below criteria.

If Opportunity type = New
show sum of = Field 1 and Field 2 

If Oppotunity Type = Renewal
Show = field 3

I need both the conditions in same formula

I am relatively new to interacting with Apex classes.  When pushing a change-set to production there is a validation error on the change-set due to an apex class that a previous consultant created and it is blocking the deployment.  I have worked through change-set before and never encountered this error.

The apex class itself is irrelevant and I wish to delete it completely from production.  I am slightly concerned about this because if I delete it from production I am not sure of the ramifications of how it interacts with other areas our instance.

Attached is a file of the error from the change set.  If you have advice about the best way to go about this that would be great.User-added image
How to make lightning datatable inline edit field mandatory ?
How to make a field mandatory in lightning data table?

I'm stucked on Service Cloud Specialist step 6. It shows the error message:

Challenge Not yet complete... here's what's wrong: 
We can't find the Recipient field in the email template. Ensure the Cloudy Weather Email Template addresses the Recipient of the email.
Close errors

However, my email template called Cloudy weather (Text format) has the following body:

Hey {!Contact.FirstName}, Sorry to hear that your panels aren't generating the power you hoped for. Based on our research, it appears the low power produced is related to the cloudy weather in your area recently. In the worst conditions, Ursa Major panels produce ~25% of maximum power. If you have additional questions, please give us a call and reference case {!Case.CaseNumber}. Thanks! {!User.Name}, Ursa Major Solar

Any ideas?

Hi.  I am doing the tralhead https://trailhead.salesforce.com/modules/lex_javascript_button_migration/units/javascript_buttons_to_lightning_actions

I have attempted to do this tralhead for about 3 weeks now -- sent in some feedback, but no change seems apparent in the tralhead.

1.  I created a brand new "My Trailhead Playground 2"
2.  Open the Developer console.
3.  Create a Lightning Component called CreateUser.cmp
4.  Copy the text in for this code.
5.  Press Save
6.  Get Error.  Failed to save CreateUser.cmp: Invalid <aura:attribute> type: Test_User__c: Source

In order for this to save, I had to create an object Test_User (Test_User__c) with the following fields:
First or First__c
Last or Last__c
Nickname or Nickname__c
Email or Email__c
Password or Password__c

I also had to change several lines of code to reflect the Field name xxx__c rather than what was listed in the tralhead.
value="{!v.user.First}"  to value="{!v.user.First__c}"  etc.

I haven't finished with the tralhead examples...but I hope this will work.

Would someone please update the tralhead or fix it?


Hello Experts,

In Contact Object, there is no field name Owner then how it is able to access "Contact.Owner.email" ??
Please explain its internal working.
It is not a question, I share my experience because I spent hours on this...
on my visualforce page, chrome kept telling me (in the Javascript console):
XMLHttpRequest cannot load https://eu3.salesforce.com/_ui/common/request/servlet/JsLoggingServlet.
No 'Access-Control-Allow-Origin' header is present on the requested resource.
Origin 'https://c.eu3.visual.force.com' is therefore not allowed access.
Browsing the net, I didn't find info on this error.
At the end, It appears this was due to a call to the "alert" javascript box just before the call to an "<apex:actionFunction". See below,
Javascript is:
function jsRemoveLineItemCatBtn() {
alert( 'CURRENT ID ' + vLICInProgressNum );
afRemoveLineItemCatBtn( String(vLICInProgressNum) );
where afRemoveLineItemCatBtn is the name of my action function.
Since I commented the call to alert, I don't have the error message anymore...
Hope to help few to save time.