• Richard Fleck
  • -1 Points
  • Member since 2021

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 1
I have created a flow that is set to run in system mode (System context without sharing).
Based on the documentation, this is supposed to ignore all object permissions.

The flow I have built is meant to create a record of an object that certain profiles don't have the create permission for. I assumed that, if I run the flow in system context this wouldn't cause issues for these profiles. But it does. All profiles that don't have create permissions for that object get an error when they launch the flow. When I change the profile it works fine.

To me that sounds like the behavior of the flow is different from what the documentation describes.

Does anybody have an idea on how to handle that? I tried opening a case with SF but it is considered a development case which is not covered by our support package so I was advised to post the question here.