• werewolf
  • 5604 Points
  • Member since 2006

  • Chatter
  • 216
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 5
  • 3262


I am from BMC Software, I tried using the login code from Chatterworkbook by using API calls for Java Clients.The username and password are correct but it gives an exception


Exception in thread "main" [UnexpectedErrorFault [ApiFault  exceptionCode='API_DISABLED_FOR_ORG'
 exceptionMessage='API is not enabled for this Organization or Partner'


How can i overcome this?

  • July 23, 2010
  • Like
  • 0

Hello, all-

I have what I fear to be a long-shot question:

I currently have a custom button on a custom object that executes an email template.  This code works; it sends the email template to a Contact that is directly related to this object via a look-up field:

location.replace('/email/author/emailauthor.jsp?retURL=/{!Custom_Object__c.Id}&p3_lkid={!Custom_Object__c.Id}&rtype=003&p2_lkid={!Custom_Object__c.VolunteerId__c }&template_id=00X50000001JKO1&p26=myemail@domain.org&p5=');

My problem is that I need a similar button that will send the same email template to a Contact in my system that is not directly related to this object via a look-up field.

I have both a cross-formula field storing my desired Contact's full name and a cross-formula field storing my desired Contact's email address.  I tried putting each of those fields in my code, replacing the {!Custom_Object__c.VolunteerId__c } part, but no dice.  (It looks like only ID fields work here--not custom fields.)

Is there another way?

Either 1) adding this other Contact in the "To" field, so that it would have its own button, or 2) adding this other Contact to the "CC" field, appending this other Contact to my existing button, would be equally fantastic.  I have no preference.

Many thanks in advance!

I used a CCTIButton class to created a button in the Softphone GUI to navigate to linked Task URL. But I don't know how to get the current call who_id (Contact/Lead) or what_id (Account/Opportunity/Campaigne) that I need in SetLinkURL function parameter. What I am trying to accomplish is to mimic the 'Call A Log' functionality in the Activity History section of Contact or Account Page.

Is there any API I can use to get those information?

  • July 13, 2010
  • Like
  • 0

I have a custom button which populates the account name on a custom activity field using Javascript OnClick. Works great except if the account name has an apostrophe. How would I escape any potential apostrophes from Account.Name in the following javascript?




We are using cases for incident tracking in salesforce.com. There is a "close case" button on the cases page that when clicked, takes the user to another page from where the case can be closed by writing case resolution description and changing status to closed. However, the case close button is still on the detail page even when the case is closed. My manager wants the "close case" button to disappear if the status is closed. We also have a status called reopened. I want the close case button to reappear if the case is reopened.


Can someone pelase help me? How can this be done? I appreciate the help. Thanks!

In Apex Explorer 8.0, when I right-click on an ID field, a "copy ID' option is available.  However, when I click on it, I receive an Unhandled Exception error. Any ideas?  Here is the debug: 


************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
   at ApexExplorer.DataGridHyperLinkColumn.menu2_Click(Object sender, EventArgs e)
   at System.Windows.Forms.MenuItem.OnClick(EventArgs e)
   at System.Windows.Forms.Command.Invoke()
   at System.Windows.Forms.Control.WmCommand(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.DataGridTextBox.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/Program%20Files%20(x86)/salesforce.com/Apex%20Explorer%208.0/ApexExplorer8.0.exe
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Web.Services/
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/Program%20Files%20(x86)/salesforce.com/Apex%20Explorer%208.0/DocumentControl.DLL
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_64/System.Data/
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Deployment/
    Assembly Version:
    Win32 Version: 8.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/Program%20Files%20(x86)/salesforce.com/Apex%20Explorer%208.0/ICSharpCode.SharpZipLib.DLL
    Assembly Version:
    Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/



Hi all,


Is it possible to setup an email to be sent to a user when they are given access to a record via a manual sharing rule?






I know that Email to Case agent has a daily limit of 2500. I also read some where in the forum that with one API call, we can process 10 emails. Does it mean we can process 25000 email per day??? Is the limitation on number of API calls or number of emails processed?? Any input on this is highly appreciated. 

  • April 28, 2010
  • Like
  • 0

In the following case, the field CalendarAvailability__c is a picklist field and Closed, Tenative, & Open are the fields values. I'm trying to have an image displayed in a formula field based on the value of that field but am receiving the following error on save:


Error: Syntax error. Missing ')'


 But as far as I can tell my Case statement seems to be formatted properly ... what am I missing ...?



IMAGE('/img/samples/color_red.gif', 'Closed' [, 25, 100]),
IMAGE('/img/samples/color_yellow.gif', 'Tenative' [, 25, 100]),
IMAGE('/img/samples/color_green.gif', 'Open' [, 25, 100]),
' '





Message Edited by jbroquist on 03-30-2010 06:50 PM

We have a need to display refId information to the agent before he/she sends out an email for a given case.


I researched the SFDC schema and even queried the DB for various fields for each object - Case, EmailMessage, etc. but couldn't find a field corresponding to the refId value that gets inserted in each email.



1. refId is an attribute of which object?

2. Is the refId information available programmatically/API? If so, which one?


Thanks in advance,


I have enabled both Inline Editing and Enhanced Lists in my Sandbox's Setup (per the instructions here), but I still can't edit any fields in my custom List View.  Neither the pencil icon nor the lock icon appears when I hover over what should be an editable field.


Am I missing something?


Thanks in advance!

Hi all--


Has anyone had any luck creating a formula field that pulls the domain from the email address of the record - everything to the right of the '@'?


Thanks for any help you can provide. 

Message Edited by TaleoTom on 03-12-2010 04:33 PM

Can someone please let me know how to use SOSL from .Net?


I am using the below query and geeting MALFORMED_QUERY: unexpected token: FIND


string txt="Acme"; string query="FIND :"+txt+" IN NAME FIELDS RETURNING Account(Id, Name, Type,BillingStreet,Billingcity,BillingState,BillingPostalCode,Owner.Name WHERE RECORDTYPEID='xxxxxxx')";


Please advise...

  • March 11, 2010
  • Like
  • 0
We've created a Custom Case Button (URL) that's available from Case Related Lists on our Custom Product Details Page.  


It's pre-populating the Contact Info into the Case just fine, but when we click Save the following error is displayed: 


Unable to Access Page
Invalid parameter value "Bob Jones" for parameter "cas3". 

Error: The value of the parameter specified above contains a character that is not allowed or the value exceeds the maximum allowed length. Remove the character from the parameter value or reduce the value length and re-submit. If the error still persists, please report it to our Customer Support team and provide the URL of the page you were requesting as well as any other related information. 
We use 'Person Accounts' in our implementation and I'm concerned that might be causing our issue here, but the fact that it pre-populates just fine makes me wonder.  Any other ideas of what might be going wrong here?  Thanks!

Hey there,


We're building a new Case Custom Button (available in a related list from the Product detail page) but when it's used it's skipping the Select Case Record Type screen.


I've seen a bunch of posts advising people on how to create VF pages to skip the Select Case Record Type screen, but we seem to have the opposite problem.


Here's our code, just in case:



Any idears?  Thanks! 

With regards to the option in new cases to "Send notification email to contact" is there a way to make this default checked? I see that you can individually save preferences for tasks to do this but cant see an option for cases.


Apex code? 



Is there anyone out there who tried to integrate Avaya AES with Salesforce.com CTI Toolkit?
  • March 01, 2010
  • Like
  • 0

I created an email button in a custom object which works fine, except when I click on send or cancel, it does not loop back to the previous page ie the custom object. 


Here is the code:  


location.replace('/email/author/emailauthor.jsp?retURL=/{!Gift_Requests__c.Name}&p3_lkid={!Gift_Requests__c.Id}&rtype=003&p4={!Opportunity.OwnerEmail}&p2_lkid=0037000000g3KpE&template_id= 00X700000017qEN ');


Can someone tell me what's missing so when the user clicks on cancel or send it loops back to the custom object.



  • February 26, 2010
  • Like
  • 0



I have a workflow rule that has never worked. any ideas please? thanks.


In my Org we are required to track the validity of multiple certifications per contact. I have instated a time based workflow rule that notifies by email 30 days before it expires.




I have set the following parameters


  • Evaluation Criteria: Evalutaion When a record is created, or when a record is edited and did not previously meet the rule criteria 
  • Rule Criteria: ExpiryDate not equal to [blank]
  • Time Dependent Workflow action: 31 days before expiry date: Send Email, create task.
Thanking you


  • February 26, 2010
  • Like
  • 0



I wanted to know the UPPER LIMITS (max. allowed) for the following:

1. The maximum number of concurrent logins allowed for an Email-to-Case enabled user. In other words, are there any licensing limits for a user who is enabled for Email-to-Case and is being used by several instances of Email-to-case client.

2.  The client based version 1.08 of Email-to-case currently has a limitation of 2,500 incoming emails per day. Is this limit for a given instance of Email-to-Case process or is this limit for the underlying Email-to-case user which creates cases in SFDC from the Email-to-Case client process.


Thanks and regards,



Hi all,

This simple question has got me stumped.  My offending snippet is:

<apex:dataTable id="itemlist" value="{!sortedChecklistItems}" var="Item">
       <apex:facet name="header"><b>Checkbox</b></apex:facet>
            <apex:inputCheckbox id="{!Item.Id}" value="{!Item.Checkbox__c}" disabled="{!Item.Not_Available__c}"  />

Unfortunately the id attribute is giving me trouble.  When I try to save this I get:

Save error: Unknown property 'Checklist__cStandardController.Item'

But when I remove the id attribute it all works fine, showing clearly that the Item property is perfectly valid, since I'm also using it in the value attribute.  

Is there something about the id attribute that acts differently from the other attributes?  Can I not use a merge field in that?  If not, how else can I ensure that each input item in my table gets a predictably unique ID?  Thanks.

Message Edited by werewolf on 01-08-2009 10:37 AM
Hi all,

I was happily humming along writing my Case before insert trigger, but when I wrote my tests, they all failed.  This appears to be due to the fact that Trigger.newMap is coming up null, and I'm trying to use it late in my trigger.  Meanwhile, Trigger.new works just fine.

I added this code to the very beginning of my trigger:

trigger CaseAutocreateContact on Case (before insert) {
      System.debug(Trigger.newMap == null?'Trigger.newMap is null!':'Trigger.newMap is populated.');

And lo and behold when I run my tests I see:

    20081107011750.678:Trigger.CaseAutocreateContact: line 2, column 5: Trigger.newMap is null!

What gives here?  How can Trigger.new be populated but Trigger.newMap be null?  My trigger is using the 14.0 endpoint.

I am faced with the odd situation that I am creating a page where setup="true" which is using the standardController of one of my custom objects, whose tabStyle happens to be greenish.  I am rendering the detail page followed by some of my own custom page blocks.  Because setup="true" at the apex:page level, the detail portion of the page shows up as gray like a setup page (which is good and what I intend).  However, the pageBlocks are picking up their color from the tabStyle of the custom object, so I end up with a gray detail page and 2 greenish related lists.

Is there a tabStyle that I can give these pageBlock elements that will tell them to render themselves in setup-gray instead of custom-object-greenish?  Thanks.
So I'm trying to deploy a pretty simple trigger, and I put a test method that should cover it 100% in a class.  When I try to save everything, I get the message saying I have 0% test coverage.  Ok, fair enough, maybe I just need to run the tests.

So I go to the Classes folder and hit Run Tests.  That should run my tests, right?  Instead I get:

INVALID_OPERATION: Cannot specify both runAllTests and specific RunTests

Huh?  What did I do wrong here?  How can I get it so that it just saves my freaking trigger?  Thanks.
I've been using the Force.com IDE since it was called the Apex plugin for Eclipse.  Today I had some trouble on it on Eclipse 3.2, so I got a brand new, clean copy of Eclipse and installed it.  I fired up Eclipse 3.3 and installed the Force.com toolkit with its dependency (WST or whatever it was).  Everything seemed to go well.  Eclipse restarted itself.

Upon restart, though, I could see no trace of the Force.com IDE.  There was no way to create an Apex (or Force.com) project.  There is no Force.com perspective.  Everything seems to be MIA.  Meanwhile, if I go up to Help->Manage Configuration, the Force.com IDE is listed there and seems to think that it is installed properly.

I have tried disabling it, cleaning it out and reinstalling, but to no avail -- upon my second installation (which also appeared to go well), there were no Force.com items available upon restart.

What gives here?  Has anyone had this issue before, and if so, how did you fix it?

I've been working on this for a while, but I can't quite figure it out.


1. When you send an email from a case, it sends as the user, not as the customer support email address, by default.  It is a selection though. How do I make it default to the correct address?


2. Say we reply to a case, then close it.  A customer repsonds and it gets back into the case.  What's the best practice for us to KNOW that it's been replied to, instead of just staying closed?




I want to show one Modal Dioloug box (Based on certain conditions) when Any user  login to salesforce Org using Standard Login Page

Bussiness need some thing like that

1) User goes to login.salesforce.com link and enter creditials

2) We want to Show some Modal Dioloug  box like Accept Terms and Conditions  , If he agree then we want to redirect him to INSIDE


redirect to /logout.jsp


I tried following Approach

Load a frame [Visual force page ] on Home page component and show some modal box,

But it takes some time to load the frame after login (few seconds....)

Inbetween If user click else where (like any Tab ) then he will enter in side the system


Please let me know if any other approach for it,



Thanks in Advance,




Hi everybody,

i'm looking for a Web2Lead and Case2Lead forms.

For the first form type, is plenty of information over internet.

What about Case2Lead forms? Anyone can point me in the right direction?

How we can make it ?


Many thanks!



I thought I read somewhere the new user interface from the Spring 10 release will not work with Windows XP.


I'm trying to find where I read that but I can't.  Did I dream it?



  • September 02, 2010
  • Like
  • 0

We have created a web to lead form from our developer sandbox. But sadly, none of the data we are entering has been working. We have enabled the debug setting but haven't gotten anything back in a debug email.


The html we are using is:


		<META HTTP-EQUIV="Content-type" CONTENT="text/html; charset=UTF-8">
		<form action="https://www.salesforce.com/servlet/servlet.WebToLead?encoding=UTF-8" method="POST">

		<input type=hidden name="oid" value="00DT0000000HRXp">
		<input type=hidden name="retURL" value="http://pictometry.com">
<input type="hidden" name="debug" value=1>
<input type="hidden" name="debugEmail" value="xxxx@pictometry.com">
<label for="first_name">First Name</label><input  id="first_name" maxlength="40" name="first_name" size="20" type="text" /><br>

<label for="last_name">Last Name</label><input  id="last_name" maxlength="80" name="last_name" size="20" type="text" /><br>

<label for="email">Email</label><input  id="email" maxlength="80" name="email" size="20" type="text" /><br>

<label for="company">Company</label><input  id="company" maxlength="40" name="company" size="20" type="text" /><br>

<label for="city">City</label><input  id="city" maxlength="40" name="city" size="20" type="text" /><br>

<label for="state">State/Province</label><input  id="state" maxlength="20" name="state" size="20" type="text" /><br>

<input type="submit" name="submit">




But I am using a valid email address in the real HTML.


What we get from the salesforce servlet is:


Your request has been queued.

Record Information:

oid: 00DT0000000HRXp
retURL: http://pictometry.com
debug: 1
debugEmail: xxxx@pictometry.com
first_name: Matthew
last_name: Allen
email: xxxx@pictometry.com
company: Pictosomething
city: Rocherster
state: NY
submit: Submit Query



I am using Visual Studio 2008.  When Adding a COM base class to the CTI connector project, I could not find the following in the .h file:

_interface ISalesfornceCTIAdapter : IDispatch




Hence I could not do steps 6a and 6d from page26 of  the CTI Toolkit Developer Guide.


Please advise on what I need to do.


We had our daily WebToLead limit increased above the default limit of 500. Immediately after that change was put into effect I started received error messages every time a new web lead came in. The error message implicates the WebToLead servlet and is a warning that we're approaching the 1000 query row limit.


My diagnosis is that the count is referring to a rolling 24-hour count of web leads; that there is some Apex in effect for the WebToLead Servlet and that that Apex is querying our Lead table for web leads.  Salesforce support has not confirmed any of these assumptions.


It has not yet hit the 1000 mark, so I don't know what will happen when it does, but I'm guessing that like any Apex code, it will not execute. Which means we won't get the web lead.


Has anyone else ever encountered this behavior? I'm guessing there's not much I can do since I have no access to the WebToLead servlet.


Error Message:


Operation: /servlet/servlet.WebToLead

By user/organization: 0058000000ICHCB/00D80000000oHai

Caused the following Apex resource warnings:

Number of query rows: 609 out of 1000



I have followed the instructions on how to get this working. I send test emails to the email service address created by salesforce when I activated the Email-to-Case and it does not create a case. I looked at the System Log and there is no entry regarding this. Any ideas why this is happening?




  • July 29, 2010
  • Like
  • 0

We have a workflow rule that routes cases to a queue upon creation, based on some criteria.  The rule does not include an email notification, and the queue is not set up to notify users (with the checkbox).  However, on some case creations, every member of the queue is receiving an email. 


We have narrowed it down to happening only when a user adds information into an Internal Comments field, which through a workflow rule, populates the Case Comments.  We do have a email notification when Case Comments are added --- however, the email that is firing is our Case Assigned Template email, not our Case Comment Notification email.


Does anyone have any ideas about how to stop the assignment email from firing off (other than not adding anything into the Internal Comments field)?

I am trying to find a formula for a custom field in contacts that will take the opportunity name in the contact's opportunities related list and put it into the contact details.  (This is so I will be able to map the opportunity name field to a corresponding field in vertical response)


  • July 23, 2010
  • Like
  • 0


I am from BMC Software, I tried using the login code from Chatterworkbook by using API calls for Java Clients.The username and password are correct but it gives an exception


Exception in thread "main" [UnexpectedErrorFault [ApiFault  exceptionCode='API_DISABLED_FOR_ORG'
 exceptionMessage='API is not enabled for this Organization or Partner'


How can i overcome this?

  • July 23, 2010
  • Like
  • 0
I see that you can attach a file to a case.  Is it possible to get this functionality for a custom object?
Hey Everyone,

I thought there used to be a specific message board for TAPI but I don't see it anymore. Anyways, I was wondering if anyone has edited or created a new softphone interface that allows users to update custom and standard fields from the phone component, similar to recording the comments of a phone call in the area provided. Any direction on this would be most appreciated.

  • April 17, 2008
  • Like
  • 0
Hi, I am trying to develop a CTI connector between our CTI system and Salesforce using the CTI Toolkit.

I have successfully compiled and run the Demo Adapter example and played with that and I am now working on my own connector. I am at the point where SalesforceCTI.exe is loading and calling into my code. I can see my UI and eventsink initialising in the logs and can see my CreateLoginForm() being called. The problem is that within the browser the softphone start to initialise then never actually starts up. It sits and says "Initializing Softphone..." and never progresses past this point.

Obviously I am doing something wrong or missing something but I am not sure what? In the demo code after initialisation you see the CTIConnect() being called but that isn't happening in my code. Perhaps I am missing something in my initialisation? What causes CTIConnect to be called?

Where is the best place to post questions such as this?


Simon Jansen