• marie.tourne
  • 15 Points
  • Member since 2006

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 5
  • 20
Hello I am using Snap-ins chat component in a Lightning component and I can't seem to find where this is configured. Any idea ?

In the documentation I see a lot of paramters that can be configured but in my community snap-ins there are only a few of them  - and not the welcmome message (that is in English whereas the rest is properly translated)

See printscreen :
User-added image

Hello I am trying to do App Development with Salesforce DX trailhead, but I can't signup for a dev hub trial (https://developer.salesforce.com/promotions/orgs/dx-signup), I get the error : "Could not complete signup due to an unexpected error: Service Unavailable. Please try again soon."
In between 2 jobs I am looking for a pro bono job in Marketing cloud (to gain more experience). I have done one project already (integration with Salesforce CRM). I am currently Marketing Cloud Email Specialist certified and I am preparing for Marketing Cloud Consultant certification.

I could work for approx 10 hours a week between now and the 8th of July completely pro bono (for a non-profit organization). If interested, please let me your email address so I can contact you directly.



I have the error : Error: Field $Action.Contact.New does not exist. Check spelling


My code is as follows :

<apex:commandButton Value="New Contact" action="{!URLFOR($Action.Contact.New, id )}"


Whereas it says in the documentation the new action for contacts should normally be supported :



Any ideas ?

(I found a workaround by using the hard-coaded URL for creating a contact but I would prefer to use Action if possible)

Thanks by advance !



I am testing PDF Quote Generation using the example provided on the wiki: http://wiki.apexdevnet.com/index.php/Visualforce_Quote2PDF.

It works pretty well with admin user, with a standard user ("standard user" profile), it does not work and displays the Insufficient privilige error page:
"You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. ", whereas the user does have access to the quote record.

I have looked over the standard profile and really can't see why it's not working. Any Ideas ? (would be of great help)

Hi all,

I am having this error when validating change set from sandbox1 to sandbox2. Has anyone have any idea on this? Thanks
  • March 01, 2018
  • Like
  • 0
Hello I am trying to do App Development with Salesforce DX trailhead, but I can't signup for a dev hub trial (https://developer.salesforce.com/promotions/orgs/dx-signup), I get the error : "Could not complete signup due to an unexpected error: Service Unavailable. Please try again soon."
We have the managed package which is created by us so we are try to install this package  some other org.

It works fine in all orgs but in one org we have the error message like below:

 (UpdateAcc-2) myrule_1_A1(Action Call) – We can’t find an action with the name and action type that you specified

The UpdateAcc is the Process builder which call the Apex Class.

In the package also we have these components but we got the Error!!!

Any one please help on this!!!

There seems to be an issue in this trailhead module when running it on Windows. Unencrypting the encrypted server key on the Travis server doesn't work.
This seems to be a known issue (https://github.com/travis-ci/travis-ci/issues/4746) and this alternative (https://docs.travis-ci.com/user/encrypting-files/#Using-OpenSSL) didn't work for me as well.

Hi, this is really annoying.  On the first page of the tutorial on creating our first force.com app:




in Step 4 it says to click the Quick Start button.  I don't have this button.  I only see the New and Reorder buttons.


How can I proceed?

For several years the following URL has been able to be called from my .NET client application with no problems:


servURL + '/secur/frontdoor.jsp?sid=' & binding.SessionHeaderValue.sessionId.ToString + '&retURL=" + '/' + objectID


where the servURL is accessed from the binding.URL and the objectID is the object that I want to view in Salesforce


For some strange reason it now randomly goes to a login screen instead of using the sessionID provided and going straight to the object.


Has there been a change in API 21 that would cause this?




I have a custom field on the Account Level that will allow you to type in the name of another Account record this one is "associated" with.  While it is not a Parent/Child record, it is an association between these two Accounts that we need to track.  There will only be one "association" so I am not worried about multiples.  Of course the users don't want to type in the names of Accounts that are already in there, they would like a lookup.  I know I cannot have a lookup on a custom field on Account TO the Account again - but I would like to somehow make the custom field a picklist that shows all the current accounts (and updates dynamically as new Accounts are added) and let the user choose the appropriate one. 


Can someone out there point me in the right direction?  



I would like to take back the "Lead Owner Role Name" or the "Assigned to Role Name" in a new field on the Lead Page Layout.

I only found "Assigned to" and " Owner ID" in the different choices for the formula, but I really need to take back the Role in this new field. I tried with these last choices but I've got about 500 "Assigned to" or "Owner ID", with the formula, that's unfaisable, SFDC is limited at 3900 charachters.

If you have a solution in order to take back directly the role of the "Assigned to" in a new field, it would be fantastic.


Many thanks in advance




Montpellier - FRANCE

I have a work flow rule that sets the Close Date on Opportunities that are created by a specific person to 6 months from the Opportunity Created Date. Here is the formula I am using




Up until today it has been working just fine, however now that it is July 1st and the new close date would be January 1, 2010 it is causing an error when the specific person noted above tries to create an opportunity. Below is the message they receive.


A workflow or approval field update caused an error when saving this record. Contact your administrator to resolve it.: Close Date: value not of required type: common.formula.FormulaEvaluationException: Month or Day out of range in DATE() function

Can anyone give me an idea of why it is no longer working correctly?


I want to upload a file  from my local drive and send that file as an attachment using Apex
for this to upload the file Iam using a standard object of Salesforce Document here
After uploading the file through URL the size of the file is 0 bytes
How to send this document as an attachment through email
can any one please send me the code to solve my issue
This is the code what Iam writing
Document doc=new Document();
Folder fold=new Folder();

Folder[] fld = [select f.id from Folder f  where f.Name = : ('MyFolder')];

doc.URL = 'c:/ImpUrls.txt';
//doc.IsPublic = true;
doc.FolderId = fld[0].id;
//doc.ContentType = 'txt';
insert doc;
We have a sandbox that's been updated to the Summer '08 pre-release.
I created a very basic Visualforce to show my colleague the up-coming PDF functionality I saw demo-ed at Dreamforce, but couldn't figure out how to get the convert to PDF button to display. help?
[Update] __________
so, i found it in the component reference information for apex:page, but now when i try to test it out, I get an internal server error. Here's my code:
<apex:page standardController="Account" renderAs="pdf">
   <apex:detail subject="{!Account.id}"/>


Message Edited by lnryan on 05-22-2008 02:08 PM
I need to to upload files from local machine and save them against a record.I tried using Attachment objectfor this but didnt get any success.I am new to salesforce and got no idea how to manage this.
guys i am lookin forward for some guidance for the same........
  • January 31, 2008
  • Like
  • 0
I am trying to use URLFOR() and set some parameters to default some custom fields values. The custom fields start with two leading zeroes. The S-Control syntax checker does not seem to accept any parameter name that starts with numbers. I get "Error: Syntax error. Missing field name". The whole s-control is as follows and is used to override New Opportunity functionality to default some fields. Help! I've tried changing spaces between the quotes, param names, etc.
window.location.href='{!URLFOR($Action.Opportunity.New, null, [  isdtp="mn", save="x",00N40000001V3eK="test" ] , true)}'
hi, I am able to prepopulate fields using current record values like
parent.frames.location.replace("/006/e?retURL=%2F006%2Fo&RecordType=012500000009ELe&opp4={!Permits_Wells__c.Account__c}") }
 but now my requirement is to populate a standard field 'account name(acc2)'with a temporary variable 'name1' using
parent.frames.location.replace("/001/e?retURL=%2F001%2Fo&acc2=name1") } I tried using this but this is not working. Is there any problem with the syntax. Any help is appreciated. thanks in advance.
  • June 05, 2007
  • Like
  • 0
       can anyone tell how we call a S-Control from Workflow ?
thanks in advance.
So we can replace and redevice the logic for he standard buttons on the detail pages such as delete,
I tried, but seems to me there is no go for the Save button. Am I right?
Seems that only applies to the standard buttons, which doesn't include "Save".  So what can I do if
I want some extra logic embeded in the "Save" action? Like when the "Save" button on salesforce is pressed, I also want the record to be created or updated on our company's side.

Thanks for your input.
  • April 04, 2007
  • Like
  • 0
These boards have numerous threads about sending emails from s-controls.  Having just wrestled with a variant of the problem for a customer, I thought I'd post the solution I used, which (now!) seems fairly straightforward (although it took some bobbing & weaving to get here).

Problem Statement
:  With one click, allow a user to create an object, then send a template-based email to a Contact associated with that object.  The email template must populate with correct values from the just-created object.

Solution:  Save the following code as an s-control snippet.  Then include the snippet, and call the function from anywhere in your main s-control.  (I won't cover the part about creating a new object here - let's assume you can do that, and then retrieve the object ID of your newly created object.)

function sendEmail(templateId, contactIdForToAddress, relatedObjectId) {

  var url = "https://na3.salesforce.com/email/author/emailauthor.jsp?";
  url += "p2_lkid=" + contactIdForToAddress;
  url += "&p3_lkid=" + relatedObjectId;
  url += "&template_id=" + templateId;
  url += "&new_template=1";
  url += "&retURL=%2F" + relatedObjectId;
  url += "&nosave=0";   // not sure what this parameter does, or if it's really needed
  url += "&save=1";   // send it now - don't just bring us to the "send email" page


The net effect here is that a new window (actually, a tab in Firefox) will open up, pointing at the newly created object.  If it has an Activity History related list, the just-sent email will appear there. 

This all worked rather elegantly for me.  The actual use case is a Google Map showing the location of various Communities (a custom object).  The user can select several Communities (from a sidebar with a list of accounts & checkboxes), then click a single button to create "Referrals" (a custom object) to each selected Community, and email each Community's primary contact with their Referral data.  After the click, the user waits a moment, and then multiple tabs open up, one for each newly-created Referral.

I'm happy to discuss further if anyone is interested or needs help doing something similar - glenn@appirio.com.

Message Edited by GlennAtAppirio on 02-18-2007 01:05 PM

Message Edited by GlennAtAppirio on 02-18-2007 01:05 PM

Can I send an email through Scontrol? On running SControl I want to send email notification to specific users....
Can it be done usinf SControl?
If Yes then how?
Waiting for reply.