• Sai Lavu
  • 0 Points
  • Member since 2008

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 3
  • 9
I have a VF page with a tab panel and two tabs. When I click on the printable view it always displays the right most tab's details. In other words, based on the code snippet below, even when the Account tab is selected the printable view still shows details from the Account Stuff tab.
If I change switchType on the tab panel to server then the printable view works as I expect it to but the return URLs don't work.
<apex:page standardController="Account" showHeader="true" tabStyle="Account" extensions="AccountExtension">
    <apex:tabPanel switchType="client" selectedTab="tabDetails">
        <apex:tab label="Account" name="AccountDetails" id="tabDetails">
            <apex:detail subject="{!Account__c}"/>
        <apex:tab label="Account Stuff" name="AccountStuff" id="theAccountStuffTab">
            <apex:detail subject="{!accountStuff}" relatedList="true" rendered="{!(accountStuff != null)}" />

Is it a case of RTM or is this a bug?
A similar issue has been reported here.

Message Edited by Sai Lavu on 10-03-2008 12:50 AM
Am sure this is something silly...
I delete a contact & run the following SOQL but get no results - I have read access on that Contact.
SELECT Id, isDeleted FROM Contact WHERE isDeleted = true

Any clues?
I got SFDC support to enable Person Account on one of our Sandbox, let's call it Dev1. Did the development on it and attempted to deploy the changes to our UAT sandbox, which also had the Person Account enabled, using Force.com IDE.
1. The Force.com IDE does not retrieve the Person Account record types when you open the Account.object file from Dev1 even after multiple refresh from server attempts. I've got the setting below in the package.xml too. Am I missing something?

2. I also get the following error for the page layout when I validate the deployment
# Deploy Results:
   Name:    unpackaged/layouts/Account-REC Marketing Individual.layout
   Action:  NO ACTION
   Result:  FAILED
   Problem: Layout must contain an item for required layout field: ParentId

Help appreciated. Thanks.
Hi Folks,
Does anyone know how to identify the list of all the images available in salesforce ? I wanted to include a image in my visualforce page and hence got stuck there without knowing the path for the image.

Am sure this is something silly...
I delete a contact & run the following SOQL but get no results - I have read access on that Contact.
SELECT Id, isDeleted FROM Contact WHERE isDeleted = true

Any clues?
I have created a custom object, at the time of creating this I have mapped this to Opportunity object using look up
After creating this custom object, Iam able to add the records By Clicking on  the new button i.e manually
But if I try to insert programatically by using Apex code, Iam not getting any errors but the record that is inserted is not visible
what sort of settings I have to do, can any one please help me to solve this issue
Hi Folks,
                   I have crated 2 custom objects: AR__c and Opportunity_Invoice__c
Now i nvoked a trigger on a AR__c object so once i save any record in AR_c object the trigger should fire and  create a new record in  Opportunity_Invoice__c  object .
my code is follows:

trigger ARPTrigger on AR__c (before insert) {

for(AR__c arpc : Trigger.new){
String text=' Invoice';

and my class is follows:

public class OpportunityInvoice{
public static void createOppInvoice(Date invoiceDate,String invoiceLineDesc,String Name){
Opportunity_Invoice__c record= new Opportunity_Invoice__c();
Opportunity_Invoice__c[] oppInvoice = new Opportunity_Invoice__c[]{record};
// Attempt to insert it...
insert oppInvoice ;

compilation successful(Tested this using test methodsee the log )

Debug Log

 *** Beginning Test 1: OpportunityInvoice.public static testMethod void testIcreateOppInvoice()

20080529040720.360:Class.OpportunityInvoice.testIcreateOppInvoice: line 17, column 9: 1
20080529040720.360:Class.OpportunityInvoice.testIcreateOppInvoice: line 19, column 9: date:2008-05-28 00:00:00
20080529040720.360:Class.OpportunityInvoice.testIcreateOppInvoice: line 21, column 9: Invoice descriptionFirst Invoice Line Desc
20080529040720.360:Class.OpportunityInvoice.testIcreateOppInvoice: line 26, column 9: Name:Best Invoice
20080529040720.360:Class.OpportunityInvoice.testIcreateOppInvoice: line 27, column 9: oppInvoice:(Opportunity_Invoice__c:{Date__c=Wed May 28 00:00:00 GMT 2008, Line_Description__c=First Invoice Line Desc, Name=Best Invoice})
20080529040720.360:Class.OpportunityInvoice.testIcreateOppInvoice: line 28, column 9: Insert: LIST:SOBJECT:Opportunity_Invoice__c
20080529040720.360:Class.OpportunityInvoice.testIcreateOppInvoice: line 28, column 9: DML Operation executed in 26 ms
20080529040720.360:Class.OpportunityInvoice.testIcreateOppInvoice: line 29, column 9: Inserted:
20080529040720.360:Class.OpportunityInvoice: line 12, column 35: returning from end of method public static testMethod void testIcreateOppInvoice() in 28 ms

Cumulative resource usage:

Resource usage for namespace: (default)
Number of SOQL queries: 0 out of 100
Number of query rows: 0 out of 500
Number of SOSL queries: 0 out of 20
Number of DML statements: 1 out of 100
Number of DML rows: 1 out of 500
Number of script statements: 14 out of 200000
Maximum heap size: 0 out of 500000
Number of callouts: 0 out of 10
Number of Email Invocations: 0 out of 10

Total email recipients queued to be sent : 0
*** Ending Test OpportunityInvoice.public static testMethod void testIcreateOppInvoice()

but when i crate a record in custom object the trigger should fire and call the class

and insert record in to Opportunity_Invoice__c object but no record is inserted in to Opportunity_Invoice__c object
when i created a record in AR__c object, can u suggest me , how can make this successful.

Hi there,

I generated an APEX class from the following WSDL file - http://sdpws.strikeiron.com/sdpZIPCodeInfo?WSDL from strikeiron.

I then created the following APEX Trigger -

trigger UpdateCounty on Lead (before insert, before update)
        for (Lead lead: System.Trigger.new) {
               if (lead.County__c == null){
               wwwStrikeironCom.SDPZipCodesSoap oZipCodeLookup = new wwwStrikeironCom.SDPZipCodesSoap();
               oZipCodeLookup.LicenseInfo = new wsStrikeironCom.LicenseInfo();
               oZipCodeLookup.LicenseInfo.RegisteredUser = new wsStrikeironCom.RegisteredUser();
               oZipCodeLookup.LicenseInfo.RegisteredUser.UserID = 'sanand@kbb.com';
               oZipCodeLookup.LicenseInfo.RegisteredUser.Password = 'sumajee76';
               wwwStrikeironCom.ZipCodeOutput oLookupResult = oZipCodeLookup.GetZipCode(lead.County__c);
               lead.County__c = oLookupResult.ServiceResult.ZipCodes.ZipCodeInfo[1].County;

I need to be able to automatically populate the COUNTY field under LEADS object based off the info the user enters in the web-to-lead form. That means, the zipcode should be captured and based off this COUNTY field should be updated or filled in the LEADS form.

When I create the new LEAD and enter zipcode - hoping that when this record is saved I would see the COUNTY field uploaded - it gives me this error message;-


Force.com Sandbox


Apex script unhandled trigger exception by user/organization: 005300000010lx0/00DT0000000F6LV


UpdateCounty: execution of BeforeInsert


caused by: System.CalloutException: Callout from triggers are currently not supported.


Class.wwwStrikeironCom.SDPZipCodesSoap.GetZipCode: line 94, column 13

Trigger.UpdateCounty: line 10, column 63


Any ideas?

Hi all,
I've been involved with SF customization for about 6 months now, and I'm just starting to dig into the more advanced features.  Right now I'm trying to solve a sharing / record visibility problem.  You can read a detailed description in this forum: http://community.salesforce.com/sforce/board/message?board.id=discuss&thread.id=6846 but essentially what I'm trying to implement is conditional sharing / visibility, based on some value.  What I want to occur is, when the checkbox 'Visible to Client A' is checked, the public group 'Client A' needs to get visibility of that record.  This can be done through manual sharing, but that is obviously tedious and I would like to automate that process.
Outbound Messaging came up as a potential solution.  Can anyone point me in the right direction about how to make this happen?
Thanks a ton.
I've set up a custom button to clone account records (don't ask - it's a long story).  Everything checks out ok but I can't get a multi-select field to pass through to the new record.  I've tried everything.  Here's what I am using.  The bold red line is the one that isn't working.




For some reason the excel connector for PE has stopped working and we desperately need some help.

First it worked great, but then it was moved. We then followed the instructions below, deleted all signs of the excel connector on the computer, restarted, re-installed the excel connecter, and did everything possible - but we can’t get the excel connector back to working.

Each time we re-install, re-add the Add-in (or replace it), and then go to re-add the sforce connector toolbar, it gives us the same error that it cannot be found and is still looking for it in the original place it was – the first time it was installed.

Is there any way to fix this?

We’ve been trying everything on the discussion board, including the instructions below from the FAQ and still cannot get it to work.

I already tried this:
Open Excel
Click Tools, Add-Ins
Uncheck the sforce_connect checkbox, click OK
Close Excel
Open Excel again, if the "sforce_connector" menu bar is still there, right click on the tool bar area of excel, uncheck the sforce Connector check box
Close Excel
Open Excel
If the bar is gone and the Add-INs list is showing the add-in as unchecked or gone then you can re-install the add-in from the new file location of the XLA, see the install instructions on the web (http://sforce.sourceforge.net/excel/index.htm)


Thanks so much!