• SubashKumar
  • 0 Points
  • Member since 2008

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 5

I am having a Visualforce page where I should render a google visualization chart. In the same page, I need to render details of an account using <apex:detail> tag with relatedListHover set to On.


For some reason these two when tried on the same page does not work. Though the hover links appear, the area below it is blank when we hover over the links.


I monitored javascript error console and it says "iFrameDoc.body is null". How ever if I remove the google.load () call from the page, the hover works perfectly.


Does some one have a work around for this ?



I have embedded a VF page in account detail page layout. All Account detail page should show the VF page. How ever each user should have the ability to turn on or turn off the VF page. This property will be controlled by a flag in User object. No separate profile will be assigned to show the VF page.


I though that using javascript, I can set the height of the iframe  which renders the VF page. If I set the height this can be achieved. How ever There is permission error as there domains are different.


Can any one suggest any idea to achieve this?






I want to get the last modified date of a custom object definition in Apex or via WS.  Schema.DescribeSObjectResult doesn't have a method like getLastModifiedDate.  But this info is clearly available in the custom object definition detail page.  Is there anyway to get this in the Apex code?  Similarly I want to know the last modified date of a custom field definition, and I'm facing the same issue.


I also check the meta data API reference and cannot find anyway to get the last modified date of custom object definition.


Please point me to the right direction.




-Qin zhang

  • January 21, 2011
  • Like
  • 0

Got a problem where richtext fields don't save on a Visualforce page. They show up just fine in view and edit mode on the VF page. I can put data and pictures in them from the standard UI but when I add anything to the richtext fields on the VF page and click Save those fields aren't saved. Every other field on the page is saved, just not the richtext fields. The page and controller are both on version 19.0 and all development (and testing) is being done on in a dev org, not Eclipse.


Am I doing something wrong here?


Here's the relevant code:


public class contactEditController
  ApexPages.StandardController controller;
  public Contact con;

  public olesContactEditController(ApexPages.StandardController c)
    controller = c;

    // Get the current record.
    this.con = (Contact)controller.getRecord();


  // Override standard save to NOT return a page reference.
  // This lets us close the popup window via javascript.
  public PageReference save()
    return null;

        <apex:pageBlockButtons location="bottom">
          <apex:commandLink action="{!save}" value="Save" oncomplete="closeWin(true);" title="Save changes" />
            <apex:outputLabel for="relationship">Relationship:</apex:outputLabel>
            <apex:inputField id="relationship" value="{!Contact.Relationship__c}" />







We have enabled Chatter in our org. and the number of records in Feed Track Changes increased our storage space so we were not able to load any more data.


When I tried to delete each feed from the Standard Object feeds like Accountfeed, Contactfeeds etc. there  were no data available in those objects. But the number of records in the Feed Track Change object still remained the same.


I tried to delete the feeds of Custom Objects as well but I did not find any records in them as well.


Can anyone provide me a solution of where can i search for these feeds in order to delete them??


Is there an easy way to delete all the feeds together rather than deleting each Objects feeds individually???


Thanks in advance.




  • July 19, 2010
  • Like
  • 0



I was trying to perform a quick test on my Apex Web Service (Apex method with webservice annotation).

The online help on using web service WSDLs in Apex callouts mentions that 'only one loopback connection to Salesforce domain is allowed.' So I guess I should be able to use Apex callout feature to test this Apex web service hosted in same org i.e. loopback test. Further, I guess should be able to make an Apex callout to another Apex Web Service in another org.


Question is: how do I connect to same/another Salesforce org using Apex callout? In other words, what's the equivalent in Apex of login() call in Web Services API that returns session Id to be used in subsequent calls? 


Since my Apex Web Service and Apex client (generated from the WSDL of Apex web service) are in same org, I tried using current session id to connect to this service, but it failed with SOAP fault INVALID_SESSIONID.


How do I obtain correct session id using Apex?


Although Salesforce-to-Salesforce feature can be used to access Salesforce data from another org, I can see legitimate use cases where a web service hosted in one org needs to be accessed from another org.


Any tips, hints, code snippets would be highly appreciated.