• joe_armitage
  • 0 Points
  • Member since 2008
  • Developer
  • Gateshead Consulting

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 11
I would like to know the correct way to logout/disconnect from a session that I attach to from an outbound message using the logged in user's session id. If I catch an exception repeatedly, I eventually get an out of memory error in the TomCat 5 Server that is running my web service.
Do I need to explicitly logout and/or disconnect from my session to release memory on a normal or an abnormal exit from my process ?.
Also, if if anyone can point me to detailed documentation on the Dead Letter queue feature I would appreciate it. We are tying to decide on the best strategy for notifying the user of the success/failure of the outbound message delivery and processing. Should we let exceptions roll back to SalesForce, or try to handle them ourselves ?.
Hi, in the Trailhead module 'Subscribe to a Platform Event' I am getting the following error:
"The 'cometd' static resource was not found. Check for typos."

The static resource exists and is spelt correctly and the notifications are working perfectly - just the Trailhead gives an error. I've gone through this 3 times now and always the same error. Can anybody help at all please?
<aura:component >
	<aura:attribute name="item" type="Camping_Item__c" required="true"/>

	<ui:outputText value="{!v.item.Name}" />
	<ui:outputCheckbox value="{!v.item.Packed__c}" />
	<ui:outputCurrency value="{!v.item.Price__c}" />
	<ui:outputNumber value="{!v.item.Quantity__c}" />
	<ui:button label="Packed!" press="{!c.packItem}"/>
	packItem : function(component, event, helper) {
		var button = event.getSource().get("v.disabled");
		component.set("v.item.Packed__c", "true");
		component.set(button, "true");
What am I doing wrong?


I'm having trouble checking the challenge, I've checked other discussions and I've done exactly what others have done to pass but everytime I click check challange it gives me this error message:

Looks like something went wrong, please try again later.

I've logged out of both Developer Edition and Trailhead acc, used another new Developer Edition to redo the challenge and it gives me the same message.

I'm trying to complete the Importing Data module, and after I download the CSV file and attempt to upload it, I continue to get this error:

There was a problem uploading the CSV file. Try again, or choose another file.

This has happened to me in the past when usnig the import wizard but I cannot recall how I moved past the error.



I am creating a visualforce page, In that i have added 16 columns and column values are all dropdowns. There is also an expand view i.e "+" when clicked on this "+" another set of dropdowns are added for all the columns at a time.The first row of the table is created dynamically using visualforce components but when we add rows (i.e by clicking "+") those are done through javascript and i have given the dropdown values in the javascript but how to make it dynamic using Apex Class and Visualforce Components.

Can any one help me out in this.




I'm configuring multiple outbound messages for multiple objects.So do I have to develop multile webservices or one
webservce is enough for all the outbound messages.
thanks in advance
I have created a very simple page to simply display a list of Accounts.  I am trying to make this list visible on a Sites page so I can demo some functionality to my team. 

Nothing I've tried yet has allowed me to display any object data, though the page renders fine within SFDC. 

Here's the code for the page.

<apex:page standardcontroller="account" showheader="true" recordsetvar="accounts">

<apex:form >
    <apex:pageblock title="All Accounts">
<apex:pageblockTable value="{!accounts}" var="a"> <apex:column value="{!a.Name}"/> <apex:column value="{!a.createddate}"/>
</apex:pageblock> </apex:form> </apex:page>

I have made sure that the Field Level Security is set to "Visible" for these fields.  Also, the Site Page Profile has "Read" Access to the Account object.

Can anyone recommend other things I should be looking at to get this (very simple) page to display? 

Thanks for any ideas!

I am trying to send emails using the 'sendMail' call. to achieve this I have upgraded to the v10 wsdl. I can now use the call but recieve the follwing error from the endpoint:

'UNSUPPORTED_API_VERSION: This call requires a minimum API version of 9.0. Please upgrade to the latest version of the WSDL.'

Any ideas?