• reatlimeco
  • 0 Points
  • Member since 2009

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 23
  • 28
This problem seems to start when I run a new test from the developer console, change the code, then do a rerun of the test.  I did an error that the Id doesn't exist but yet it seems to start TWO tests, one that seems to run forever, and the retry with the expected failure.

I get no debug logs after this even after hours of waiting.

I tried to abort the running test but it says that I have to wait for it to finish.

I tried deleting all the debug logs to make sure that it was a space issue and then restarted the developer console.

Tried going a new test but the debug log doesn't appear.

I then tried running the test from the Setup menu and looked at the Debug Logs and there are still NONE.

Anyone else seeing this problem?  Any other work around to this problem?   Anyone know how long these tests are allowed to run before they get reset.

I notice that after a week.  It works again but only works for the first new test, then the rerun fails in the same way again!
Seems to start when I run a new test then try to run the test again after I update the code.

I get an error back from developer console when I do the rerun that the Id doesn't exist but yet it starts something that seems to run for ever but it also starts the test which completes but the debug log never shows up in the developer console.

I tried to abort the test but it says that I have to wait for the test to finish.

I tried deleting all the debug log under set up and restarting the developer console.  It shows no delog logs.

I tried to uncheck the show only current debug logs and it still shows all the debug logs that I deleted via setup.

But even if I run a new test, I get the test information under the Test tab but nothing shows up under the Log tab.  THis has been going for weeks now.

Anyone else see this problem?  Is there a work around? 

If I come back to it after a week, I can run the new test and get one debug log but if I try to do a rerun I still get the error and get NO MORE debug logs after that.
Is there a need for a team of Salesforce contractors with experience in every aspect of Salesforce with clients from start up to multi-billion dollar, multi-national corporation including Architect, Business Analyst, Sr. Developer, Scrum Master, and QA developer as well as program/project manager?

apex:axis fails if you try to bind to "fields"


apex:barSeries fails if you try to bind to "orientation"

A silent failure occurs with apex:axis on the fields attribute as well as with the orientation attribute on apex:barSeries.


These are obvious failures that Salesforce testing should have found.

Could have swarn that it returned all objects in the past.   Does anyone know why it doesn't return the objects from other 3rd party objects loaded into the customers org?


Anyway to get ALL the objects including 3rd party objects

I have done launched and relaunched Sales Cloud and Service Cloud implementations as well as Custom Clouds including integration with ERP and other systems since 2002.


Whether you need someone to help architect your solutions, provide visual force pages or components, provide batch jobs or triggers for use with Salesforce CRM, Sites, or Custom application,  I have done it all.


Also, I am excellent problem solver and strong analytic skills to unravel the most complex data issues.


If you have a implementation at risk or previous implementation doesn't scale that's ok.   Very quick turn around to put you back on schedule.


Immediate availability.


David Mosher



There are a few more case where this non-descript error is thrown.


[1]  If you don't have a <apex:messages /> declared in the page of the controller and you add a Apexpages.add to your apex you will get this error with out a line number

[2] If you leave off a system name spacce like ApexPages  (e.g., new Message( ...) instead of  new ApexPages.Message (...) you will also get this error


Would be very helpful the error included the specific name of the object or method that can't be resolved.

I am looking for a way to get a list of the fields that have changed from within a trigger that doesn't require getting the full list of fields on an object and looping through them to find out which changed, which is going to use up a lot of cycles of the governor limit doing this.

Contact Biz Performance Solutions for additional information.


or email me

23:28:42.064 (1064722000)|DML_BEGIN|[169]|Op:Insert|Type:OpportunityLineItem|Rows:3

23:28:42.064 (1064744000)|HEAP_ALLOCATE|[EXTERNAL]|Bytes:16

 23:28:42.070 (1070062000)|DML_END|[169]

23:28:42.071 (1071501000)|FATAL_ERROR|Internal Salesforce.com Error

23:28:42.760 (1071567000)|CUMULATIVE_LIMIT_USAGE


Number of SOQL queries: 48 out of 100  

Number of query rows: 550 out of 50000  

Number of SOSL queries: 0 out of 20  

Number of DML statements: 16 out of 150  

Number of DML rows: 50 out of 10000  

Number of script statements: 1519 out of 200000  

Maximum heap size: 0 out of 6000000  

Number of callouts: 0 out of 10  

Number of Email Invocations: 0 out of 10  

Number of fields describes: 0 out of 100  

 Number of record type describes: 0 out of 100  

Number of child relationships describes: 0 out of 100  

Number of picklist describes: 0 out of 100  

Number of future calls: 0 out of 10

Implement layout changes including separating and creating new recordtypes.  

Implement or change existing workflow including time-based and email templates.

Implement updates to profiles


Investigate issues including access issues and resolve the problem with the end user.


Experience with ERP environments and the process flows is extremely helpful.


This is an account with 2000 salesforce users.


This engagement starts in November and may end in February.


Contract to hire may be an option.


Apply through me    Send resume then we will schedule a time to talk.   I will be your resident expert for this engagement.

Is there a way to use the Google Doc authentication that a Salesforce org already has to store/retrieve documents from an organization's exisitng Google Doc account?


If not, the example of authenication shows a visualforce page to capture and generate the authenication token.   Is it possible to do the authenication instead in an apex class where the account name and password would come from the "Configuration" object instead.  If so, can someone post an example of how this is done.

I have extensive experience in Force.com and Sites, including Apex, triggers, components, and packaging as well as Salesforce.com setup and administration.  I can also provide project management and information architecture services as well as data cleanup and migration.


David Mosher



Message Edited by reatlimeco on 03-22-2010 02:35 PM

<apex:inputField value="{!theirTask.Subject}" /> <apex:inputField value="{!theirTask.description}" /> <apex:inputField value="{!theirTask.priority}" /> <apex:inputField value="{!theirTask.status}" /> <apex:inputField value="{!theirTask.ActivityDate}" />


Task newTask = new Task(); Public Task theirTask { get { newTask.WhoId = cId; return(theirTask);} set; }


<apex:inputField value="{!si.response.Institution__c}" rendered="{!si.question.Lookup__c == 'Institutions'}" /> <apex:inputField value="{!si.response.Activity__c}" rendered="{!si.question.Lookup__c == 'Activities'}" />



public class SurveyItem { public Question__c question {set;get;} public Response__c response {set;get;} public Invitation__c invite {set; get;} public List<SelectOption> answers {set; get;} public String answerType {set; get;} public SurveyItem (Question__c q,Invitation__c i,Response__c r, List<SelectOption> a, String atype ) { question = q; system.assert( q != null ); invite = i; system.assert( i != null ); response = r; system.assert( r != null ); system.debug(this); answers = a; answerType = atype; } }


Field Label
Data TypeControlling FieldModified By
Edit | Del Lookup(Activity)  David Mosher, 2/3/2010 8:21 PM
Edit | Del Lookup(Contact)  David Mosher, 1/31/2010 8:41 PM
Edit | Del Email  David Mosher, 2/3/2010 11:01 PM
Edit | Del Lookup(Account)  David Mosher, 2/3/2010 8:20 PM
Edit | Del Lookup(Invitation)  David Mosher, 1/31/2010 9:04 PM
Edit | Del Text(255)  David Mosher, 1/31/2010 8:42 PM
Edit | Del Phone  David Mosher, 2/3/2010 11:00 PM
Edit | Del Lookup(Question)  David Mosher, 1/31/2010 9:10 PM


Public Settings has read on Accounts (aka Institutions) and Activities (custom object not standard object).

These fields with lookups all have field level access made visible.


I have made the standard lookup page available via the Customer Portal page settings.

Here is the visualforce code:


<apex:detail subject="{!$User.contactId}" relatedList="true"/>


Trying to let the Portal user edit their own contact record including custom fields.



The profile of the Portal user has Read and Edit checked for Contact records also.

Here is the Visualforce page running under Sites:


<apex:pageBlockTable title="Educational History" value="{!Educational_Records}" var="er"> <apex:column value="{!er.school__r.name}"/> <apex:column value="{!er.start_date__c}"/> </apex:pageBlockTable>




The controller code is:


Public List <EducationalHistory__c> Educational_Records {get; set;} public portalController() { System.debug('portalController'); String uId = UserInfo.getUserId(); User u = [select Id, ContactId from User where ID = :uId Limit 1]; String cId = u.ContactId; UserContact = [select Id, firstname, lastname, homephone, mobilephone, otherphone, mailingstreet, mailingcity, mailingstate, mailingpostalcode,Text_Message_Enabled__c,Best_way_to_contact__c, email, alternative_email__c, access_to_computer__c, access_to_internet__c, social_networks__c, otherstreet, othercity, otherstate, otherpostalcode, birthdate,gender__c,race_ethnicity__c, high_school_status__c, high_school_graduation_year__c,residence__c,college_status__c,actual_post_secondary_school__c,original_post_secondary_school__c,current_post_secondary_school__c, employment_status__c,employer__c,occupation__c,career_objective__c,hours_per_week_worked__c,hours_per_week_worked_range__c,military_status__c, alumni_ambassador_assignment__c,high_school_counselor_assignment__c from contact where Id = :cId LIMIT 1]; if (UserContact == null) { System.debug('UserContact not set'); } Educational_Records = [select Name,school__c, start_date__c, end_date__c, class__c, status__c, type__c, earned_credits__c, gpa__c from educationalhistory__c where alumni__r.id = :cId]; if (Educational_Records == null) { Educational_Records = new List <EducationalHistory__c> (); } }


The debug log shows that the SOQL is made and gets a record to return to set the variable.


I have a sharing on this object to share with All Portal Users Read/Write.


This is within a page that requires authenication and the user is logged in at the time when the page is rendered and not even the title renders.


Anybody have any ideas why this is happening.

VF page: recordSetVar="filteredSet"\> Component: Component controller: public [] componentControllerSet { get; set;} If I try to iterate through this set, I get the following error which suggests that the typing is wrong: [Lcore.apexpages.el.adapters.metadata.AbstractSObjectELAdapter; cannot be cast to common.apex.runtime.impl.IterableValue This changes if I change the processing to try to handle it as List .
How custom labels can be used in the picklist. While creating a picklist field, can we directly refer the values from the Custom labels?. I know about the translation settings, but what I want, I don't want the picklist values to be hardcoded, since the picklist value is referred in Apex coding in multiple place. And Hence, a change in Picklist means, I have change every where in the code. What is the best solution to such scenario?

apex:axis fails if you try to bind to "fields"


apex:barSeries fails if you try to bind to "orientation"



I am trying to create multiple charts on a VF page by including the apex:chart component inside an apex:repeat or apex:datatable component. I have created a wrapper class that includes field elements as well as chart data. I expected that when the page is renderd, the structure would be as follows










however, when the page renders, all charts included inside the span of the first row. eg..










I am not sure if I am doing something wrong here or if this is a bug. My VF code is as follows..

<apex:dataTable var="f" value="{!achievements}">
<apex:column >
<apex:outputText value="{!f.oInstance.Account__r.Name}"/>
<apex:column >
<apex:chart height="125" width="285" animate="true" data="{!f.ChartData}">
<apex:axis type="Gauge" position="gauge" title="{!f.ChartData[0].data1}%" minimum="0" maximum="150" steps="5"/>
<apex:gaugeSeries dataField="data1" labelField="label" needle="false" donut="65" colorSet="#78c953,#ddd"/>


I also tried to solve this issue by trying to force the chart to render inside a specific component using the renderto attribute. However, this required use of a variable to generate dynamic ids for the components and as of now this doesn't seem to be supported. The error message asked me to use a literal value for the id attribute.


Please help!!!



Alok Agrawal


i write a visualforce page with source code

<apex:page controller="MyController1">
<apex:pageBlock >
<apex:pageBlockSection  id="search">
<apex:commandLink action="{!commandLinkAction}" value="Advance Search"  reRender="thePanel" id="theCommandLink"/>
<apex:outputPanel id="thePanelWrapper">
<apex:outputPanel id="thePanel" rendered="{! rend}" layout="block">My div</apex:outputPanel>

and the MyController1 class is

public class MyController1{
public Boolean rend{get;set;}
public PageReference commandLinkAction(){
return null;


when i click on Advanced Search link nothing happens but i was expecting outputPanel with id "thePanel" should render.why it is not rendering please someone explain??

This is a high level Design/Developer/Architecting of an existing SFDC environment custom integrated with SAP.  We will be adding SAP CRM and are looking for someone to integrate functionality with Salesforce.com.  


Expert knowledge in ERP landscape, APEX, Force.com, Visual Force and Web Services is a must.


Salesforce Certification a bug plus.


Major Areas of Accountability:

  • Works to develop concepts and designs that meet or exceed the requirements when developing new systems.
  • Develops concepts and designs for support of existing systems.
  • Works to estimate schedule on assigned projects and tasks.
  • Creates the required design specifications to allow customers and other personnel to accurately review the proposed solution, and creates designs which optimize personnel and technical resources.
  • Implements designs in a manner consistent with appropriate standards and guidelines.
  • Thoroughly tests and debugs programs, applications, and systems, working with other personnel to complete implementation within appropriate life cycle requirements.
  • Identifies and solves problems efficiently, creatively, and effectively, staying organized and clear headed throughout troubleshooting process.
  • Effectively uses diagnostic tools to provide insight into the problem.
  • Completes assigned tasks within the time allocation.
  • Promptly informs supervisor or other appropriate personnel of any significant events that would result in schedule delays. Shows perseverance and strong follow through.
  • Provides training appropriate to expertise level to other personnel and customers as required.
  • Performs other duties as assigned.

Education & Skills:

  • Bachelor’s degree in technical field & 8 yrs progressively demanding project / design experience; or
  • AA / Vo-Tech degree in a technical field & 10 yrs relevant technical experience; or
  • 14 yrs relevant technical experience.

23:28:42.064 (1064722000)|DML_BEGIN|[169]|Op:Insert|Type:OpportunityLineItem|Rows:3

23:28:42.064 (1064744000)|HEAP_ALLOCATE|[EXTERNAL]|Bytes:16

 23:28:42.070 (1070062000)|DML_END|[169]

23:28:42.071 (1071501000)|FATAL_ERROR|Internal Salesforce.com Error

23:28:42.760 (1071567000)|CUMULATIVE_LIMIT_USAGE


Number of SOQL queries: 48 out of 100  

Number of query rows: 550 out of 50000  

Number of SOSL queries: 0 out of 20  

Number of DML statements: 16 out of 150  

Number of DML rows: 50 out of 10000  

Number of script statements: 1519 out of 200000  

Maximum heap size: 0 out of 6000000  

Number of callouts: 0 out of 10  

Number of Email Invocations: 0 out of 10  

Number of fields describes: 0 out of 100  

 Number of record type describes: 0 out of 100  

Number of child relationships describes: 0 out of 100  

Number of picklist describes: 0 out of 100  

Number of future calls: 0 out of 10

Is there a way to add more selections into a multi-select pick list using apex? If there is a code sample or a link to some documentation would help. Thanks. 

We are in the process of creating a client portal based on SFDC customer portal and our own content and reports.  We needa developer familiar with customizing the look and feel, reporting and "custom" functionality we'd like to deploy in the portal - all while using SFCD user profiles to drive what clients can see and access.  We also need to integrate SFDC data and non-SFDC data together in reports, charts, etc.


If you have experienc with these issues please contact me and provide a summar of relevant experience.



Hi Folks,
we created public site on a customer portal and while  inserting few opportunitylineitems for a newly created opportunity we are getting this error..

"Insert failed. First exception on row 0; first error: INSUFFICIENT_ACCESS_ON_CROSS_REFERENCE_ENTITY, insufficient access rights on cross-reference id: []"

The steps are..

#1 Insert a opportunity..

#2 Insert Few opportunitylineitems on the basis of some buiseness logic for the opportunity created in step1

Sample code is something like this.
ContactId= CurrentLoggedUsersContactId ;
Opportunity Opp = new Opportunity(with all required details filled......);
insert  Opp;
OpportunityLineItem Oli = new  OpportunityLineItem (Contact__c = ContactId,UnitPrice=40.0,PricebookEntryId=01uT0000000pbcuIAA,OpportunityId= Opp.Id);

Insert Oli;//Error comes right at this line of code 
I check all the 3 Ids provided in insert call are valid.
This thing was working fine before the spring 10 release.

IS this because of the new release??

Please guide if any one knows or faced a similar problem.

Nikhil Jain
  • February 01, 2010
  • Like
  • 0

Hey Guys,


Is there a sample of doing a multi-select list in VF just like the built in one where you can move values back and forth between a selected and unselected boxes?




I'm working on extending the Sorting Tables example from the wiki: http://wiki.developerforce.com/index.php/Sorting_Tables


I'd like the user to be able to enter some filter criteria and then see a sortable table of the results. One of the filter criteria is a checkbox for "Include Details." If this box is checked, the user should get a sortable table; if not, just some summary data. 


The problem that I'm running into is that adding a rendered="{!includeDetails}" attribute to the details pageBlock breaks my sorting action --- clicking on a column heading no longer does anything. Without the rendered attribute, both doFilter and doSort work correctly; with the rendered attribute, doFilter works and outputs a table, but it isn't sortable.



<apex:page controller="forecastClass" tabstyle="Opportunity" sidebar="false"> <apex:form > <apex:pageBlock title="Filter Criteria"> <table cellpadding = "4" cellspacing = "4"> <tr> <td><label><b>Site: </b></label></td> <td><label><b>Start Date: </b></label></td> <td><label><b>End Date: </b></label></td> <td><label><b>Include details? </b></label></td> <td></td> </tr> <tr> <td><apex:inputField value="{!filterOp.Site__c}"/></td> <td><apex:inputField id="StartDate" value="{!filterOp.CloseDate}" /></td> <td><apex:inputField id="EndDate" value="{!filterOp.Confirmation_Date__c}" /></td> <td align="center"><apex:inputField id="IncDetails" value="{!filterOp.Anonymous_gift__c}" /></td> <td><apex:commandButton value="Go" action="{!doFilter}" rerender="container"></apex:commandButton></td> </tr> </table> </apex:pageBlock> </apex:form> <apex:outputPanel id="container"> <apex:pageBlock id="opDetails" title="Opportunity Details" rendered="{!includeDetails}"> <!-- remove rendered attrib for sorting --> <apex:form > <apex:pageBlockTable value="{!opps}" var="o" id="table"> <apex:column > <apex:facet name="header"> <apex:commandLink value="{!$ObjectType.Opportunity.Fields.Name.Label}" action="{!doSort}" rerender="table"> <apex:param name="sortField" value="Name" assignTo="{!sortField}"/> </apex:commandLink> </apex:facet> <apex:outputLink value="/{!o.id}">{!o.name}</apex:outputLink> </apex:column> <apex:column > <apex:facet name="header"> <apex:commandLink value="{!$ObjectType.Opportunity.Fields.StageName.Label}" action="{!doSort}" rerender="table"> <apex:param name="sortField" value="StageName" assignTo="{!sortField}"/> </apex:commandLink> </apex:facet> <apex:outputField value="{!o.StageName}"/> </apex:column> <apex:column > <apex:facet name="header"> <apex:commandLink value="%" action="{!doSort}" rerender="table"> <apex:param name="sortField" value="Probability" assignTo="{!sortField}"/> </apex:commandLink> </apex:facet> <apex:outputField value="{!o.Probability}"/> </apex:column> <apex:column > <apex:facet name="header"> <apex:commandLink value="{!$ObjectType.Opportunity.Fields.CloseDate.Label}" action="{!doSort}" rerender="table"> <apex:param name="sortField" value="CloseDate" assignTo="{!sortField}"/> </apex:commandLink> </apex:facet> <apex:outputField value="{!o.CloseDate}"/> </apex:column> <apex:column > <apex:facet name="header"> <apex:commandLink value="{!$ObjectType.Opportunity.Fields.Amount.Label}" action="{!doSort}" rerender="table"> <apex:param name="sortField" value="Amount" assignTo="{!sortField}"/> </apex:commandLink> </apex:facet> <apex:outputField value="{!o.Amount}"/> </apex:column> <apex:column > <apex:facet name="header"> <apex:commandLink value="Revenue" action="{!doSort}" rerender="table"> <apex:param name="sortField" value="Time_Restriction__c" assignTo="{!sortField}"/> </apex:commandLink> </apex:facet> <apex:outputField value="{!o.Time_Restriction__c}"/> </apex:column> <apex:column > <apex:facet name="header"> <apex:commandLink value="Type" action="{!doSort}" rerender="table"> <apex:param name="sortField" value="Type" assignTo="{!sortField}"/> </apex:commandLink> </apex:facet> <apex:outputField value="{!o.Type}"/> </apex:column> <apex:column > <apex:facet name="header"> <apex:commandLink value="Owner" action="{!doSort}" rerender="table"> <apex:param name="sortField" value="OwnerId" assignTo="{!sortField}"/> </apex:commandLink> </apex:facet> <apex:outputField value="{!o.OwnerId}"/> </apex:column> </apex:pageBlockTable> </apex:form> </apex:pageBlock> <!-- opDetails --> </apex:outputPanel> <!-- container --> </apex:page>



  • September 30, 2009
  • Like
  • 0

When I run lookup of an account in a sites VF page the search does not return any results. I have territory turned on.


It works fine in salesforce with the same VF page. I suspect that I need to assign my site user to a territory, but how?


I can not find a way to assign the site user to a territory anywhere.


Can someone point me in the right direction?





The role is set up not to allow the edit of the basic info on an account, but we would like for the user to be able to make a note or attach an email or document to an account. Since the note section is a separate field and does not respond when edits are made to the account it would seems that it should be allowed. The only way I have been able to allow this function is to give them full edit rights, please tell me if there is a way to allow notes without allowing a change on the entire account info.


Thanks, Janice  

  • August 07, 2009
  • Like
  • 0

I have an order form that uses a collection of components that has content that is dynamically generated.  Each instance of the component checks a local variable to determine if certain content needs to be rendered.  I've noticed that once a 'false' is encountered for the component, all subsequent rendering of that component element is also rendered false.  So I skinnied this down in a different sandbox environment so that SF could have a 100% repeatable scenario to work from.


To prove this out, I added a custom object, embedded a VF page in that object's layout, added a controller extension that housed a member list collection (of a different wrapper class) and in the VF page I added an apex:repeat to iterate over the member collection.  Simple.  The Wrapper object takes a String when instantiated and there is a local boolean in the wrapper that returns true if the String passed to the Constructor is 'First'.  So here:


public class DynamicComponent {

Boolean isFirst;
public DynamicComponent(String dynamicType){
isFirst = false;

if (dynamicType == 'First'){
isFirst = true;

public Boolean getIsFirst(){
return isFirst;

 And in the page controller I instantiate 4 of these objects, 3 of which [0, 1 and 3 index] should return an isFirst of True:


public class DynamicController {

List<DynamicComponent> dynComps;
public DynamicController(ApexPages.StandardController controller){
DynamicComponent dynComp1 = new DynamicComponent('First');
dynComps = new List<DynamicComponent>();
DynamicComponent dynComp2 = new DynamicComponent('First');
DynamicComponent dynComp3 = new DynamicComponent('Second');
DynamicComponent dynComp4 = new DynamicComponent('First');
public List<DynamicComponent> getDynComps(){
return dynComps;


<apex:component >
    <apex:attribute name="EachElem" description="Each dynamic Element" type="DynamicComponent" required="false" />
    <apex:pageBlock title="Dynamic Element">
        <apex:pageBlockSection showHeader="false">
            <apex:pageBlockSectionItem rendered="{!EachElem.isFirst}">
                <apex:outputText value="I am rendered" />


And the VF Page, which iterates over the collection using an apex:repeat:


<apex:page standardController="Dynamic_Container__c" extensions="DynamicController" >
<apex:repeat value="{!dynComps}" var="eachComp">

<c:DynamicCollectionElement EachElem="{!eachComp}" />



So the expected result in this case would be 4 page blocks: first, second and fourth should have 'I am Rendered' output and the third should not.  But instead, the last one doesn't have the 'I am rendered' text.  




Also, if I change the first instantiated wrapper object to instead take a 'Second' value in the constructor, none of the component instances display the conditional text (leading me to believe the first false found causes subsequent rendering of the element to fail.  Please look into this, Visualforce friends


anyone know?
Message Edited by Guyver118 on 06-17-2009 08:33 AM



I am receiving an error when trying to create a note via the web services API.


Here is the request. I believe I have set all of the required fields. The user logged into the API has full access to the Parent object. 


<create xmlns:tns="urn:partner.soap.sforce.com" xmlns="urn:partner.soap.sforce.com">


<ens:type xmlns:ens="urn:sobject.partner.soap.sforce.com">Note</ens:type>

<ens:ParentId xmlns:ens="urn:sobject.partner.soap.sforce.com">a0iS00000048mIp</ens:ParentId>

<ens:Title xmlns:ens="urn:sobject.partner.soap.sforce.com">Note From Ops: [4/20/2009 12:02:50 ...]</ens:Title>

<ens:Body xmlns:ens="urn:sobject.partner.soap.sforce.com">RMYERS 4/20/2009 12:02:50 PM:

This is a test note made at 12:02





Here is the response. Has anyone seen this or know what I am doing wrong?


<createResponse xmlns="urn:partner.soap.sforce.com">



<fields xsi:nil="true" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"/>


insufficient access rights on cross-reference id






<id xsi:nil="true" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"/>





Thanks in advance.



I've searched here and seen a number of posts with the above error, but I haven't found anything that addresses my issue with it.  When Customer Portal users create a case and select a contact for the case from their account, the case will not save and gives the error, "insufficient access rights on cross-reference id".

The system will only let them create cases with themselves as the ContactName (and owner).  If I then try to reassign within SF (Sys Admin) I cannot change the contactname to anything other than the Customer Portal owner.  If I do and save it, the system changes name right back.  The Customer Portal profiles have read/edit permissions.  I've also looked through the Field security and don't see anything at all.  Help!?
Hello Everyone,

I hope you can help me on this..Im working with singleEmail to send an email to a particular sales representative on every territory. but every time I invoked my trigger via update of my objects, it returns an exception. The error is: System.EmailException: SendEmail failed. First exception on row 0; first error: INVALID_ID_FIELD, WhatId is not available for sending emails to UserIds.\.: Trigger.Notify_Rep_Trigger: line 90, column 21

my code is written below:

Account territory = [select Territory_Name__c from Account where Id =:data.Account_ID__c];
            if(territory.Territory_Name__c != null)
                List<string> splitID = territory.Territory_Name__c.split(';', -1);
                Set<string> tID = new Set<string>();
                List<Territory> territoryId = [Select id From Territory where name in :splitID];
                List<UserTerritory> usersId = [Select UserId From UserTerritory where territoryid in :territoryId];
                for(integer x=0; x < usersId.size(); x++)
                List<User> emailAdd = [select Id, email from User where Id in :tID];
                Messaging.SingleEmailMessage mail = new Messaging.SingleEmailMessage();
                List <String> Addresses = new List<String>();
                for(integer i=0; i < emailAdd.size(); i++)
                    //String[] toAddresses = new String[] {emailAdd[i].email};
                    String toTargetObjects = (string)emailAdd[i].Id;
                    system.debug('target object deb:'+toTargetObjects);
                    system.debug('data id deb:'+data.Id);
                    Messaging.sendEmail(new Messaging.SingleEmailMessage[] { mail });

any suggestion? I would really appreciate it if you can help me on this.

Thanks in advance,


Message Edited by wilson34 on 11-21-2008 01:50 AM

Message Edited by wilson34 on 11-21-2008 01:51 AM

Message Edited by wilson34 on 11-21-2008 01:51 AM

Message Edited by wilson34 on 11-21-2008 01:53 AM
I was having difficulty with migrating email templates and finally figured out that it was not seeing any templates in folders.

I can move templates from the 'unfilled' 'folder just fine now.

I tried using the 'folder' type and many other variations for 'emailtemplate' with no sucess. There are no examples I can find for the syntax to migrate email templates and folders. Does anyone have a sample here?


  • September 18, 2008
  • Like
  • 0