• SteveFromTL
  • 0 Points
  • Member since 2009

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 3
I have two workspaces in Eclipse.  One for production (linked to a production version of  salesforce.com) and one for development (linked to a development edition of salesforce.com).  The production one returns details of the execution including the system.debug ouput.  The log level in production is set to Debug.  If I run the same code in the development environment it only returns 'Anonymous execution was successful' no matter what setting you use for the log level.

I am in the middle of debugging an Apex/Visualforce application, and the maintenance that just occurred this evening (1/22/10) just completely changed the behavior of the debug logs.  Two problems with this new behavior:


- My filter settings don't seem to be saving.  For instance, when I change my filter settings to "FINEST" in Apex Code and Save, those changes do not show up when I go to filter settings again.


-MOST IMPORTANT: the log line does not show the method name. Here is an example of the new format:


23:35:20.840|USER_DEBUG|[157,4]|DEBUG|***s.Id b4: a4yQ000000000DAIAY


Notice - no method name in any of the debug lines.


I went to the Help and Training to find out if I am doing something wrong. It says the event identifier will log "any additional information logged with that event, such as the method name or the line and character number where the code was executed."  But they give an example pretty much like the one I copied and pasted in here -- no method name.


If anyone has any insight on how to get the method name to show or how to get the old debug log format to show, please be so kind as to respond.  If this is not possible, then salesforce just got 10 times harder to debug in my book.


Thanks for any help!

Message Edited by BodhiDharma on 01-23-2010 12:04 AM



I have created some batch apex code alongwith other triggers and class/controller codes. 


When I run individual test methods on them, I am able to get test success result alongwith nice code coverage %. However when I run all tests together, I get following test failure errors:-


1)System.AsyncException: Database.executeBatch cannot be called from a batch or future method.

2)System.AsyncException: Future method cannot be called from a future method: changeOwners(String, String)

3)System.AsyncException: Future method cannot be called from a future method: getLead_Rollup_Amount(Id)

4)System.AsyncException: Future method cannot be called from a future method: changeOwners(String, String)


Please note again that the exceptions dont come when tested individually.


Please advise on same.