• AlwaysConfused
  • 135 Points
  • Member since 2010

  • Chatter
  • 5
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 12
  • 76

I have a business case, where there is a .Net web application that opens up Salesforce within the app. How do I ensure that the user is automatically logged in without being asked for a username and password.
1. The login needs to be seamless - so that even when a new user is setup, he/she does not have to go through the process of password reset. The user should not have to know what his / her username and password is
2. This Salesforce org already has SSO enabled. However, the users that use the web app are not on the same network. Hence SSO will not work. I would need a parallel authentication mechanism. Is it possible to have 2 parallel external authentication mechanisms. Is yes, how? Is there some documentation that I can refer?
3. I dont want to maintain Salesforce usernames and passwords in the .Net app, since it will be an overhead to sync the passwords everytime
4. I cannot use a single API user that will impersonate all users, because, I need to keep a history of which user did what. 

What options do I have? And if I am willing to store the paswords in the .Net app, are there easy options to automatically store the user credentials and have the user login into Salesforce.


Hey all,


The problem I'm facing is that an api query is timing out when all I want to do is count the number of records on the object. eg:



SELECT count() FROM contact Where email != ''



Purpose of the query is to count the number of rows on the contact object (with an email addy) in order to compare against a replicated set of records. We want to measure the % sync between SF and another system.


Any ideas of:

1) A method to prevent query timeout?

2) A method to count the # of records on the object without the query?

3) A work-around (creative suggestions on splitting the query up into smaller chunks?)





We are using the new bulk API for uploading large volumes of data with .NET Webrequests.


In order to improve performance, Salesforce recommends compressing the files that are sent to the systen. Does anybody know how to use compression in the outgoing webrequest? We would love to see some example .NET code, or e.g. the source code of the new DataLoader (v9), even java code would do.


Many thanks,


Hi guys,


I'm a C# developer so go easy on me.


I found this in the Data Loader source code ... 


    public void addReferenceToSObject(Controller controller, SObject sObj, String refFieldName) throws ParameterLoadException { 

        // break the name into relationship and field name components 

        ObjectField refField = new ObjectField(refFieldName); 

        String relationshipName = refField.getObjectName(); 

        String fieldName = refField.getFieldName(); 


        // get object info for the given reference (foreign key) relationship

        DescribeRefObject entityRefInfo = controller.getReferenceDescribes().get(relationshipName);


        // build the reference SObject

        SObject sObjRef = new SObject();

        // set entity type, has to be set before all others


        // set external id, do type conversion as well

        Class typeClass = SforceDynaBean.getConverterClass(entityRefInfo.getFieldInfoMap().get(fieldName));

        Object extIdValue = ConvertUtils.convert(this.referenceExtIdValue.toString(), typeClass);

        sObjRef.setField(fieldName, extIdValue);

        // Add the sObject reference as a child elemetn, name set to relationshipName

        sObj.addField(relationshipName, sObjRef);


I'm a little confused by the last line here, on the basis that the object passed in is "SObject sObj" from what I've seen in my type definition in C# this isn't possible.

Could someone explain what is going on here?

Is this an sObject or some other type?

If it is an sObject how do I do the equivelent of "sObj.addField" in C#?

Thanks guys.

Hi Guys,


Using the dataloader I can upsert data from a CSV file that contains no unique id's for related objects in salesforce, instead it only requires the external id for the object and it seems to resolve the actual SF unique id as it goes ...


In my mapping file i have something that looks like this:


Customer\ Number=Account__r\:Corporate_Number__c


Which says to me, "take the value from the Corporate number custom field and resolve the AccountID then use that to link the record to the acocunt".


In this particular case the record I'm upserting is an order so it's related to both an account and a customer.


My question is ...

How can I do this in the API?


If I don't provide a value for "Account__c" I get a required field missing error and if I put the Corporate number in there I get an invalid format error (the format of my external id's is different intentionally).


I want to avoid downloading any accounts or contacts just to find the sf unique id on a related object.

Ok so lets say i do something like this ...



I then have an upsert result array:


UpsertResult[] results = binding.Upsert(sObject[], externalIdField);




So lets assume i have some errors and I want to identify what data caused the problem, I want to pull the field values from the sObject in question and look at them ....


Now what ...


Seemingly all I have is a list of fields (literally as a string, this would be much better if it was a field array) a message, and a status code.


There must be more available than this surely?


Ok so I have some data in a .Net DataTable object and I want to put this on a customers Salesforce.


I have the login details and I have my reference to the SF Partner API all setup.


I make my call to "DescribesObjects" so I know what fields are available on the account sObject type.


now what?


In the documentation it says its really easy ... all i need to do is declare an array of sforce.Account objects ... erm big flaw there ... the partner API does not have any of those ... only the base sObject type.


So lets start there ...


sObject obj = new sObject();


hmmm ... nothing to let me assign to fields?


So what now?

This is probably a stupid question but ...


In order to view the relevant WSDL I want to refer to I have to login to salesforce.


Once I have found the WSDL I can then copy and paste the url to it in to other browser windows as long as I remain logged in.


As soon as I logout however the link breaks.


So how does the reference in my client application work?

I am currently experiencing http 500 errors when trying to use the API ... and i'm wondering if this is related.


It's like you have to be logged in order to even view what the API looks like, surely that kinda negates the whole point in having an API that you need to login to???


Does anyone know how one would go about regenerating the enterprise WSDL based on the default base url and a given set of account details being known.


I'm trying to build a generic way of talking to any SF implementation that we can reuse for all our customers that use SF.


At the moment I have to add the Web reference manually using VS for each individual customer project.

It would be cool if I could just use something to pull the latest definition during execution.


Most of my code simply uses datatable objects and reflection to "map" columns to sobject properties so this is the only thing that would hold it back so far.

Hey guys,


I have a problem, pretty big one as it happens.

One of our customers has about 10,000 campaigns and about 78 MILLION campaign member items in the SF db.


They have asked if we can produce weekly complex reports on them that we can't build through SF and since we control the data we have built a copy of the SF data on a local SQL server.


I'm trying to build a syncronisation tool / process using SSIS and a bit of C# code that regularly looks up (using the SF api) whats changed and updates our copy of the data.


Of course this leads to a problem, due to the sheer number of records in the DB I often hit timeout issues and when I don't hit timeout issues I often need to sync millions of rows by downloading them.


Has anyone had any experience with dealing with huge row counts that they could lend some thoughts on this?


Does anyone know how I might "partition" the data so I can still somehow query the entire dataset but work mostly on subsets (eg split down per campaign)?

Hi guys, no idea why but when I run this query the server throws a 500 error at me, any ideas why ?


SELECT col1, col2, colx

FROM Contact

WHERE LastModifiedDate > 2000-01-01T01:00:00.000Z

AND SystemModstamp > 2000-01-01T01:00:00.000Z


The query contains quite a few cols so i chopped them out (total query length is normally just over 3,000 chars).


The Contacts list is pretty big (2.7 million records) which might result in a query timeout or something ... not sure though, surely a timeout would result in some sort of .Net exception on the service but this is just dying on the server.


Hey guys,


Just trying to figure out some problems with the data i have in a SQL server database this end and i found that i'm missing about 200 records.


Can i do this in SOQL against the API :


select field1, field2, fieldx

from Contact

where id in (id1, id2, id3, id4 idx)


I tried and the server threw a 500 internal server error at me.

I'm guessing that this is the wrong syntax for soql but what is the equivilent to this sql? 


Thanks in advance :)

Hi guys,


I'm fully aware of the point of query locators but i'd just like to know ...


If i query the API and get back the first batch, can i make a changeto the locator to go back to a point of my choosing from a previously failed query?


For example :



Then i handle a few batches, then the query fails (for whatever reason - maybe loss of connectivity lets say) ...


So how do i get back to the point where the query failed (assume this query runs for over an hour)?


Hey Guys,


I'm curious as to why this code would be sooooo slow compared to the apex data loader:

it uses the recommended mechanisms / technologies :

1. Connection is held open

2. asynchronous calls are made

3. multithreading is used


From what I can see underlying all this .NET does the same as what the data loader source code does in that it takes the data stream and deserialises it in to an object (QueryResult) then that is handed to some other portion of code which can process the data in another thread.


The connection is kept and dropped only after the logout call is made (nowhere in this code).


In my class constructor i login to the salesforce service to get session details.

Then i attach some event handlers, then within the calling code i call Test() ...


service.queryCompleted += new queryCompletedEventHandler(service_queryCompleted);

service.queryMoreCompleted += new queryMoreCompletedEventHandler(AsyncFetch);

ResultsReceived += new ResultsReceivedHandler(SalesForce_ResultsReceived);


 public void Test()




string query = "select Id,AccountId,Salutation,FirstName,LastName,RecordTypeId,MailingStreet,MailingCity,MailingState," +

"MailingPostalCode,MailingCountry,Phone,MobilePhone,Email,Birthdate,CreatedDate,LastModifiedDate,LastModifiedById," +

"Gender__c,User_Login_ID__c,Date_Last_Cleaned_Checked__c,Age_Range__c from contact ";

QueryOptions qo = new QueryOptions();qo.batchSize =

1500;qo.batchSizeSpecified = true;

service.QueryOptionsValue = qo;

service.queryAsync(query, query);


catch (Exception ex)


throw ex;



void service_queryCompleted(object sender, queryCompletedEventArgs e)


QueryResult qr = e.Result; if (!qr.done)


service.queryMoreAsync(e.Result.queryLocator, e.UserState.ToString());

ResultsReceived.BeginInvoke(qr.records, qr.done, e.UserState.ToString(), null, null);




 void AsyncFetch(object sender, queryMoreCompletedEventArgs e)


QueryResult qr = e.Result; if(!qr.done)

service.queryMoreAsync(qr.queryLocator, e.UserState.ToString());

ResultsReceived.BeginInvoke(qr.records, qr.done, e.UserState.ToString(), null, null);



 void Salesforce_ResultsReceived(sObject[] Results, bool done, string Query)


if (Results.Length > 0)


// get components needed by table builder

 string[] fields = GetFieldsFromQuery(Query);

// build and return objects as datatable

DataReceived(proc.BuildTable(Results, fields), done);



Hey guys,



I'm trying to figure out how to do this type of thing ...



for salesforce, but can't seem to figure out the url i need to build prior to making the request.


I have built some async code based on creating the web reference and making standard web service calls but can't seem to match the performance put out by the APEX data loader.


I've looked around and found that from the code (what little i actually understand of java) and some forum threads on here the data loader effectively uses 2 threads, 1 to pull the data and a second to save it locally i can see that in the code:



I'm trying to do the same thing but i'm dumping the data to a SQL server database this end instead of a CSV file.

Whilst my code works it's nowhere as efficient as the data loader and i can't seem to figure out why.


Essentially my code works by doing the following:

1. make async query

2. when response comes back call "querymoreasync" (recursive until query completes)

3. on another thread save the results


I figured this would at least come close to the dataloader but it somehow is about 5 times slower :(


When I dug a bit deeper I found that the data loader actually requests then handles the data as a stream, i'm not actually handling the stream at the moment in favour of relying on .NET's generated classes from my web reference which could explain some of the performance hit.


Anyone else trying to do this?

Any ideas?



I have code like follows, to login/connect to Salesforce web services...


    _SalsesforceService = New SforceService

    _SalsesforceService.Timeout = 60000
    _LoginResult = _SalsesforceService.login(UserName, Password + SecurityToken)


This, of course, works great. 


However, if a lot of time goes by without communicating with Salesforce, the "connection" is no longer valid, and, if I try to make calls, I get errors.


So, the question is, how can I determine if the connection to the service has timed out, so that I can know if I need to reestablish the connection? Secondly, if it has timed out, do I just run _SalsesforceService.login(UserName, Password + SecurityToken) again to reestablish the connection?




   Please provide me the steps to integrate the .Net application in salesfore crm.


I am creating Contact using .net code and it is getting created successfully.


But after creating contact I need to do one entry in contact share(you might be wondering why to make entry in contact share when it is being managed by salesforce. well it is just because i wanted to give share all of my contacts created using system administrator's account to be shared by some other users too, so i am creating one more entry pertaining to other users in contactshare)


hope the the above senerio is clear to you.


well everything works fine but what if something goes wrong in contactshare and it is not able to create row in contactshare ....here i wanted to rollback the record entered in contact also.


now the query is how to do that? how to maintain transactions in salesforce.




I'm trying to create a .net site (c#) to display a crystal report that uses Salesforce data.  The problem is, when I try to refresh the data in the report, I get the following error

 Failed to load Database information.
Details:  The database connector 'crdb_sforce.dll' could not be loaded.  The correct version of the database client for this database type might not be installed.


So I locate the crdb_sforce.dll file on the machine (found in the Crystal Reports .....\Common\3.5\bin folder) and try to add it as a reference to the project.  This throws the following error:


A reference to 'C\.......\crdb_sforce.dll' could not be added.  No type libraries were found in the component.


I'm not really sure how to proceed from here.  I do not come from a .NET/windows world so I'm handcuffed a little on that. 


I'm wondering if anyone has gotten this working, or if it's a simple .NET error that someone would be willing to push me towards the answer.



Hey all,


The problem I'm facing is that an api query is timing out when all I want to do is count the number of records on the object. eg:



SELECT count() FROM contact Where email != ''



Purpose of the query is to count the number of rows on the contact object (with an email addy) in order to compare against a replicated set of records. We want to measure the % sync between SF and another system.


Any ideas of:

1) A method to prevent query timeout?

2) A method to count the # of records on the object without the query?

3) A work-around (creative suggestions on splitting the query up into smaller chunks?)






I am working on a project that involves tranferring large ammount of data from a SQL Server database to custom objects in SalesForce. So far, it has been going very well. However, today , I came across this error whil making an UPSERT call through the API :


System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host


The error is worrying enough in itself, but when I reran the script, although it ran correctly, it created everything TWICE in the database. Surely the UPSERT command should make sure that the objects are only created once, using the external ID from our system?


Many thanks!



Hi Guys,

           Actually i am working on integration but i am very new to salesforce. We have opportunity has list of agency, partner in the layout as a relatedlist.

           I am trying to add partners using .net.  but i could not... please any one can provide sample code snippet.....








At the moment, the only way I found out in order to create a lead and link it to a campaign in SalesForce via the API web service, is to first create the lead, and then create a campaignMember object which I link to the created lead (campaign id + lead id).


Question: is there a way to push the lead with the linked campaign all at the same time?

Hi Friends,

I am developing a simple asp.net application which is pointing to salesforce sanbox and i am using enterprise wsdl downloaded from  sandbox environment.If i want to change this url pointing to production.


 By changing address location in sandbox enterprisewsdl and key value in web.config is sufficient 



1) In enterprise.wsdl change  <soap:address location="https://test.salesforce.com/services/Soap/c/17.0" />

to  <soap:address location="https://www.salesforce.com/services/Soap/c/17.0" />


2)In web.config >> <add key="SalesForce.enterprise" value="https://test.salesforce.com/services/Soap/c/17.0"/> to

<add key="SalesForce.enterprise" value="https://www.salesforce.com/services/Soap/c/17.0"/> 


Or I need to download a seperate wsdl from production.Please suggest me.

  • March 16, 2010
  • Like
  • 0

I have some custom objects in our instance. I can run a query through APEX and get results. But when I run the same query through my .NET code (I have the latest WSDL and updated my web reference) , there is soap exception saying that the object is invalid. Here is is error : urn:fault.enterprise.soap.sforce.com:INVALID_TYPEINVALID_TYPE: sObject type 'XXXX_XXX_XX__c' is not supported.


Am I doing something wrong ? or is there some quirk I need to know.


Please help !!!

  • February 23, 2010
  • Like
  • 0

I've gotten maybe 10 of these from an integration we have that simply pulls Contract records from production.  Iv'e had these one and off (maybe like 1 every 10 days) for a couple months, but this morning I've gotten just a landslide.    Using reflector, the endpoint I'm pointing to currently (in the app config) is: "https://www.salesforce.com/services/Soap/u/16.0".  


Is there something change that I missed or something like that with Salesforce connectivity?  Thanks. 


Machine: CSMSIIS1

Date: 2/19/2010 8:12:40 AM

Type: System.Net.WebException

Assembly: CSG.MSI.Contracts.SFDCWrapper, CSG.MSI.Contracts, Version=, Culture=neutral, PublicKeyToken=null

Codebase: file:///C:/Program Files/Metastorm BPM/Engine/dotnetbin/CSG.MSI.Contracts.DLL

Message: The underlying connection was closed: An unexpected error occurred on a receive.

Source: CSG.MSI.Contracts

Stacktrace:    at CSG.MSI.Contracts.SFDCWrapper.ExecuteSOQL(String soql) in C:\Documents and Settings\bryang\Desktop\CSG.MSI.Contracts\CSG.MSI.Contracts\DAL\Util\SFDCWrapper.vb:line 127

   at CSG.MSI.Contracts.SFDCContractMapper.SelectMultipleInternal(String SOQL) in C:\Documents and Settings\bryang\Desktop\CSG.MSI.Contracts\CSG.MSI.Contracts\DAL\Data\Mappers\SFDCContractMapper.vb:line 77

   at CSG.MSI.Contracts.SFDCContractMapper.Select(String id) in C:\Documents and Settings\bryang\Desktop\CSG.MSI.Contracts\CSG.MSI.Contracts\DAL\Data\Mappers\SFDCContractMapper.vb:line 25

   at CSG.MSI.Contracts.ContractStatus.GetContractStatus(String contractid) in C:\Documents and Settings\bryang\Desktop\CSG.MSI.Contracts\CSG.MSI.Contracts\BLL\ContractStatus.vb:line 6

   at CSG.MSI.Contracts.Contract.GetContractStatus(String contractId) in C:\Documents and Settings\bryang\Desktop\CSG.MSI.Contracts\CSG.MSI.Contracts\Contracts.vb:line 6

Exception Custom Data: 

SOQL Statement = SELECT Id, AccountId, OwnerId, Status, Opportunity__c, Contract_Status__c, Contract_Begin_Date__c, Contract_Type__c  FROM Contract  WHERE Id = 'XXXXXXX'  


Any ideas would be most welcome.  Thanks. 

Hi there,


I'm using the salesforce webservice on .net platform to create leads in salesforce which works fine.

I recently added some code (see below) though to be able to add an existing campaign to my freshly created lead but I get the following error "insufficient access rights on cross-reference id". The user I'm logged in with the webservice has all the rights and permissions and should be able to do whatever he wants.


Can anyone help please, many thanks!



Lead lead = new Lead();

lead.Salutation = "Mr.";

lead.FirstName = "testfirstname";

lead.LastName = "testlastname";

lead.Email = "test@tester.com";

if (login())


SaveResult[] sr = binding.create(new sObject[] { lead });

foreach (SaveResult s in sr)


if (s.success)


errorLog.eventLog.Log("salesForce.createLead()", string.Format("Successfully created Lead in SalesForce with ID: {0}", s.id));

//***************************************************** CAMPAIGN ID *************************************************

CampaignMember campaignMember = new CampaignMember();

campaignMember.CampaignId = campaignID;

campaignMember.LeadId = s.id;


SaveResult[] srCmp = binding.create(new sObject[] { campaignMember });

foreach (SaveResult sc in srCmp)


if (!sc.success)


errorLog.eventLog.Log("salesForce.createLead()", string.Format("Error creating campaign to lead in SalesForce: {0}", sc.errors[0].message), System.Diagnostics.EventLogEntryType.Error);







errorLog.eventLog.Log("salesForce.createLead()", string.Format("Error creating Lead in SalesForce: {0}", s.errors[0].message),System.Diagnostics.EventLogEntryType.Error);



Message Edited by VASCOdev on 02-09-2010 11:58 PM

Hello everyone.

I was hoping someone out there may have come accross a solution to an issue I am currently having.

I have a winform project that I am moving over to a CLR stored procedure that will automatically update

Contacts on salesforce when changes are made to our db. The initial development for the winform was

easy enough to create but once I put it into a CLR project the web reference presents problems.

It builds, compiles and deploys fine but throws an error when I try to run it from SSMS. After

researching out the error below I serialized the .dll using sgen.exe from the command line and

successfull created and added the foo.xmlserializers.dll file to the project, I added the pre and post

deployment scripts necessary to add and drop the serialization assembly and am still recieving

the same error after I deploy the project.

If you recognize the method and the error and have a possible solution for me the help would be greatly

appreciated. It is for .net 2.0 and sqlserver 2005.


The error:

Msg 6522, Level 16, State 1, Procedure SynchronizeSalesforceContactDetails, Line 0

A .NET Framework error occurred during execution of user-defined routine or aggregate "SynchronizeSalesforceContactDetails":

System.InvalidOperationException: Cannot load dynamically generated serialization assembly. In some hosting environments assembly load functionality is restricted, consider using pre-generated serializer. Please see inner exception for more information. ---> System.IO.FileLoadException: LoadFrom(), LoadFile(), Load(byte[]) and LoadModule() have been disabled by the host.


at System.Reflection.Assembly.nLoadImage(Byte[] rawAssembly, Byte[] rawSymbolStore, Evidence evidence, StackCrawlMark& stackMark, Boolean fIntrospection)

at System.Reflection.Assembly.Load(Byte[] rawAssembly, Byte[] rawSymbolStore, Evidence securityEvidence)

at Microsoft.CSharp.CSharpCodeGenerator.FromFileBatch(CompilerParameters options, String[] fileNames)

at Microsoft.CSharp.CSharpCodeGenerator.FromSourceBatch(CompilerParameters options, St



at System.Xml.Serialization.Compiler.Compile(Assembly parent, String ns, XmlSerializerCompilerParameters xmlParameters, Evidence evidence)

at System.Xml.Serialization.TempAssembly.GenerateAssembly(XmlMapping[] xmlMappings, Type[] types, String defaultNamespace, Evidence evidence, XmlSerializerCompilerParameters parameters, Assembly assembly, Hashtable assemblies)

at System.Xml.Serialization.TempAssembly..ctor(XmlMapping[] xmlMappings, Type[] types, String defaultNamespace, String location, Evidence evidence)

at System.Xml.Serialization.XmlSerializer.GetSerializersFromCache(XmlMapping[] mappings, Type type)

at System.Xml.Serialization.XmlSerializer.FromMappings(XmlMapping[] mappings, Type type)

at System.Web.Services.Protocols.SoapClientType..ctor(Type type)

at System.Web.Services.Protocols.SoapHttpClientProtocol..ctor()

at salesforceContactUpdate.ForceWebReference.SforceService..ctor()

at salesforceContactUpdate.UserDefinedFunctions.SynchronizeSalesforceCo...

  • February 03, 2010
  • Like
  • 0

I'm calling upsert on a custom object with a custom id field.  I set that id field to "AutoNumber" and also set it to be an external id.


When I call upsert, if the id passed in, matches an id in a previously added record, it updates great.  Updating works perfect.


Now, when I don't have an id, I pass null in the id field.  The upsert fails because it says it requires the id field.  I don't have an id for a new record.  Even when I do pass in an id, the upsert STILL fails, because is says I can't set a value myself to an AutoNumber field.


What I would expect is, if I pass in a matching id, it updates the record.  If I pass in a null id, it creates a new record with the AutoNumber having incremented.


What do I do?


Here is the code:


sforce.Time__c[] time = new Time__c[1];

time[0] = new sforce.Time__c();

Dictionary<string, Object> dataRow = (Dictionary<string, Object>)data[i];

time[0].id__c = dataEntry.Value;  // THIS MAY BE NULL, OR IT MAY BE AN ACTUAL NUMBER ID 

time[0].date__c = Convert.ToDateTime(dataEntry.Value);time[0].date__cSpecified =

true; time[0].time__c = (string)dataEntry.Value;


sforce.UpsertResult ur = binding.upsert("id__c", time)[0]; // THE id_c FIELD IS THE AUTONUMBER FIELD.

I primarily need to dowload customer/contact information in small or even individual batches from Salesforce.com into customer's that use our billing system. My first read is that there are 3 APIs or more. I am trying to figure out where to start here, I am at the very beginning of figuring out how to begin access and development.


I will be using visual studio 2008 and programming in VB. I assume that I should be using the Force.com Partner WSDL, but the examples I downloaded appear to be using something called APEX. Any guidance on this and getting started would be MUCH appreciated.





I have such error during getting response:  '', hexadecimal value 0x1F, is an invalid character. Line 1, position  

I've had this error.But it was caused by invalid login and password. Now these parameters are ok.

About a week ago it worked good. 


This error occurs here:


public override WebResponse GetResponse()


return new GzipWebResponse(wr.GetResponse ());



I use Gaiaware library. 



Does anybody know what this error caused by ? 




Message Edited by Getlin on 01-05-2010 02:04 AM
Message Edited by Getlin on 01-05-2010 02:04 AM
  • January 05, 2010
  • Like
  • 0

I've a .NET web service with a method that recieve byte[]:


[WebMethod] public void DoSomething(byte[] array) { ... }

 I'm imported the web service into apex using the wsdl import mechanism. 


The problem is that the byte[] object is represented as String array.


How can I call a web method which needs to recieve a byte[]?




I have a custom Field on case. I want to create a workflow to update this field if a specific condition is true.


this custom field has validation trigger.


When I am trying to create the workflow this field(custom field with validation rule) is not available in selection. I use the adance tab to use this field but then it is not available to update and I try for field update rule.


Any ideas why this is happening and a way to do this.



  • December 21, 2009
  • Like
  • 0