• prince1986
  • 0 Points
  • Member since 2010

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 1

HI Friends,


Iam facing this issue when the Records get extracted through Automated Batch Processing - Data Loader.


While Data Loader Extract  through Batch processing ,Many a times the process is stopping in the middle.

We are getting this error frequently in Log files which are getting generated and the records are not getting extracted.
 ERROR (ExportProcessRunner.java:main:77) - error SFDC processor - Error is ->[UnexpectedErrorFault [ApiFault  exceptionCode='INVALID_SESSION_ID'
  exceptionMessage='Invalid Session ID found in SessionHeader: Illegal Session. Session not found, missing session key:some numbers
 Can anybody help me why this problem is arising and what should be done to overcome this "Invalid Session Id" error.


Thank you all in Advance.

HI Friends,

i have a user whose first name is R'amesh. On Assigning this Event to R'amesh and saving an Event in SFDC Online, i donot have any pproblem and the Event is getting saved successfully.


But when i create the same Event in SFDC Offline assigning it to R'amesh its not allowing me to save the Event. It is throwing me an error message

"Error: No Matches Found".


Is there any problem with Apostrophe in SFDC Offline?


Can you please help me where is the problem?


Thank you All in Advance.


I believe this is only recent, but I am no longer able to perform API actions against my development install using code that hasn't changed in quite some time.  When I run the code listed below, I get a error on the "Describe Object" call that says "INVALID_SESSION_ID: Invalid Session ID found in SessionHeader: Illegal Session".   It looks as though I'm getting a valid session ID back from the login call, but the subsequent API call doesn't seem to like it.   

The interesting thing is that I have a QA org that's on NA1 (my dev org is also on NA1) that has no problems with the code below.   Also, this problem is only happening for my dev org when I run the code from our corporate environment.  If the code runs on our production environment (which have different IP ranges and are locate outside of our corporate office), then it works properly as well.

Is is possible that there is some sort of configuration set in my dev org that doesn't agree with the code below as it's run from our corporate environment?  I've played around with the "Lock sessions to the IP address from which they originated" setting in my dev org, but it didn't seem to do anything.

Here is the code I am running that seems to work for every other install except my dev org:

          Dim sfdcService As New SforceService

          Dim loginResult As New LoginResult

          sfdcService.SessionHeaderValue = New SessionHeader

          loginResult = sfdcService.login(username, password)

          sfdcService.Url = loginResult.serverUrl

          sfdcService.SessionHeaderValue.sessionId = loginResult.sessionId

          Dim results As SForce.DescribeSObjectResult = sfdcService.describeSObject("Lead")


Any help would be greatly appreciated.

Thank you,


  • February 12, 2008
  • Like
  • 0