• @ImJohnMDaniel
  • 0 Points
  • Member since 2011
  • Lead Platform Architect
  • Morgan & Morgan

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 3

I have an email template that is using an HTML letterhead. I added an if statement that is working but when I try to add a URL link to the conditional statement, it breaks.


This statement is working:

{!IF(Contact.Industry__c="Printers","Sign up for", NULL)}


When I try to add the URL, it won't display anthing. I've tried adding it multiple ways.


I tried adding the url link using the formatting controls at the top fo the page but it won't display anything when I select the template:

{!IF(Contact.Industry__c="Printers","Sign up for using format link", NULL)}


I've also tried adding HTML code but th doesn't display anything either.


{!IF(Contact.Industry__c="Printers",<a href="google.com">Sign Up for</a>, NULL)}


Any help would be appreciated.







i want to hide the salesforce provided Help link which is available in all pages.

especially i want  to hide th link in Relates list, for example"Open Activities Help" in Open Activities related list.


is there any option to hide this link by configuring Layouts or through profiles or any options for this?



Thank you for the Help..

We use custom settings in a SalesForce app. We access it like so:

    MySettings__c settings = MySettings__c.getOrgDefaults();


This was working fine, but today the app completely crashed. By that I mean the page doesn't load at all, I just get a white screen telling me an internal error occurred. We traced it down to this line of code - when it is commented out the page loads as well as it can without those settings (but at least it loads). 


Running that single line of code in the System Log (using the Execute functionality) also causes a report of Internal System Error. The only thing the system log reports is "FATAL_ERROR Internal Salesforce.com Error." The Apex code modal reports "Internal System Error: 1018505045-332 (-920440070)"


The setting has values for the organization - we've also tried deleting the settings and recreating them to no affect. So far SalesForce support has been no help beyond telling us to try posting here.


This is very frustrating as it was working fine on Friday and today it was broken before anyone touched anything.