• Umer Naseer
  • 0 Points
  • Member since 2012

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 2

Hi ,


    i created one webservises and i generated WSDL file after that  when i run that address url it showing  like


405 GET not supported, this is a SOAP service, please use POST. what is the problem can any budy suggest ....   


my wsdl url is:



when I run the following code:


$mySforceConnection = new SforceEnterpriseClient(); $mySoapClient = $mySforceConnection->createConnection(SOAP_CLIENT_BASEDIR.'/enterprise.wsdl.xml'); $mylogin = $mySforceConnection->login($USERNAME, $PASSWORD);


 I can log in just fine.  However, when I try to use the partner wsdl:


$mySforceConnection = new SforcePartnerClient(); $mySoapClient = $mySforceConnection->createConnection(SOAP_CLIENT_BASEDIR.'/partner.wsdl.xml'); $mylogin = $mySforceConnection->login($USERNAME, $PASSWORD);

 I receive the following response " INVALID_LOGIN: Invalid username, password, security token; or user locked out."


I am correctly including the SforcePartnerClient.php or SforceEnterpriseClient.php depending on which method I'm trying to use.


Does anyone have an idea as to why I'd be able to log in fine with the enterprise wsdl but not with the partner wsdl?  I'm definitely stumped.