• John T
  • 25 Points
  • Member since 2012
  • Application Development Manager
  • KVH Industries

  • Chatter
  • 1
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 10
Trying to get the response on rest explorer workbench. My salesforce Url is "https://tarunlight-dev-ed.my.salesforce.com/" and getting problem in having the Get Response with the URI "/services/apexrest/Cases/". Getting 404 error: Not Found. 
OK, so heres a strange one....
When I log into Trailhead, I see two active modules,
  1. Lightning Components
  2. Lightning Component Basics (new)
The latter I stated after having a little problem continuing with Lightning Components. Now when I click on "Continue Module" for either one, I am re-directed to Lightning Component Basics (new).

I have a feeling that the original Lightning Components has been deprecated/retired, maybe due to all of the recent improvements. I'm OK with that, but the whole  "2 in progress" modules behaviour seems a little buggy to me. Is anyone else experiencing something similar? What happens when a User is in the middle of a module that gets deprecated/retired?
I have followed these instructions to install beta version in order to develop Lightning Components in eclipse, and I'm able to create a project and retrieve those files that I already created on this organization. However if I try to create one, I get this error message

User-added image

And afer clicking ok this one where field to set the name is blocked.

User-added image

I tried several times to set credentials just in case but no luck.

In addition, if I try to modify an existing component and click on "Save to Server" link, I get also this error:

User-added image

Any clue about this?

Hi Everyone,

Currently we have the front end State/Country picklist validation settings turned on within our SF instance. Which means Records with a Country of USA need to have a valid state i.e. California and not something inaccurate such as Montreal. By having this turned on records with mismatched values are prohibited from being created.  

We want to build an API to send over new Lead Record data based on a form submission. Does anyone know if this same State/Country validation extends to record creation via an API?

Trying to get the response on rest explorer workbench. My salesforce Url is "https://tarunlight-dev-ed.my.salesforce.com/" and getting problem in having the Get Response with the URI "/services/apexrest/Cases/". Getting 404 error: Not Found. 

I need to integrate payment gateway in community for payments processing(alongwith credit card payments) with my custom object.I have done research about this but I found some paid apps on appexchange but not found any useful blog for this in salesforce . Can someone guide me what is the best method to do this and what are the steps needed ?
For one of our mobile app, we would like a community user call a APEX REST class. Is there a specific REST URL in the context of the community?

For example chatter url for a community user would be 


For internal users would be

I've started dabling in Lightning Components and worked through a tutorial last year and have done one of the trailheads a few days.  So I know how to code basic Lightning components and apps.  And I see in the metadata that these become AuraDefinitionBundles.  I also so an example of some code where a bit of JS is added to an empty VF page and that always a Lightning Component to be spun up inside a VF page.

What I want to do is take an exist VF page that is exposed to the internet as a SF "Sites" application and port it to Lightning.  What I included in the prior paragaph leads me to believe the page is codable.  Here's what I don't know.  When a Sites application is configured, you have to tell it what it has access to-- VF pages, Apex controllers, objects and fields, etc.  I don't know how you would give it access to the Aura bundle.  (Unless it's totally implicit and you don't have to and it automatically gets acces.)

Can anyone address the question of how to configure and deploy Sites application that includes a VF page that spins up an Lightning Component?

Need help displaying HTML table as tooltip. I got below code from other thread. It works fine, but it displays HTML as OutputText. 


Any idea how I can modify this to show HTML as mouseover? Thanks. 



public Component.Apex.OutputText getGadgetHTMLContent(){
           Component.Apex.OutputText oppText = new Component.Apex.OutputText(escape = false);
           oppText.value = gadgetContent;       //gadgetcontent is the variable which holds the HTML content
           return oppText ;

VF Page

<apex:outputPanel rendered="{!gadgetHTMLContent!= null}" layout="none">
          <apex:dynamicComponent componentValue="{!gadgetHTMLContent}"/>