• gowtham
  • 0 Points
  • Member since 2013

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 3
  • 10

enterprise connection missing in enterprise.wsdl

action command not working for command link and command button in force.com sites. it was working fine for past 3 months but some how its not working i did not make any changes in the code. it was used for the past months. kindly give me clarification on this . its urgent





action command not working for command link and command button in force.com sites. it was working fine for past 3 months but some how its not working i did not make any changes in the code. it was used for the past months. kindly give me clarification on this . its urgent





I have got a Enterprise  WSDL file from my account. From that i have extracted all the Java classes to connect and interact with Salesforce. While implement the Web client i found that i am missing one class Called "EnterpriseConnection". Without that it seems i cannot login to Salesforce.

Today is my first day of Salesforce.  Can anyone please help me out with this. I am desperate to login to my Salesforce acount. have tried to use partner WSDL Where i have found "PartnerConnection" Class. Tried to login using it but asking for "authEndPoint". Couldn't find it anywhere.

Please help me out..

  • January 26, 2012
  • Like
  • 0

I'm trying to show or hide a <tr> HTML tag inside an apex:repeat, but can't find a way where SFDC will save the code without error. Basically I'm building a table and want to start a new <tr> if a certain condition is met (item number mod 3 = 0, so create a new row when the table row has three cells). Attached is a simplifed example, but it shows what I'm trying to do.


Note: I can't use an apex:panelGroup because I have nested repeaters in each "column".





public with sharing class TestBuildTable {
	public List<Integer> Ints {get;set;}
	public TestBuildTable() {
		this.Ints = new List<Integer>();
		for (Integer i=0; i<20; i++) {


VF page first try (fail):

<apex:page id="TestBuildTable" Controller="TestBuildTable">
    <apex:repeat value="{!Ints}" var="int">
	  {!IF(MOD(int,3)==0,'<tr>',' ')}
	    <td>{!int} nested repeat here</td>
	  {!IF(MOD(int,3)==0,'</tr>',' ')}


VF page second try (fail):

<apex:page id="TestBuildTable" Controller="TestBuildTable">
    <apex:repeat value="{!Ints}" var="int">
	  <apex:outputPanel rendered="{!MOD(int,3)==0}" layout="none"><tr></apex:outputPanel>
	  <apex:outputPanel rendered="{!MOD(int,3)==0}" layout="none"></tr></apex:outputPanel>


The desired result is a table that looks like this:

1    2    3

4    5    6

7    8    9

10 11 12

13 14 15

can anyone post a successful database-conf.xml file used to extract data from salesforce into SQL Server 2005.  I am attempting to use the CLI for data loader 20.0.  I believe my process-conf.xml file is fine because when i attempt to process the file it only erros when it gets to my dbDataSource bean in my database-conf.xml file. 


I was hoping someone could tell me that they were successful with apex data loader 20.0.  I was trying to use a jdbc driver or a jtds driver, maybe I dont have my executable jar files in the right place, currently I have them in the same place as my process/database conf files.  Is this right?  Do i need to do somethig else with the drivers?


I have seen examples, I have read the pdf on connecting salesforce and sql but I am just not getting it.  here is my dbDataSource bean:


<bean id="dbDataSource"
     <property name="driverClassName" value="com.microsoft.sqlserver.jdbc.SQLServerDriver"/>
     <property name="url" value="jdbc:sqlserver://MyServer;databaseName=MyDatabaseName;"/>
     <property name="name" value="test"/> 
     <property name="password" value="test"/>     



The error I get is: cant resolve reference to bean 'dbDataSource' while setting property 'dataSource'; nested exception is org.springframework.beans.factory.BeanCreationexception: Error creating bean with name 'dbDatasource' defined in file . . . Error setting property values; nested exception is org.springframework.beans.NotWritablePropertyException:  INvalid property 'drverCalssName' of bean class [com.salesforce.dataloader.process.ProcessRunner]:Bean property 'driverCalssName' is not writable or has an invalid setter method: Does the parameter type of the setter match the return type of the getter?


im fairly cetain i have the correct driver class name?  anyways, i am very frustrated, I feel like maybe Im close but maybe not??



Does anyone know why the following query line:

List<Contact> contacts = new List<Contact> ([Select Id, Email from Contact where IsPersonAccount = false]);

Yields this error message:

Error: Invalid Data.
Review all error messages below to correct your data.
Apex trigger LeadAssignmentFromImagitas caused an unexpected exception, contact your administrator: LeadAssignmentFromImagitas: execution of BeforeInsert caused by: System.QueryException: Non-selective query against large object type (more than 100000 rows). Consider an indexed filter or contact salesforce.com about custom indexing. Even if a field is indexed a filter might still not be selective when: 1. The filter value includes null (for instance binding with a list that contains null) 2. Data skew exists whereby the number of matching rows is very large (for instance, filtering for a particular foreign key value that occurs many times): Trigger.LeadAssignmentFromImagitas: line 18, column 9


The query returns only 58 rows.

Any help is greatly appreciated.  Thank you.
  • February 19, 2008
  • Like
  • 0
Question 1)
Iam trying to get data from salesforce custom object which has more than a million records.
I got the following error.

faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
faultString: java.net.SocketTimeoutException: Read timed out
{http://xml.apache.org/axis/}stackTrace: java.net.SocketTimeoutException
: Read timed out
at java.net.SocketInputStream.socketRead0(Native Method)
at java.net.SocketInputStream.read(Unknown Source)
at com.sun.net.ssl.internal.ssl.InputRecord.a(Unknown Source)
at com.sun.net.ssl.internal.ssl.InputRecord.read(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.a(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.a(Unknown Source)
at com.sun.net.ssl.internal.ssl.AppInputStream.read(Unknown Source)
at java.io.BufferedInputStream.fill(Unknown Source)
at java.io.BufferedInputStream.read(Unknown Source)
at org.apache.axis.transport.http.HTTPSender.readHeadersFromSocket(HTTPS
at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:141)

in CommonsHTTPSender

httpClient.setHttpConnectionFactoryTimeout(5000); methods
i changed time from 5000 to 10000 still it didn't help?
Question 2)
Everybody on the forum saying "Make sure you're using HTTP/1.1 persistent connections".
How do I know which HTTP I am using? How can I implement HTTP/1.1..
Right now the Http class(CommonsHTTPSender) I am using is copied from the Quickstart examples.

Please help..this is urgent..
  • January 31, 2006
  • Like
  • 0