• Kim Schaefges
  • 5 Points
  • Member since 2014
  • Senior Cloud Consultant
  • Cloud for Good

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 1
    Likes Given
  • 1
  • 5
I keep getting the following errors when trying to install the forceios.

C:\>npm install -g cordova forceios
C:\AppData\Roaming\npm\cordova -> C:\AppData\Roaming\npm\node_modules\cordova\bin\cordova
npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\
node_modules\\npm\\bin\\npm-cli.js" "install" "-g" "cordova" "forceios"
npm ERR! node v4.4.1
npm ERR! npm  v2.14.20

npm ERR! notsup Unsupported
npm ERR! notsup Not compatible with your operating system or architecture: force
npm ERR! notsup Valid OS:    darwin
npm ERR! notsup Valid Arch:  any
npm ERR! notsup Actual OS:   win32
npm ERR! notsup Actual Arch: x64

npm ERR! Please include the following file with any support request:

Can anyone help me understand what these errors are and how to resolve them?  
Can someone help me with module Metadata API, unit Build Admin Tools for Automated Configuration Changes?

The error I'm getting is:
Line 12: Method does not exist or incorrect signature; void add(Metadata.CustomMetadataValue) from the type List

Below is my code:
public class MetadataExample {

    public void updateMetadata () {
        Metadata.CustomMetadata customMetadata = new Metadata.CustomMetadata();
        customMetadata.fullName = 'MyNamespace__MyMetadataTypeName.MyMetadataRecordName';
        Metadata.CustomMetadataValue customField = new Metadata.CustomMetadataValue();
        customField.field = 'customField__c';
        customField.value = 'New value';
        List <Metadata.CustomMetadata> mdtlist = new List<Metadata.CustomMetadata>();
        mdtlist.add(customField);  // Line 12


I feel like I'm missing something very basic but I can't find any documentation specific to what I'm trying to do and the challenge is not similar (to me) to the example. Can someone please explain where I went wrong?
I am trying to deploy the xml package for Customer_Interaction__b.object using the workbench for this unit. However I deploy and get success message in workbench but cannot see any big object.
  • I did see on the unit page it says that the examples are written for api unit 41.0 but my workbench doesnt allow me to go beyond 40. Does this matter?
  • My trailhead playground is on winter 18.
  • Does it matter what the file name for the object and permission set? (I do have the package.xml)
  • I have tried with and without having 'Single package' selected in workbench deploy
  • I have double checked the workbench is logged into the correct org
User-added image
User-added image

I've tried a second time using a brand new Trailhead Playground, and still get the error when checking the challenge:
"Challenge Not yet complete... here's what's wrong: 
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: VRHJDGJD "
I seem to have no clue what's wrong in the report which I created. As per the requirement - Summarize the report by Account Name, the contact’s Full Name, and show the Hobby Name." Here I do not understand Full Name, as in the report we only get First Name, Last Name.
The error says - 
Challenge Not yet complete... here's what's wrong: 
The 'Lightning Hobbies by Contact' report does not appear to have either the correct report type or (most likely) the correct columns.

I have summarized the report by Account Name, then by Last Name. Another column shown is Hobbies Name. The report filter is on Hobby Type (the bucket field) = Outdoor Activities and it is locked.

Does anyone know whats wrong?
I'm attempting to answer the questions in the Use Case module, and I'm unable to click on any of the answers. Module 2, and I'm already running into problems. Doh!