• Santiago Perez
  • 5 Points
  • Member since 2014
  • Solutions Architect
  • JM Family Enterprises

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 5
New to SFDC API integration but have created the Enterprise WSDL, referenced it in my C# Code. When I instantiate the client and try calling .Query Ihave a list of required parameters that I don't see in any of the existing sampels online where it just expects the SOQL string. Furthermore in my reference the .query function returns LimitInfo[] array not a QueryResult. 

The parameters are the the following in this order: 
  1. Sessionheader
  2. QueryOptions
  3. MruHeader
  4. PackageVersionHeader
  5. queryString
  6. out queryResult

What am I doing wrong? 
Getting Error: Keystore contains an entry whose alias is not acceptable for import : f322e2be-7b11-4337-bbff-4eca63e1a164. Can anyone explain what this means? This is a cert that's being used on a stage server with a partner and receiving requests from them. 

THank you, 
Facing problem "TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.","errorCode":"UNSUPPORTED_CLIENT"

How can i resolve this issue kindly help me
Hi ,
Since Salesforce Disabling TLS 1.0 Encryption, I am using .NET Framework 4.0 Webclient class to connect to salesforce. 

var _webClient=new WebClient();
var content = new System.Collections.Specialized.NameValueCollection
                {"grant_type", "password"},
                {"client_id", clientId},
                {"client_secret", clientSecret},
                {"username", username},
                {"password", password}
var responseBytes = _webClient.UploadValues(tokenRequestEndpointUrl, "POST", content);
var responseBody = Encoding.UTF8.GetString(responseBytes);

I know that System.Net.ServicePointManager.SecurityProtocol (https://msdn.microsoft.com/en-us/library/system.net.securityprotocoltype(v=vs.100).aspx)supports Tls (which is default choice) . But as you look at the link it says it is TLS1.0 protocol. How do I specify TLS1.1 and higher.

I cannot upgrade my existing solution to .NET4.5 since it is a huge undertaking. Is upgrading to .NET4.5 the only way because I see System.Net.ServicePointManager.SecurityProtocol (https://msdn.microsoft.com/en-us/library/system.net.securityprotocoltype(v=vs.110).aspx) supports TLS1.1 and 1.2.


Related post: https://developer.salesforce.com/forums/ForumsMain?id=906F0000000BMX0IAO
There is documenation out there which suggests that SF supports CMIS. Unfortunately I can't seem to find anything which gives me details or details (e.g. CMIS wsdl, etc etc) for pointing and connecting my CMIS browser to SF or SF Files.

Can anyone validate, clarify or point me in the right direction?
It has been a few years since I've worked on Salesfoce. But I'm back for more! I was pocking around looking for a new sparkly IDE that might be waiting for me and I'm left with a feeling of confusion. What is going on? I get that Salesforce has/is working hard on the tooling api but who has a solid IDE solution that has professional support and sparkly toys? I know I know, I can just use the Eclipse plugin but you know, its not sparkly.

Cloud9 looks like the perfect solution for salesforce developers. The two cloud geeks are already working together with Heroku so why don't they have a OOTB Cloud9 solution for Salesforce.com development?

Has anyone tried to hook up a salesforce org with Cloud9? If not someone should make that happen. Or maybe I should have a go at it.
I looked at BrainEngine but the sign up page gives an azure 403, for that last week. It didn’t look like BrainEngine had more than one guy supporting it, and not open source. Maybe I’m overlooking something?

Any up dates on whats going on would be helpful.
I started to use BrainEngine Cloud studio and was trying the online service until it's unavailable for few days now.
I tried to contact BrainEngine but had no response.
Has someone any news from BrainEngine guys ?