• Lee Goldin
  • 0 Points
  • Member since 2014
  • Salesforce Manager
  • Nonprofit Finance Fund

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 1

Three or four days ago, I started experiencing difficulties logging into Salesforce from Linux (Ubuntu).  My machine is dual-booted with Windows Vista, which was not having any problems logging in.

Firefox 3.5.5, Chrome Beta and Opera 10.00 all reflect the same problem, which originally led me to believe that maybe there was something in a recent Linux update (however unlikely) that caused the conflict.  I couldn't find anything out of the ordinary as I was able to navigate all other sites just fine.  The only sites I had any problems with at all were the ones on the Salesforce domains (i.e. ideas.salesforce.com, login.salesforce.com, developer.salesforce.com, www.salesforce.com, etc.).  When I would go to https://login.salesforce.com, it would just spin forever and never resolve.  I am able to ping these subdomains just fine and lynx (text browser) doesn't appear to have the issue so much.

Today, I tried clearing all cache and cookies from the three browsers and tried again.  I was able to access the https://login.salesforce.com page once in each browser, but when I put my credentials in, it would never actually redirect me to my org.  I tried this with multiple orgs with the same result (clearing cache and cookies before each attempt).  If I fail to clear the cache and cookies and try to load the login page a second time, it will not resolve.

To further compound this oddity, I was able to successfully login to a couple orgs by explicitly specifying the node in the login URL (i.e. https://na3.salesforce.com).  I have been playing around with the cookies that are created during these sessions and the problem seems to reside in the "salesforce.com" domain set of cookies.  Each subdomain has its own set of cookies (i.e. these community boards store cookies under the "community.salesforce.com" label) which don't appear to be the root of the problem.


The only way I am able to login and make this post was if I keep the cookies window open (I'm using FF at the moment) and delete the "salesforce.com" folder whenever it popped up.  The "community.salesforce.com" folder remains and doesn't appear to be causing any harm from what I've noticed so far.  In Ubuntu, I am only able to get as far as creating this message.  In order to post it, I've had to switch to Vista, paste what I wrote in Ubuntu and press the Post button from here.  Ubuntu would not complete the posting transaction.

This still may be some obscure bug in my own configuration, but I figured I'd throw it out there to see if anyone else was experiencing similar symptoms.