• Mohammad Anis
  • 55 Points
  • Member since 2014

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
  • 13
I am trying to access the test.png file from my static resource into the .css of a aura component.

Working CSS: background:url('/resource/158765027200/test'); //resource path achieved using {!$Resource.test} in .cmp

Non-Working CSS: background:url('/resource/test');

Issue with the working CSS is that the static resource code is dynamic in nature and hence will vary from one salesforce instance to another, making this code non-ideal for deployment to other instances of salesforce.

Can anyone help me with this issue or any resolution. Thanks!
I have created a "Contact" form to create a contact with bare required fields and to do so I am using LightningRecordEditForm and the "AccountId" - lookup field is working fine in Lightning view, however using the same component in Salesforce1. It is not working.

I have already found a known Issue and Salesforce Documentation for this behaviour - KnownIssue Link: https://success.salesforce.com/ideaView?id=08730000000Dom1AAC
Salesforce Documentation: "The lookup type is supported in Lightning Experience only. When used in the mobile app, the lookup type is rendered as an input text field. Dependent lookups are not supported."

I am courious to know If someone has faced this issue and worked on this using any WORKAROUND.  Thanks in advance!
I am still struggling with the Einstein Analytics and Discovery Insights Specialist Superbadge (https://trailhead.salesforce.com/en/content/learn/superbadges/superbadge_analytics_insights_specialist?trailmix_creator_id=briankessler&trailmix_id=getting-started-with-analytics), step 2.

Finally my chart is displaying and my toggle switches are displaying, but the toggles are not functioning as expected.

When I select any of the three risks (e.g. "Medium Risk") the chart disappears and is replaced with a a message:
Can't display this widget. More Details

When I display more details I see:
This widget can't be displayed because there is a problem with its source step:
The binding 'row(Tenure_Length_1.selection,[0],["min","max"]).asRange ("Tenure")' contains an error: The column name 'min' doesn't exist in the data.

However the following query seems to be working correctly:
beattieSubscribers = load "Beattie_Subs";
tenuredSubscribers = filter beattieSubscribers by{{row(Tenure_Length_1.selection,[0],["min","max"]).asRange ("Tenure")}};
churnedSubscribers = filter tenuredSubscribers by 'Churn' == "Yes";
groupedSubscribers = group tenuredSubscribers by all full, churnedSubscribers by all;
churnRate = foreach groupedSubscribers generate (count(churnedSubscribers) / count(tenuredSubscribers))*100 as 'churnRate';",

What do I need to do to make the toggles work correctly?
Hi Developers,
I have a issue with [sf:deploy] 560. applications/standard__Content.app -- Error: Property 'tab' not valid in version 43.0

<?xml version="1.0" encoding="UTF-8"?>
<CustomTab xmlns="http://soap.sforce.com/2006/04/metadata">
<motif>Custom26: Flag</motif>

Please suggest me on this.
Does anyone know how to get the inputfield for a reference field/lookup working on Salesforce1.

Ive built a custom componet with a recordEditform that is launched from an object action button and shows the lookups correctly. But in Salesforce1 it shows just a input text fields. 
Challenge Requirements:
Create a flow:
Name: New Lead
Type: Screen Flow
In the flow, add a screen with these required screen fields.
Last Name
Company Name
In the flow, create a lead record.
Use the screen fields to set the lead’s Last Name and Company.
Store the lead’s ID in a Text variable called leadId.
In the flow, add another screen with a Lightning component screen field.
Name the field Upload_File
Choose the forceContent:fileUpload Lightning component.
Use the leadId variable to set the component's Related Record ID attribute.
Activate the New Lead flow.
Create a new Lightning page:
Type: Home page
Label: Process Automation Home
In Process Automation Home, add a Flow component that references the New Lead flow.
Activate the page and set it as the default Home page.

I did all of this and yet it says it cannot detect force content?User-added image
User-added image
The controller action marks the item attribute as packed, updates the item value provider and disables the button is the task given in Trail head.

I have written the below controller to perform the action:

    packItem : function(component, event, helper) {

This is setting the Packed__c to true but I am not passing the challenge.

but when I googled, below code was suggested:

    packItem : function(component, event, helper) {
        var a = component.get("v.item",true);
         a.Packed__c = true;

But this code is not setting Packed__c to true. Please let me know the difference between two controller.

Trail head challenge:

I have a Custom lookup page that is called in a VF page. I tried using the following code but only the standard lookup opens in the mobile. But in the Browser I am getting the correct Custom Look up page.I have also enabled mobile access to the Page
<apex:form >
            <apex:inputField value="{!Event.Event_Id__c}"/>

Kindly Guide me.

Thanks and Regards,

What is Test.startTest() and Test.stopTest() methods?



What is the importance of these methods in test Class?


What will happen internally if these methods are used.

In my apex code, system.now() returns the current Datetime based on a GMT calendar. My aim is to get the date time value in my local time zone.Since we have day light saving, I didn't think  about manipulating the time difference.


I would appreciate your suggestions.


Under personal information, I have set the time zone as "Time Zone(GMT-05:00) Eastern Daylight Time (America/New_York)".





<meta http-equiv="Content-Type" content="text/html; charset=utf-8"><meta name="ProgId" content="Word.Document"><meta name="Generator" content="Microsoft Word 11"><meta name="Originator" content="Microsoft Word 11">


Is there any way to get current date and time as per the logged in user time zone in apex?

I used System.now(), but its returning as per GMT time zone. I need it as per the user time zone.Like if logged in use time zone is Singapore time zone then it should return current time and date  as per the Singapore time zone which is GMT+8,  not as per the GMT time zone. 

Thanks and Regards,

Rajan Jasuja